Instalar el Service Pack (revisión)

Microsoft SQL Server 2005 Service Pack 2
Instalar el Service Pack (revisión)

Puede actualizar cualquier componente de SQL Server 2005 instalado al SP2 de SQL Server 2005. Si el nivel de versión de un componente de SQL Server 2005 existente es superior al nivel de versión del SP2, el programa de instalación del SP2 lo excluirá de la actualización.

Al instalar el SP2 de SQL Server 2005, deben tenerse en cuenta las consideraciones siguientes:

  • Una vez aplicado el SP2 de SQL Server 2005, éste no podrá quitarse sin desinstalar todo el producto.

  • Todas las características que pertenezcan a una instancia de SQL Server deben actualizarse al mismo tiempo. Por ejemplo, si actualiza Servicios de bases de datos, también debe actualizar Analysis Services si está instalado en la misma instancia de SQL Server. Si un componente o una instancia del árbol de características no está seleccionado, dicho componente o instancia no se actualizará al SP2 de SQL Server 2005.

  • Utilice la autenticación de Windows siempre que sea posible.

  • Cuando se utiliza la Autenticación de SQL Server, la contraseña proporcionada para el inicio de sesión de sa no puede contener comillas dobles. Si la contraseña contiene comillas dobles, al aplicar el SP2 de SQL Server 2005 utilice la Autenticación de Windows en lugar de la Autenticación de SQL Server, o bien cambie la contraseña del inicio de sesión de sa antes de ejecutar el programa de instalación del SP2.

  • Cuando se actualiza una instancia de Reporting Services, el programa de instalación se conecta al servidor de informes para actualizar la base de datos del servidor de informes. Si la cuenta de Windows del usuario que ejecuta el programa de instalación no es miembro de la función fija de servidor sysadmin en el servidor de informes, debe proporcionar un inicio de sesión y una contraseña de SQL Server que tengan suficientes privilegios. Para hacerlo, seleccione la instancia de Reporting Services en el cuadro de diálogo Modo de autenticación, especifique las credenciales de una cuenta que tenga los privilegios necesarios y haga clic en Aceptar.

  • De forma predeterminada, los archivos de registro del programa de instalación del SP2 de SQL Server 2005 se guardan en %Archivos de programa%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Documentación adicional

Dispone de la siguiente documentación adicional para el SP2 de SQL Server 2005:

  • Archivo Léame del SP2 de SQL Server 2005 SP2.

  • Este artículo de Microsoft Knowledge Base acerca del SP2 de SQL Server 2005.

Requisitos de espacio en disco

Para descargar e instalar el SP2 de SQL Server 2005, el equipo debe tener al menos 1,9 GB de espacio disponible en disco. En la tabla siguiente se describe el uso del espacio en disco:

Uso del disco (MB) | Ubicación | Tipo
50 | Directorio de instalación de SQL Server 2005 | Permanente
1,000 | Unidad del sistema | Permanente
600 | Directorio Temp | Temporal
250 | Ubicación de descarga | Temporal

Una vez finalizada la instalación, puede quitar el paquete de descarga de 250 MB del equipo. El uso de espacio en disco permanente del SP2 de SQL Server 2005 una vez finalizada la instalación es de aproximadamente 1 GB.

Información general sobre la instalación

En esta sección se ofrece información general de la instalación del SP2 de SQL Server 2005, incluyendo cómo hacer lo siguiente:

  • Preparar la instalación del SP2 de SQL Server 2005

  • Instalar el SP2 de SQL Server 2005

  • Reiniciar los servicios y las aplicaciones

Preparar la instalación del SP2 de SQL Server 2005

Antes de instalar el SP2 de SQL Server 2005, debe hacer lo siguiente:

  • Haga una copia de seguridad de las bases de datos de SQL Server 2005. Antes de instalar el SP2 de SQL Server 2005, haga una copia de seguridad de las bases de datos master, msdb y model. Al instalar el SP2 de SQL Server 2005, estas bases de datos se modifican y se vuelven incompatibles con versiones anteriores al SP2 de SQL Server 2005. Las copias de seguridad de estas bases de datos son necesarias si decide volver a instalar SQL Server 2005 sin el SP2.

    Asimismo, es una medida prudente hacer una copia de seguridad de las bases de datos de usuario.

Importante:
Al aplicar el SP2 a las instancias de SQL Server que participan en una topología de réplica, debe hacer una copia de seguridad de las bases de datos replicadas junto con las bases de datos del sistema antes de aplicar el SP2.

  • Haga una copia de seguridad de las bases de datos de Analysis Services, el archivo de configuración y el repositorio. Antes de actualizar una instancia de Analysis Services al SP2, debe hacer una copia de seguridad de lo siguiente:

    • Bases de datos de Analysis Services. De forma predeterminada, se instalan en C:\Archivos de programa\Microsoft SQL Server\MSSQL.1\OLAP\Data\.

    • Valor de configuración de Analysis Server en el archivo de configuración msmdsrv.ini. De forma predeterminada, éste se encuentra en el directorio C:\Archivos de programa\Microsoft SQL Server\MSSQL.1\OLAP\Config\.

    • (Opcional) La base de datos que contiene el repositorio de Analysis Services. Este paso sólo es necesario si se ha configurado Analysis Server para trabajar con la biblioteca de objetos de ayuda para la toma de decisiones (DSO).

Nota:
Si no realiza ninguna copia de seguridad de las bases de datos, del archivo de configuración y del repositorio de Analysis Services, no podrá revertir una instancia actualizada de Analysis Services a la versión anterior.

  • Compruebe que las bases de datos del sistema tienen espacio libre suficiente. Si no se selecciona la opción de crecimiento automático para las bases de datos del sistema master y msdb, dichas bases de datos deberán tener como mínimo 500 KB de espacio libre cada una. Para comprobar que las bases de datos tienen suficiente espacio, ejecute el procedimiento almacenado del sistema sp_spaceused en las bases de datos master y msdb. Si el espacio sin asignar de alguna de las bases de datos es inferior a 500 KB, aumente el tamaño de la base de datos. Para obtener más información, vea "Expandir una base de datos" en los Libros en pantalla de SQL Server.

  • Compruebe que las cuentas de servicio de SQL Server 2005 no están deshabilitadas y se pueden iniciar. Pueden producirse errores en el programa de instalación si el tipo de inicio de los servicios MSSQLServer, MSSQLServerOLAPService y ReportServer está establecido en Deshabilitado.

    Para comprobar las cuentas de servicio y habilitarlas:

    1. En el Panel de control, haga doble clic en Herramientas administrativas y, después, haga doble clic en Servicios.

    2. Localice el servicio MSSQLServer en la lista y anote el valor de Tipo de inicio.

    3. Si el valor de Tipo de inicio es Deshabilitado, haga doble clic en el nombre del servicio y cambie Tipo de inicio a Manual o Automático.

    4. Repita los pasos 2 y 3 para los servicios MSSQLServerOLAPService y ReportServer y, a continuación, haga clic en Aceptar.

    5. Repita el proceso para todas las instancias de SQL Server instaladas.

  • Detenga los servicios y aplicaciones. Detenga todas las aplicaciones y servicios que establecen conexiones con las instancias de SQL Server que se están actualizando, incluidos SQL Server Management Studio, Business Intelligence Development Studio, Panel de control y Agregar o quitar programas, antes de instalar el SP2 de SQL Server 2005.

Nota:
Los servicios no pueden detenerse en un entorno de clúster de conmutación por error. Para obtener más información, vea la sección sobre instalación de clúster de conmutación por error más adelante en este tema.

  • Para eliminar el requisito de reinicio del equipo tras la instalación del SP2, el programa de instalación mostrará una lista de los procesos que están bloqueando los archivos. Si el programa de instalación del SP2 debe finalizar un servicio durante el proceso de instalación, lo reiniciará una vez que concluya la instalación.

  • Si el programa de instalación determina que hay archivos bloqueados durante la instalación, puede que sea necesario reiniciar el equipo una vez completada la instalación del SP2. Si es necesario, el programa de instalación le indicará que reinicie el equipo.

Instalar el SP2 de SQL Server 2005

En esta sección se describe el proceso de instalación durante la ejecución del programa de instalación del SP2 de SQL Server 2005.

Importante:
El programa de instalación del SP2 de SQL Server 2005 debe ejecutarse con una cuenta que tenga privilegios de administrador en el equipo en el que se instalará el SP2.

Iniciar el programa de instalación del SP2 de SQL Server 2005

Para instalar el SP2 de SQL Server 2005, ejecute el archivo del paquete autoextraíble SQLServer2005SP2-KB921896-PPP-LLL.exe, donde PPP indica la plataforma específica y LLL representa un designador que varía según el idioma.

Nota:
Para aplicar el SP2 a los componentes de SQL Server 2005 que forman parte de un clúster de conmutación por error, vea la sección sobre la instalación de clúster de conmutación por error. Para ejecutar el programa de instalación del SP2 en modo desatendido, vea Instalar desde el símbolo del sistema (revisión).

Instalación de clúster de conmutación por error

La siguiente información sólo es válida para los componentes de SQL Server 2005 que forman parte de un clúster de conmutación por error.

Para instalar el Service Pack en un clúster de conmutación por error:

  1. Asegúrese de que el SP2 de SQL Server 2005 se instalará en todos los nodos de una instancia de clúster de conmutación por error; para ello, compruebe que el Programador de tareas se está ejecutando en todos los nodos pasivos de la instancia de clúster de conmutación por error.

  2. Si se agregaron recursos que tienen dependencias en los recursos de SQL Server, dichas dependencias deben quitarse o dejarse sin conexión antes de instalar el SP2 de SQL Server 2005. Si no quita las dependencias, la instalación del SP2 dejará dichos recursos sin conexión.

    Nota:
    Cuando un recurso agrupado se deja sin conexión, el servicio de clúster también deja sin conexión todos los recursos dependientes.

  3. Ejecute el archivo del paquete ejecutable del SP2 de SQL Server 2005 desde el nodo activo que sea propietario del grupo que contiene la instancia de clúster de conmutación por error que desea actualizar. Con ello se instalan los archivos del Service Pack en todos los nodos del clúster de conmutación por error. El SP2 no se puede instalar desde ningún nodo pasivo del clúster de conmutación por error.

  4. En la página de selección de características del Asistente para la instalación del SP2 de SQL Server 2005, seleccione la instancia de clúster de conmutación por error que desea actualizar. El programa de instalación le solicitará las credenciales de inicio de sesión que se utilizan para conectarse a los otros nodos del clúster.

    Nota:
    Mantenga todos los nodos del clúster en línea durante la instalación. De este modo se garantiza que la actualización se aplique a cada uno de los nodos del clúster.

  5. Si en el paso 1 ha quitado las dependencias o ha dejado los recursos sin conexión, restaure las dependencias o ponga los recursos en línea.

    Nota:
    El programa de instalación puede necesitar que se reinicien los nodos del clúster de conmutación por error. Este reinicio sustituye los archivos que estaban en uso durante la instalación.
Volver a generar un nodo de clúster de conmutación por error del SP2 de SQL Server 2005

Si es necesario volver a generar un nodo del clúster de conmutación por error tras aplicar el SP2, lleve a cabo los pasos que se indican a continuación:

  1. Vuelva a generar el nodo en el clúster de conmutación por error. Para obtener más información acerca de cómo volver a generar un nodo, vea "Cómo recuperarse de un error en un clúster de conmutación por error en el escenario 1" en los Libros en pantalla de SQL Server.

  2. Ejecute el programa de instalación original de SQL Server 2005 para restaurar el nodo al clúster de conmutación por error.

  3. Ejecute el programa de instalación del SP2 de SQL Server 2005 en el nodo que ha agregado.

Reiniciar los servicios y las aplicaciones

Una vez finalizada la instalación, es posible que se le solicite que reinicie el equipo. Una vez reiniciado el sistema, o cuando el programa de instalación se complete sin solicitar el reinicio, utilice el nodo Servicios del Panel de control para reiniciar los servicios que detuvo antes de aplicar el SP2 de SQL Server 2005.

Esto incluye servicios como Coordinador de transacciones distribuidas y Microsoft Search, o bien servicios equivalentes específicos de las instancias. Reinicie las aplicaciones que cerró antes de ejecutar el programa de instalación del SP2 de SQL Server 2005. Es recomendable también hacer otra copia de seguridad de las bases de datos master, msdb y model actualizadas justo después de que finalice correctamente la instalación.


Instalar desde el símbolo del sistema (revisión)

Instalar desde el símbolo del sistema (revisión)

Antes de continuar, revise las consideraciones acerca de la instalación en Instalar el Service Pack (revisión).

A continuación se indican los modificadores del símbolo del sistema compatibles con la instalación desatendida del SP2 de SQL Server 2005. Pruebe y modifique las secuencias de comandos de instalación para adaptarlas a las necesidades de su organización.

Importante:
Cuando sea posible, proporcione credenciales de seguridad en tiempo de ejecución. Si debe almacenar credenciales en un archivo de secuencias de comandos, proteja el archivo para evitar el acceso no autorizado.

Modificador

Descripción

/?

Muestra la ayuda del símbolo del sistema para la instalación desatendida.

/allinstances

Aplica el SP2 de SQL Server 2005 a todas las instancias de SQL Server 2005 y a todos los componentes compartidos que no reconocen instancias de SQL Server 2005.

/instancename=nombreDeInstancia

Aplica el SP2 de SQL Server 2005 a una instancia de SQL Server 2005 denominada nombreDeInstancia y a todos los componentes compartidos que no reconocen instancias de SQL Server 2005.

/password=contraseña

Contraseña de cuenta de usuario para conectarse a un nodo de clúster de conmutación por error remoto.

/quiet

Ejecuta el programa de instalación del SP2 de SQL Server 2005 en modo desatendido.

/reportonly

Sólo se ejecuta la sección de descubrimiento y enumeración del programa de instalación, y se muestra un informe en el que se enumeran las instancias locales y los componentes de SQL Server 2005.

Nota:
Si se utiliza este modificador, el SP2 de SQL Server 2005 no se aplica.

/rsupgradedatabaseaccount=nombreDeCuentaRS

Especifica una cuenta con permisos para modificar el esquema en una base de datos del servidor de informes cuando se utiliza la Autenticación de SQL Server. Este parámetro se utiliza cuando se actualiza una instancia de Reporting Services que incluye una base de datos del servidor de informes que requiere un inicio de sesión de SQL Server.

/rsupgradepassword=contraseñaRS

Especifica la contraseña para una cuenta que tiene permisos para modificar el esquema en una base de datos del servidor de informes remoto. Este parámetro se utiliza cuando se actualiza una instancia de Reporting Services que incluye una base de datos del servidor de informes remoto.

/rsupgradedatabase

Utilice el modificador /rsupgradedatabase=0 para evitar que la base de datos de Reporting Services se actualice.

/sapwd=contraseñaDeInicioDeSesiónSa

Pasa la contraseña de autenticación de SQL Server para que el inicio de sesión de sa ejecute secuencias de comandos.

Nota:
No deben utilizarse caracteres de escape para /sapwd. En caso de utilizarlos, el programa de instalación dará un error.

/user=dominio\nombreDeUsuario

Cuenta de usuario para conectarse a un nodo de clúster de conmutación por error remoto.


Aviso de derechos de autor (revisión)

Aviso de derechos de autor (revisión)

Esta documentación, incluidos los ejemplos de aplicaciones que se incluyen en la misma, se proporciona únicamente con fines informativos y sin ninguna garantía expresa o implícita. La información que se proporciona en esta documentación, incluidas las direcciones URL y otras referencias a sitios Web de Internet, está sujeta a modificaciones sin previo aviso. El usuario asume todos los riesgos derivados del uso de esta documentación.

El objetivo principal de los ejemplos que se incluyen en esta documentación es ilustrar un concepto o un uso razonable de una instrucción o cláusula determinada. La mayoría de los ejemplos no incluyen todo el código que debería tener un sistema totalmente en producción, puesto que se ha eliminado parte de la validación de datos y el control de errores habituales para resaltar en el ejemplo un determinado concepto o instrucción. No hay soporte técnico disponible para estos ejemplos ni para el código fuente incluido.

A menos que se indique lo contrario, los nombres de compañías, organizaciones, productos, nombres de dominio, direcciones de correo electrónico, personas, lugares y acontecimientos de ejemplo aquí mencionados son ficticios, y no se pretende indicar ni se debe deducir ninguna asociación con ninguna compañía, organización, producto, nombre de dominio, dirección de correo electrónico, persona, lugar o acontecimiento real. Es responsabilidad del usuario el cumplimiento de todas las leyes de derechos de autor aplicables. Sin que se limiten los derechos de autor, ninguna parte de esta documentación puede ser reproducida, almacenada o introducida en un sistema de recuperación, o transmitida de forma alguna, ni por ningún medio (ya sea electrónico, mecánico, por fotocopia, grabación o de otra manera) con ningún propósito, sin la autorización expresa y por escrito de Microsoft Corporation.

Microsoft puede tener patentes, solicitudes de patentes, marcas, derechos de autor y otros derechos de propiedad intelectual sobre la materia objeto de esta documentación. La entrega de esta documentación no le otorga ninguna licencia sobre dichas patentes, marcas, derechos de autor u otros derechos de propiedad intelectual, a menos que así se prevea en un contrato por escrito de licencia de Microsoft.

© 2006 Microsoft Corporation. Reservados todos los derechos.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System y WinFX son marcas registradas o marcas comerciales de Microsoft Corporation en Estados Unidos y otros países.

SAP NetWeaver es marca registrada de SAP AG en Alemania y otros países.

Las demás marcas comerciales pertenecen a sus respectivos propietarios.

Directiva de documentación para soporte y actualización de SQL Server 2005

El contenido que aparece en la documentación de SQL Server sólo se publica tras haberlo comprobado suficientemente. La documentación del producto (Libros en pantalla de SQL Server, archivos léame, documentos de problemas conocidos y artículos de Knowledge Base) contiene la suficiente información acerca de las características de SQL Server y su funcionalidad para que resulte segura para el uso general de todos los clientes. Esta directiva se aplica a toda la documentación de SQL Server, incluidos los archivos léame de las distintas versiones y los Service Pack. Un archivo léame se considera una extensión de los Libros en pantalla.

En algunos casos, los usuarios no utilizan directamente una característica específica, por lo que no se documenta. A menos que una característica se explique en la documentación de SQL Server publicada por Microsoft, los servicios de soporte al cliente (CSS) de Microsoft no ofrecen soporte para el contenido de libros o sitios Web de terceros y este contenido no debe utilizarse en aplicaciones o bases de datos de producción.

Los clientes no deben utilizar API no documentadas, incluyendo, entre otros: procedimientos almacenados, procedimientos almacenados extendidos, funciones, vistas, tablas, columnas, propiedades o metadatos. Los servicios de soporte al cliente de Microsoft no prestarán soporte a aquellas bases de datos o aplicaciones que presenten o utilicen puntos de entrada no documentados.

No se garantizan las actualizaciones de servidor y base de datos a versiones futuras de SQL Server para aplicaciones y bases de datos que presenten o utilicen puntos de entrada no documentados. El uso de características y funciones de SQL Server debe limitarse a las incluidas en la documentación de Microsoft SQL Server. Si una característica no aparece documentada en la documentación de Microsoft SQL Server, no constituye una parte de SQL Server susceptible de recibir soporte técnico.


Interfaz de usuario de instalación (revisión)

Interfaz de usuario de instalación (revisión)

En los siguientes temas se ofrece información adicional sobre las decisiones del proceso de instalación del SP2 de SQL Server 2005. Para ver un tema de la Ayuda, haga clic en el vínculo correspondiente:

Términos de licencia (revisión)

Selección de características (revisión)

Modo de autenticación (revisión)

Autenticación remota (revisión)

Configuración de informes de errores y uso (revisión)

Procesos en ejecución (revisión)

Preparado para instalar (revisión)

Progreso de la instalación (revisión)

Instalación completada (revisión)

Información adicional (revisión)


Términos de licencia (revisión)

Términos de licencia (revisión)
Interfaz de usuario de instalación (revisión) >

Use la página Términos de licencia (revisión) del Asistente para la instalación del SP2 de para aceptar los términos de la licencia de esta versión.

Opciones

Para continuar con la instalación del SP2 de SQL Server 2005, debe hacer clic en el botón de opción que indica que acepta los términos de la licencia del SP2 de SQL Server 2005. Después, puede hacer clic en Siguiente para continuar.

Use el botón Imprimir para imprimir una copia de los términos de licencia para esta versión. Para finalizar el programa de instalación del SP2 de SQL Server 2005, haga clic en Cancelar.


Selección de características (revisión)

Selección de características (revisión)
Interfaz de usuario de instalación (revisión) >

Use la página Selección de características (revisión) del Asistente para la instalación del SP2 de para seleccionar los componentes y características de SQL Server que desea actualizar.

Opciones

Haga clic en el nombre de una característica en el panel de la izquierda para ver los detalles de idioma, sistema operativo, edición y estado.

Para actualizar un componente o característica, active la casilla de verificación situada junto al nombre de la característica. Para excluir un componente o característica de esta actualización, desactive la casilla de verificación situada junto al nombre de la característica.

Se pueden actualizar varias instancias de SQL Server 2005 en un equipo individual en momentos diferentes, pero todos los componentes de una instancia de SQL Server deben actualizarse al mismo tiempo. Todos los componentes compartidos, como los componentes de la estación de trabajo, Analizador de MSXML, SQLXML, componentes de Compatibilidad con versiones anteriores y Escritor de VSS, deben actualizarse al SP2 de SQL Server 2005.

Si un componente no puede actualizarse, en el panel Detalles aparecerá una explicación.


Modo de autenticación (revisión)

Modo de autenticación (revisión)
Interfaz de usuario de instalación (revisión) >

Utilice la página Modo de autenticación (revisión) del Asistente para la instalación del SP2 de para proporcionar información de autenticación e instancias que el programa de instalación usará para conectarse a las instancias de SQL Server que desee actualizar.

Opciones

Si el modo de autenticación, nombre de usuario y contraseña son los mismos para todos los componentes o instancias que se van a actualizar, active la casilla de verificación Aplicar selección a todas las instancias. Si selecciona esta opción, la lista desplegable Nombre de instancia se deshabilitará. Indique el tipo de autenticación, el nombre de usuario y la información de contraseña y, a continuación, haga clic en Probar para comprobar las credenciales.

Si el modo de autenticación, el nombre de usuario y la contraseña no son los mismos para todos los componentes que se van a actualizar, indique el nombre de instancia, el tipo de autenticación, el nombre de usuario y la información de contraseña para cada uno de los componentes o instancias que se van a actualizar y, a continuación, haga clic en Probar para comprobar las credenciales.

Puesto que las credenciales se comprueban para cada componente o cada instancia de SQL Server, la tabla de estado se llenará con los resultados. Cuando todos los componentes figuren en la tabla y todos tengan el estado “Correcto", haga clic en Siguiente para continuar. Es preciso solucionar todos los problemas de autenticación antes de continuar.

Si se producen errores en la autenticación, actualice la información del componente y vuelva a intentar la prueba de comprobación. Cuando todos los componentes figuren en la tabla y todos tengan el estado "Correcto", haga clic en Siguiente para continuar.


Autenticación remota (revisión)

Autenticación remota (revisión)
Interfaz de usuario de instalación (revisión) >

Use la página Autenticación remota (revisión) del Asistente para la instalación del SP2 de para proporcionar información de inicio de sesión remota para las instancias de clúster de conmutación por error de SQL Server que desea actualizar.

Opciones

Nombre de usuario

Si el campo de inicio de sesión no está rellenado previamente, especifique un nombre de usuario que sea una cuenta de administrador válida para todos los nodos del clúster de conmutación por error.

Contraseña

Especifique una contraseña para la cuenta de administrador seleccionada.

Dominio

Especifique el nombre de dominio para la cuenta de administrador seleccionada.


Configuración de informes de errores y uso (revisión)

Configuración de informes de errores y uso (revisión)
Interfaz de usuario de instalación (revisión) >

Utilice la página Configuración de informes de errores y uso (revisión) del Asistente para la instalación del SP2 de para habilitar la funcionalidad de creación de informes de errores y uso de características para SQL Server 2005.

Opciones

El SP2 de SQL Server incluye una opción para configurar SQL Server para que envíe de forma automática informes de errores de servicio graves a Microsoft o al servidor de informes de errores corporativo. Puede deshabilitar una de estas opciones o ambas desactivando las casillas de verificación de esta página. Microsoft usa los informes de errores para mejorar la funcionalidad de SQL Server y trata como confidenciales todos los informes de errores y datos de uso de características.

Informes de errores

Si habilita la característica Informes de errores, SQL Server se configurará para enviar automáticamente un informe a Microsoft si se produce un error grave en alguno de los siguientes componentes de SQL Server:

  • Database Engine (Motor de base de datos)

  • Agente SQL Server

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Réplica

Microsoft utiliza los informes de errores para mejorar la funcionalidad de SQL Server y trata toda la información recibida de forma confidencial.

La información sobre los errores se envía a través de una conexión segura (https) a Microsoft, donde se almacena con limitación de acceso. Asimismo, puede enviar los informes de errores a su propio servidor de informes de errores corporativo. Para obtener más información sobre la configuración de un servidor de informes de errores corporativo, vea el sitio Web de Microsoft sobre creación de informes de errores corporativos (puede estar en inglés).

Los informes de errores contienen la información siguiente:

  • El estado de SQL Server cuando se produjo el problema.

  • La versión del sistema operativo e información del hardware del sistema.

  • El identificador del producto digital, que no se utiliza para identificar la licencia.

  • La dirección IP de red del equipo o el servidor proxy.

  • Información de la memoria o de los archivos asociados al proceso que ha causado el error.

Microsoft no pretende obtener de forma intencionada archivos ni información sobre el nombre, la dirección postal, la dirección de correo electrónico o información personal de otro tipo. Sin embargo, el informe de errores puede contener información personal procedente de la memoria o de los archivos asociados al proceso que ha causado el error. A pesar de que este tipo de información podría utilizarse para determinar la identidad del usuario, Microsoft no utiliza la información con este propósito.

Para obtener más información acerca de la directiva de recopilación de datos y privacidad de , vea la declaración de privacidad de SQL Server 2005 (puede estar en inglés).

Si habilita Informes de errores y se produce un error grave, puede que vea una respuesta procedente de Microsoft en el registro de eventos de Windows, dirigiéndole a un artículo de Microsoft Knowledge Base que trata sobre el error específico.

Para deshabilitar Informes de errores o Informes de uso de características en todas las instancias de SQL Server y sus componentes una vez finalizada la instalación, vaya al cuadro de diálogo Configuración de informes de errores y uso (Inicio : Todos los programas : Microsoft SQL Server 2005 : Herramientas de configuración : Informes de uso y errores de SQL Server) y desactive las casillas de verificación de Enviar informes de uso de características de todos los componentes e instancias de SQL Server 2005 a Microsoft. Si Informes de errores está habilitado para varios componentes de SQL Server (Database Engine (Motor de base de datos), Analysis Server, servidor de informes y componentes compartidos), puede deshabilitar Informes de errores para cada una de las instancias de un componente individual. También puede deshabilitar Informes de errores para los componentes compartidos, que figuran en la lista como Otros.

Uso de características

Si habilita la creación de informes de uso de características, SQL Server se configurará para enviar periódicamente un informe a Microsoft. Los informes incluirán información sobre la configuración de hardware y sobre cómo utilizar el software y los servicios de SQL Server 2005. Microsoft utilizará los datos de uso de características para mejorar los componentes de SQL Server. Los componentes de SQL Server 2005 supervisados por esta característica son los siguientes:

  • Database Engine (Motor de base de datos)

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Réplica

  • Business Intelligence Development Studio

La información sobre el uso de características se enviará a Microsoft, donde se almacenará con limitación de acceso.

Para deshabilitar la creación de informes de uso de características una vez finalizada la instalación, utilice la herramienta Informes de errores y uso de SQL Server en el menú Herramientas de configuración de SQL Server 2005.

La información se recopila una vez al día para todas las instancias de SQL Server habilitadas. De forma predeterminada, la hora de recopilación será a medianoche para reducir al mínimo la carga del servidor. Si desea cambiar la hora de recopilación, puede editar manualmente la clave del Registro que controla la hora de recopilación. Cada instancia de SQL Server tiene su propia clave del Registro. El siguiente ejemplo corresponde a la primera instancia de SQL Server instalada en el servidor (MSSQL.1):

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

El valor de esta clave del Registro contiene la hora de la recopilación que se va a ejecutar en forma de número de minutos a partir de 00:00 (medianoche). Por ejemplo, un valor de 60 iniciaría la recopilación a la 1:00 a.m., y un valor de 1200, a las 8:00 p.m.


Procesos en ejecución (revisión)

Procesos en ejecución (revisión)
Interfaz de usuario de instalación (revisión) >

Para evitar reiniciar Windows después de instalar el SP2 de , use la página Procesos en ejecución (revisión) del Asistente para la instalación del SP2 de SQL Server 2005 con el fin de identificar los procesos que están bloqueando los archivos requeridos por el programa de instalación del SP2 de SQL Server 2005.

Detenga todas las aplicaciones y servicios que establecen conexiones con las instancias de SQL Server que se están actualizando. Esto incluye detener SQL Server Management Studio y Business Intelligence Development Studio, y cerrar el Panel de control y Agregar o quitar programas antes de instalar el SP2 de SQL Server 2005.

  • Para eliminar el requisito de reinicio del equipo tras la instalación del SP2, el programa de instalación mostrará una lista de los procesos que están bloqueando los archivos. Si el programa de instalación del SP2 debe finalizar un servicio durante el proceso de instalación, lo reiniciará una vez que concluya la instalación.

  • Si el programa de instalación determina que hay archivos bloqueados durante el proceso de instalación, puede que sea necesario reiniciar el equipo una vez finalizada la instalación del SP2. Si es necesario, el programa de instalación le indicará que reinicie el equipo.

Opciones

Si el programa de instalación detecta archivos bloqueados, éstos se mostrarán en la tabla. Detenga o finalice los procesos y aplicaciones de la lista y, a continuación, haga clic en Actualizar para volver a ejecutar la comprobación. Haga clic en Detener para finalizar una comprobación que se esté ejecutando. Si no se encuentra ningún archivo bloqueado, la tabla estará vacía.

Cuando se hayan cerrado todos los procesos de bloqueo, haga clic en Siguiente para continuar.

Instalar SP2 de SQL Server 2005 en una instancia de clúster de conmutación por error

Tenga en cuenta la siguiente información para instalar el SP2 de SQL Server 2005 en una instancia de clúster de conmutación por error:

  • No detenga el servicio de clúster antes de ejecutar el programa de instalación del SP2 o mientras se está ejecutando el programa de instalación.

  • No finalice ninguno de los procesos en ejecución antes de ejecutar el programa de instalación del SP2.

  • No desconecte el servicio SQL Server antes de ejecutar el programa de instalación del SP2. El programa de instalación del SP2 detendrá e iniciará el servicio SQL Server.

  • Ejecute el programa de instalación del SP2 en el nodo principal de la instancia de clúster de conmutación por error.

  • Deberá reiniciar todos los nodos de clúster de conmutación por error una vez finalizada la instalación del SP2.

  • La actualización gradual no se admite en SP2.


Preparado para instalar (revisión)

Preparado para instalar (revisión)
Interfaz de usuario de instalación (revisión) >

La página Preparado para instalar (revisión) del Asistente para la instalación del SP2 de indica que el programa de instalación del SP2 de SQL Server 2005 tiene la información necesaria para instalar la actualización.

Opciones

Haga clic en Atrás para revisar o cambiar las opciones de instalación del SP2 de SQL Server 2005. Para continuar, haga clic en Instalar.


Progreso de la instalación (revisión)

Progreso de la instalación (revisión)
Interfaz de usuario de instalación (revisión) >

Use la página Progreso de la instalación (revisión) del Asistente para la instalación del SP2 de para supervisar el programa de instalación mientras aplica el SP2 de SQL Server 2005 a los componentes e instancias de SQL Server.

Opciones

La tabla proporciona el nombre de producto, su nombre de instancia y el estado de la instalación de SQL Server.


Instalación completada (revisión)

Instalación completada (revisión)
Interfaz de usuario de instalación (revisión) >

En la página Instalación completada (revisión) del Asistente para la instalación del SP2 de , se muestra el estado de cada componente que se actualiza al SP2 de SQL Server 2005.

Opciones

Para ver un registro de resumen de la instalación del SP2 de SQL Server 2005, haga clic en Ver resumen. El archivo de registro de resumen se guarda en C:\Archivos de programa\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Para ver la ruta de acceso de un archivo de registro, haga clic en el nombre del componente. Por ejemplo, si hace clic en SQL Server Native Client, en el panel Detalles se mostrará la ruta de acceso al archivo de registro: C:\Archivos de programa\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log.


Información adicional (revisión)

Información adicional (revisión)
Interfaz de usuario de instalación (revisión) >

Actualizado: 12 de diciembre de 2006

The La página Información adicional (revisión) del Asistente para la instalación del SP2 de contiene una casilla de verificación para abrir la herramienta de aprovisionamiento de usuario de SQL Server 2005 para Windows Vista. Use la herramienta de aprovisionamiento para actualizar la lista de usuarios en la función Administrador del sistema para SQL Server.

El Control de cuentas de usuario (UAC), que también se denomina Protección de cuentas de usuario (UAP) o Cuentas de usuario limitado (LUA), es una nueva característica de seguridad de Windows Vista. UAC permite a los usuarios realizar tareas habituales como usuarios no administradores. Las cuentas de usuario que pertenezcan al grupo local de administradores ejecutarán la mayoría de las aplicaciones como si estuvieran usando una cuenta de usuario estándar.

By default, De forma predeterminada, a los usuarios de Windows Vista que pertenezcan al grupo de administradores de Windows no se les conceden automáticamente permisos para conectarse a SQL Server. Asimismo, tampoco se les conceden automáticamente credenciales administrativas. Los miembros de la función Administrador del sistema de SQL Server pueden realizar cualquier actividad en la instancia de SQL Server.

Para permitir a los miembros del grupo de administradores iniciar sesión desde un equipo en el que se ejecute Windows Vista, debe agregar la cuenta de forma explícita a los inicios de sesión de SQL Server.

Opciones

Para actualizar la lista de usuarios en la función Administrador del sistema de SQL Server, use la casilla de verificación para iniciar la herramienta de aprovisionamiento de usuario de SQL Server 2005 para Windows Vista.

Asegúrese de que en el campo Usuario para aprovisionar aparezca el nombreDeDominio\nombreDeUsuario del usuario cuyos permisos se deben actualizar. Seleccione la función que se debe actualizar en la lista de instancias de SQL Server del panel Privilegios disponibles y, a continuación, haga clic en la flecha que señala a la derecha. Para agregar el usuario a todas las funciones disponibles para todas las instancias disponibles de SQL Server, haga doble clic en la flecha correcta.

En el panel derecho aparecerá el nombreDeDominio\nombreDeUsuario del usuario cuyos permisos se actualizarán, así como las instancias de SQL Server y las funciones a las que se agregará el usuario.

Para quitar una función del panel de la derecha, selecciónela y haga clic en la flecha que señala a la izquierda. Para quitar todas las funciones del panel de la derecha, haga clic en la flecha doble que señala a la izquierda. Tenga en cuenta que la funcionalidad de la flecha que señala a la izquierda sólo afecta a los usuarios, funciones y permisos mostrados en la herramienta. La herramienta no dispone de funcionalidad para revocar permisos. Para revocar los permisos de un usuario, un administrador debe actualizar o quitar las credenciales del usuario de forma manual.

Para implementar los cambios una vez completadas las selecciones, haga clic en Aceptar. Para cerrar la herramienta sin realizar cambios, haga clic en Cancelar.

Para obtener acceso a la herramienta de aprovisionamiento de usuario de SQL Server 2005 para Microsoft Vista después de finalizar este programa de instalación, haga clic en el vínculo Agregar nuevo administrador de la herramienta de configuración de superficie de SQL Server 2005 (SQLSAC.exe).

La lista de vínculos de Información adicional (revisión) proporciona vínculos a sitios Web en los que hay información adicional disponible acerca de SQL Server. Estos vínculos incluyen información acerca del soporte técnico del producto, actualizaciones de la documentación y opciones de Update de Microsoft para SQL Server.