安装 Service Pack（修补程序）

Microsoft SQL Server 2005 Service Pack 2
安装 Service Pack（修补程序）

可以将任何安装的 SQL Server 2005 组件升级到 SQL Server 2005 SP2。如果现有 SQL Server 2005 组件的版本级别高于 SP2 版本级别，SP2 安装程序会将其从升级中排除。

安装 SQL Server 2005 SP2 时需要考虑下列注意事项：

  • 在应用 SQL Server 2005 SP2 后，将无法将其删除，除非卸载整个产品。

  • 必须同时升级属于一个 SQL Server 实例的所有功能。例如，升级 Database Services 时，如果 Analysis Services 安装在同一 SQL Server 实例上，那么也必须升级 Analysis Services。如果未在功能树中选择组件或实例，则不会将未选择的组件或实例升级到 SQL Server 2005 SP2。

  • 尽可能使用 Windows 身份验证。

  • 使用 SQL Server 身份验证时，为 sa 登录名提供的密码不能包含双引号。如果密码包含双引号，请在应用 SQL Server 2005 SP2 时使用 Windows 身份验证替代 SQL Server 身份验证，或者在运行 SP2 安装程序之前更改 sa 登录名的密码。

  • 升级 Reporting Services 实例时，安装程序将连接到报表服务器以升级报表服务器数据库。如果运行安装程序的用户的 Windows 帐户不是报表服务器上 sysadmin 固定服务器角色的成员，则必须提供拥有足够权限的 SQL Server 登录名和密码。为此，在“身份验证模式”对话框中选择 Reporting Services 实例，提供拥有所需权限的帐户凭据，再单击“确定”。

  • 默认情况下，SQL Server 2005 SP2 安装程序日志文件保存到 %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\。

其他文档

可以从以下来源获取其他 SQL Server 2005 SP2 文档：

  • SQL Server 2005 SP2 自述文件。

  • 有关 SQL Server 2005 SP2 的 Microsoft 知识库文章。

磁盘空间要求

若要下载和安装 SQL Server 2005 SP2，计算机必须至少具有 1.9 GB 的可用磁盘空间。下表说明了磁盘空间的使用情况：

磁盘使用情况 (MB) | 位置 | 类型
50 | SQL Server 2005 安装目录 | 永久
1,000 | 系统驱动器 | 永久
600 | Temp 目录 | 临时
250 | 下载位置 | 临时

安装完成后，可以从计算机上删除 250 MB 的下载包。安装完成后，SQL Server 2005 SP2 永久使用的磁盘空间大约为 1 GB。

安装概述

此部分提供 SQL Server 2005 SP2 安装概述，包括如何执行以下操作：

  • 准备 SQL Server 2005 SP2 安装

  • 安装 SQL Server 2005 SP2

  • 重新启动服务和应用程序

准备 SQL Server 2005 SP2 安装

安装 SQL Server 2005 SP2 之前，必须执行以下操作：

  • 备份 SQL Server 2005 数据库 - 安装 SQL Server 2005 SP2 之前，请备份 master、msdb 和 model 数据库。安装 SQL Server 2005 SP2 将修改这些数据库，这将使它们与 SQL Server 2005 SP2 之前的版本不兼容。如果您决定重新安装 SQL Server 2005（不带 SP2），将需要这些数据库的备份。

    出于谨慎起见，还应备份用户数据库。

重要事项：
如果要将 SP2 应用于参与复制拓扑的 SQL Server 实例，则必须在应用 SP2 之前，将复制的数据库与系统数据库一起备份。

  • 备份 Analysis Services 数据库、配置文件和存储库 - 将 Analysis Services 实例升级到 SP2 之前，应该备份以下内容：

    • Analysis Services 数据库。默认情况下，这些数据库安装到 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\。

    • msmdsrv.ini 配置文件中的分析服务器配置设置。默认情况下，该文件位于 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\ 目录中。

    • （可选）包含 Analysis Services 存储库的数据库。仅当将分析服务器配置为与决策支持对象 (DSO) 库一起使用时，才需要执行此步骤。

注意：
如果备份 Analysis Services 数据库、配置文件和存储库失败，则无法将升级后的 Analysis Services 实例恢复到先前版本。

  • 验证系统数据库是否有足够的可用空间 - 如果没有为 master 和 msdb 系统数据库选择自动增长选项，则每个数据库必须至少具有 500 KB 的可用空间。若要验证数据库是否有足够的空间，请对 master 和 msdb 数据库执行 sp_spaceused 系统存储过程。如果其中任一数据库的未分配空间少于 500 KB，则应增加该数据库的大小。有关详细信息，请参阅 SQL Server 联机丛书中的“扩展数据库”。

  • 验证未禁用 SQL Server 2005 服务帐户并且可以启动 - 如果 MSSQLServer、MSSQLServerOLAPService 和 ReportServer 服务的启动类型设置为“已禁用”，则安装程序可能会失败。

    若要验证并启用服务帐户，请执行以下操作：

    1. 在“控制面板”中，双击“管理工具”，然后双击“服务”。

    2. 在列表中找到 MSSQLServer 服务，并记下“启动类型”的值。

    3. 如果“启动类型”的值为“已禁用”，则双击服务名称，然后将“启动类型”更改为“手动”或“自动”。

    4. 对于 MSSQLServerOLAPService 和 ReportServer 服务，重复步骤 2 和步骤 3，然后单击“确定”。

    5. 对于所有安装的 SQL Server 实例，重复此过程。

  • 停止服务和应用程序 - 安装 SQL Server 2005 SP2 之前，停止与正在升级的 SQL Server 实例连接的所有应用程序和服务，包括 SQL Server Management Studio、Business Intelligence Development Studio、控制面板和“添加或删除程序”。

注意：
不能停止故障转移群集环境中的服务。有关详细信息，请参阅本主题后面的故障转移群集安装部分。

  • 为使 SP2 安装后无需重新启动计算机，安装程序将显示锁定文件的进程列表。如果 SP2 安装程序必须在安装过程中结束某服务，它将在安装完成后重新启动该服务。

  • 如果安装程序确定安装过程中文件已锁定，则可能需要在 SP2 安装完成后重新启动计算机。如有必要，安装程序将提示您重新启动计算机。

安装 SQL Server 2005 SP2

本部分说明 SQL Server 2005 SP2 的安装过程。

重要事项：
运行 SQL Server 2005 SP2 安装程序的帐户必须对要安装 SP2 的计算机拥有管理员权限。

启动 SQL Server 2005 SP2 安装程序

若要安装 SQL Server 2005 SP2，请运行自解压的包文件 SQLServer2005SP2-KB921896-PPP-LLL.exe，其中 PPP 表示指定平台，LLL 代表各语言的特定指示符。

注意：
若要将 SP2 应用于故障转移群集中的 SQL Server 2005 组件，请参阅故障转移群集安装部分。若要在无人参与模式下运行 SP2 安装程序，请参阅从命令提示符安装（修补程序）。

故障转移群集安装

以下信息仅适用于故障转移群集中的 SQL Server 2005 组件。

若要在故障转移群集上安装 Service Pack，请执行以下操作：

  1. 为了确保 SQL Server 2005 SP2 将安装在故障转移群集实例的所有节点上，请验证任务计划程序在故障转移群集实例的所有被动节点上运行。

  2. 如果添加的资源包含 SQL Server 资源的依赖项，则在安装 SQL Server 2005 SP2 之前，必须删除这些依赖项或使其脱机。如果不删除依赖项，则安装 SP2 时将使这些资源脱机。

    注意：
    如果群集资源脱机，则群集服务也将使所有相关资源脱机。

  3. 从活动节点运行 SQL Server 2005 SP2 可执行包文件（该节点拥有的组包含打算升级的故障转移群集实例）。这样会在故障转移群集的所有节点上安装 Service Pack 文件。不能从故障转移群集中的任何被动节点安装 SP2。

  4. 在 SQL Server 2005 SP2 安装向导的“功能选择”页上，选择打算升级的故障转移群集实例。安装程序将提示您输入连接到群集中其他节点所用的登录凭据。

    注意：
    安装过程中保持群集的所有节点处于联机状态。这样可确保对每个群集节点都应用升级。

  5. 如果在步骤 1 中删除了依赖项或使资源脱机，则应恢复依赖项或使资源联机。

    注意：
    安装程序可能要求重新启动故障转移群集节点。通过重新启动，可以替换安装过程中仍在使用的文件。
重新生成 SQL Server 2005 SP2 故障转移群集节点

在应用了 SP2 后，如果必须在故障转移群集中重新生成节点，请执行下列步骤：

  1. 在故障转移群集中重新生成节点。有关重新生成节点的详细信息，请参阅 SQL Server 联机丛书中的“如何从方案 1 中的故障转移群集故障中恢复”。

  2. 运行原始的 SQL Server 2005 安装程序，将节点恢复到故障转移群集。

  3. 在添加的节点上运行 SQL Server 2005 SP2 安装程序。

重新启动服务和应用程序

安装完成后，系统可能会提示您重新启动计算机。系统重新启动后，或在未请求重新启动的情况下完成安装后，请使用控制面板中的“服务”节点重新启动在应用 SQL Server 2005 SP2 之前停止的服务。

其中包括像 Distributed Transaction Coordinator 和 Microsoft Search 这样的服务，或特定于实例的同等服务。重新启动在运行 SQL Server 2005 SP2 安装程序之前关闭的应用程序。成功安装后，最好立即对升级后的 master、msdb 和 model 数据库再进行一次备份。


从命令提示符安装（修补程序）

从命令提示符安装（修补程序）

继续操作之前，请查看安装 Service Pack（修补程序）中的安装注意事项。

无人参与的 SQL Server 2005 SP2 安装支持以下命令提示符开关。请根据您所在组织的需要测试和修改安装脚本。

重要事项：
可能的话，请在运行时提供安全凭据。如果必须将凭据存储在脚本文件中，则必须确保文件的安全以防受到未经授权的访问。

开关

说明

/?

显示无人参与安装命令提示符帮助。

/allinstances

将 SQL Server 2005 SP2 应用于 SQL Server 2005 的所有实例以及 SQL Server 2005 的所有不识别实例的共享组件。

/instancename=InstanceName

将 SQL Server 2005 SP2 应用于名为 InstanceName 的 SQL Server 2005 实例以及 SQL Server 2005 的所有不识别实例的共享组件。

/password=Password

用于连接到远程故障转移群集节点的用户帐户密码。

/quiet

以无人参与模式运行 SQL Server 2005 SP2 安装程序。

/reportonly

仅运行安装程序中的发现和枚举部分，并显示枚举 SQL Server 2005 本地实例和组件的报告。

注意：
使用此开关时，不会应用 SQL Server 2005 SP2。

/rsupgradedatabaseaccount=rsAccountName

指定一个帐户，在您使用 SQL Server 身份验证时，此帐户有权修改报表服务器数据库上的架构。如果要升级的 Reporting Services 实例包含需要 SQL Server 登录名的报表服务器数据库，则可使用此参数。

/rsupgradepassword=rsPassword

为有权修改远程报表服务器数据库上的架构的帐户指定密码。如果要升级包含远程报表服务器数据库的 Reporting Services 实例，则可使用此参数。

/rsupgradedatabase

使用 /rsupgradedatabase=0 开关来防止 Reporting Services 数据库升级。

/sapwd=SaLoginPassword

传递用于 sa 登录名的 SQL Server 身份验证密码，以便运行脚本。

注意：
不要对 /sapwd 使用转义符。使用转义符将导致安装失败。

/user=Domain\UserName

用于连接到远程故障转移群集节点的用户帐户。


版权声明（修补程序）

版权声明（修补程序）

本文档（包括其中的示例应用程序）仅供参考，并且本文档不提供任何明示或暗示的保证。本文档中的信息（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。由于使用本文档而带来的任何风险或后果均由用户自行承担。

本文档中包含的示例主要用于说明概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。对这些示例或所包括的源代码，我们不提供技术支持。

除非另行说明，否则在本文档示例中涉及的公司、单位、产品、域名、电子邮件地址、个人、地点和事件等都是虚构的，与任何真实的公司、单位、产品、域名、电子邮件地址、个人、地点和事件没有任何刻意或隐含的联系。遵守所有适用的版权法是用户的责任。除了版权法所规定的权利以外，未经 Microsoft Corporation 的明确书面许可，不得对本文档中的任何部分进行复制、存储或引入检索系统，也不能以任何形式或借助任何手段（电子、机械、影印、录制或其他手段）、出于任何目的进行传播。

Microsoft 可能拥有本文档中内容的专利、专利申请、商标、版权或其他知识产权。除非 Microsoft 提供了明确的书面许可协议，否则提供本文档并不意味着赋予您有关这些专利、商标、版权或其他知识产权的任何许可。

版权所有 © 2006 Microsoft Corporation。保留所有权利。

Microsoft、Windows、Windows NT、Windows Server、Active Directory、ActiveX、BackOffice、bCentral、BizTalk、DirectX、Excel、Hotmail、IntelliSense、J/Direct、Jscript、Microsoft Press、MSDN、MS-DOS、Outlook、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual FoxPro、Visual InterDev、Visual J#、Visual J++、Visual SourceSafe、Visual Studio、Win32、Win32s、Windows Mobile、Windows Server System 和 WinFX 是 Microsoft Corporation 在美国和/或其他国家（地区）的注册商标或商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家（地区）的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 2005 支持和升级文档策略

SQL Server 文档中的内容在发布之前已进行了充分测试。产品文档（SQL Server 联机丛书、自述文件、已知问题文档和知识库文章）包含与 SQL Server 功能相关的内容，这些内容非常可靠，在所有客户的一般性应用中都是安全的。此政策适用于所有 SQL Server 文档，包括发行版和 Service Pack 的自述文件；自述文件被视为联机丛书的扩展。

在某些情况下，如果某项特定功能不应由客户直接使用，则这项功能将不会记录在文档中。除非 Microsoft 发布的 SQL Server 文档中也介绍了某项功能，否则 Microsoft 客户支持服务部门 (CSS) 不会对来自第三方书籍或网站的相关内容提供支持，并且这些内容也不应该应用于生产环境中的数据库或应用程序。

客户不得使用未记录的 API，包括但不仅限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。Microsoft 客户支持服务部门将不为利用或使用未记录入口点的数据库或应用程序提供支持。

对于利用或使用未记录入口点的应用程序和数据库，将不保证其服务器和数据库升级至 SQL Server 的未来版本。因此，只应使用 Microsoft SQL Server 文档中包含的那些 SQL Server 功能。如果某功能未记录到 Microsoft SQL Server 文档中，则其为 SQL Server 不支持的部分。


安装程序用户界面（修补程序）

安装程序用户界面（修补程序）

下列主题提供了其他与 SQL Server 2005 SP2 安装有关的安装决策信息。若要查看“帮助”主题，请单击其链接：

许可条款（修补程序）

功能选择 (修补程序)

身份验证模式（修补程序）

远程身份验证（修补程序）

错误和使用情况报告（修补程序）

正在运行的进程（修补程序）

准备安装（修补程序）

安装进程（修补程序）

安装完成（修补程序）

其他信息（修补程序）


许可条款（修补程序）

许可条款（修补程序）
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“许可条款 (修补程序)”页可以接受此版本的许可条款。

选项

若要继续执行 SQL Server 2005 SP2 安装程序，必须单击表示您接受 SQL Server 2005 SP2 许可条款的单选按钮。然后可以单击“下一步”继续。

使用“打印”按钮来打印此版本的许可条款的副本。若要结束 SQL Server 2005 SP2 安装程序，请单击“取消”。


功能选择 (修补程序)

功能选择 (修补程序)
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“功能选择 (修补程序)”页可以选择要更新的 SQL Server 组件和功能。

选项

在左窗格中单击功能名称，即可查看语言、操作系统、版本和状态详细信息。

若要更新组件或功能，请选中功能名称旁边的复选框。若要将组件或功能排除在此次更新之外，请清除功能名称旁边的复选框。

可以在不同时间更新单台计算机上的多个 SQL Server 2005 实例，但一个 SQL Server 实例中的所有组件必须同时升级。所有共享组件（如工作站组件、MSXML 分析器、SQLXML、向后兼容组件和 VSS 编写器）必须升级到 SQL Server 2005 SP2。

如果组件不能升级，将在“详细信息”窗格中提供说明。


身份验证模式（修补程序）

身份验证模式（修补程序）
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“身份验证模式 (修补程序)”页可以提供安装程序连接到要更新的 SQL Server 实例所需使用的实例和身份验证信息。

选项

如果要升级的所有组件或实例使用相同的身份验证模式、用户名和密码，则应选中“将选择应用于所有实例”复选框。如果选择此选项，将禁用“实例名”下拉菜单。提供身份验证类型、用户名和密码信息，然后单击“测试”以验证凭据。

如果要升级的所有组件使用不同的身份验证模式、用户名和密码，则应为要升级的各个组件或实例提供实例名称、身份验证类型、用户名和密码信息，然后单击“测试”以验证凭据。

为 SQL Server 的各组件或各实例完成凭据测试后，结果将填充到状态表。当所有组件在表中列出，且所有组件均处于“成功”状态后，单击“下一步”继续。继续操作之前，必须解决所有身份验证问题。

如果身份验证失败，则应更新组件信息，然后重试验证测试。当所有组件在表中列出，且所有组件均处于“成功”状态后，单击“下一步”继续。


远程身份验证（修补程序）

远程身份验证（修补程序）
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“远程身份验证 (修补程序)”页可以为要升级的 SQL Server 的故障转移群集实例提供远程登录信息。

选项

用户名

如果登录字段未预填充，请指定一个对故障转移群集的所有节点都为有效管理员帐户的用户名。

密码

为所选管理员帐户指定密码。

域

为所选管理员帐户指定域名。


错误和使用情况报告（修补程序）

错误和使用情况报告（修补程序）
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“错误和使用情况报告 (修补程序)”页可以启用 SQL Server 2005 的功能错误和使用情况报告功能。

选项

SQL Server SP2 包含有对 SQL Server 进行配置的选项，以使其自动将服务错误报告发送到 Microsoft 或您的公司错误报表服务器。可以通过清除该页上的复选框来禁用一个或两个选项。Microsoft 使用错误报告来改进 SQL Server 功能，并对所有错误报告和功能使用情况数据保密。

错误报告

如果启用错误报告功能，SQL Server 将配置为在下列任意 SQL Server 组件中发生错误时，自动发送报告到 Microsoft：

  • 数据库引擎

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 复制

Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

有关错误的信息将通过安全 (https) 连接发送到 Microsoft，在那里保存这些信息，且对其访问将受到限制。另外，也可以将这些信息发送到您自己的公司错误报表服务器。有关设置公司错误报表服务器的详细信息，请访问 Microsoft 公司错误报告网站。

错误报告包含如下信息：

  • 出现问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 用户数字产品 ID（并非用于标识您的许可证）。

  • 计算机或代理服务器的网络 IP 地址。

  • 与出错进程相关联的内存信息或文件信息。

Microsoft 不是有意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。但是，错误报告可能包含个人信息，这些信息来自与出错进程相关联的内存或文件。虽然可能使用该信息来确定您的身份，但 Microsoft 不会将这些信息用于此目的。

有关 隐私和数据收集策略的更多信息，请参阅 SQL Server 2005 隐私声明。

如果启用了错误报告功能并出现错误，Windows 事件日志中可能会包含来自 Microsoft 的响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用 SQL Server 的所有实例及其组件的错误或功能使用情况报告，请转到“错误和使用情况报告设置”对话框（依次指向“开始”、“所有程序”、“Microsoft SQL Server 2005”、“配置工具”、“SQL Server 错误和使用情况报告”）并清除“功能使用情况”复选框。如果对 SQL Server 的多个组件（数据库引擎、分析服务器、报表服务器和共享组件）启用错误报告，则可以对单个组件的各实例禁用错误报告。还可以对列为“其他”的共享组件禁用错误报告。

功能使用情况

如果启用功能使用情况报告功能，则 SQL Server 会配置为定期将报告发送到 Microsoft。报告将包含有关硬件配置和用户如何使用 SQL Server 2005 软件和服务的信息。Microsoft 将使用功能使用情况数据改进 SQL Server。此功能监视的 SQL Server 2005 组件包括：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 复制

  • Business Intelligence Development Studio

有关功能使用情况的信息将发送到 Microsoft，在那里保存这些信息，且其访问将受到限制。

若要在安装程序完成后禁用功能使用情况报告，请使用 SQL Server 2005“配置工具”菜单上的“SQL Server 错误和使用情况报告”工具。

对所有已启用的 SQL Server 实例会每天收集一次信息。默认情况下，收集时间定为午夜，以尽量减轻服务器的负载。如果要更改收集时间，则可以手动编辑控制收集时间的注册表项。SQL Server 的各个实例有自己的注册表项。以下示例用于安装在服务器上的第一个 SQL Server 实例 (MSSQL.1)：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

该注册表项的值包含的运行收集的时间以 00:00（午夜）开始的分钟数表示。例如，值 60 表示在凌晨 1:00 运行收集，值 1200 表示在晚上 8:00 运行收集。


正在运行的进程（修补程序）

正在运行的进程（修补程序）
安装程序用户界面（修补程序） >

若要避免在安装 SP2 后重新启动 Windows，请使用 SQL Server 2005 SP2 安装向导的“正在运行的进程 (修补程序)”页来标识锁定 SQL Server 2005 SP2 安装程序所需的文件的进程。

停止与正在升级的 SQL Server 实例连接的所有应用程序和服务。它包括在安装 SQL Server 2005 SP2 前停止 SQL Server Management Studio 和 Business Intelligence Development Studio、关闭控制面板及“添加或删除程序”。

  • 为使 SP2 安装后无需重新启动计算机，安装程序将显示锁定文件的进程列表。如果 SP2 安装程序必须在安装过程中结束某服务，它将在安装完成后重新启动该服务。

  • 如果安装程序确定在安装过程中文件已锁定，则最好在 SP2 安装完成后重新启动计算机。如有必要，安装程序将提示您重新启动计算机。

选项

如果安装程序检测到锁定的文件，这些文件将在表中列出。停止或结束列表中的进程和应用程序，然后单击“刷新”可重新运行检查。单击“停止”可结束正在运行的检查。如果找不到锁定的文件，表将为空。

所有锁定进程关闭后，单击“下一步”继续。

将 SQL Server 2005 SP2 安装到故障转移群集实例上

将 SQL Server 2005 SP2 安装到故障转移群集实例上之前，请注意以下信息：

  • 在运行 SP2 安装程序之前以及在运行此安装程序的过程中，请勿停止群集服务。

  • 在运行 SP2 安装程序之前，请勿终止任何正在运行的进程。

  • 在运行 SP2 安装程序之前，请勿使 SQL Server 服务脱机。SP2 安装程序将先停止 SQL Server 服务，然后再启动它。

  • 在故障转移群集实例的主节点上运行 SP2 安装程序。

  • 完成 SP2 的安装后，您必须重新启动所有故障转移群集节点。

  • SP2 不支持滚动升级。


准备安装（修补程序）

准备安装（修补程序）
安装程序用户界面（修补程序） >

SP2 安装向导的 “准备安装 (修补程序)”页指示 SQL Server 2005 SP2 安装程序已具备安装更新所需的信息。

选项

单击“返回”以查看或更改 SQL Server 2005 SP2 安装选项。若要继续，请单击“安装”。


安装进程（修补程序）

安装进程（修补程序）
安装程序用户界面（修补程序） >

使用 SP2 安装向导的“安装进程 (修补程序)”页，可以在安装程序将 SQL Server 2005 SP2 应用到您的 SQL Server 组件和实例时对安装程序进行监视。

选项

该表提供了 SQL Server 产品名称、其实例名称及安装状态。


安装完成（修补程序）

安装完成（修补程序）
安装程序用户界面（修补程序） >

SP2 安装向导的“安装完成 (修补程序)”页显示更新到 SQL Server 2005 SP2 的每个组件的状态。

选项

若要查看 SQL Server 2005 SP2 安装的摘要日志，请单击“查看摘要”。摘要日志文件保存在 C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\ 中。

若要查看日志文件的路径，请单击组件名称。例如，如果单击 SQL Server Native Client，则“详细信息”窗格将显示其日志文件的路径：C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log。


其他信息（修补程序）

其他信息（修补程序）
安装程序用户界面（修补程序） >

更新日期： 2006 年 12 月 12 日

SP2 安装向导的“其他信息”（修补程序）页包含一个用于打开“用于 Windows Vista 的 SQL Server 2005 用户设置工具”的复选框。使用此设置工具可更新 SQL Server 的系统管理员角色中的用户列表。

用户帐户控制 (UAC) 也称为用户帐户保护 (UAP) 或受限用户帐户 (LUA)，它是 Windows Vista 的一项新增安全功能。UAC 允许用户以非管理员身份执行常见任务。作为本地 Administrators 组的成员的用户帐户可运行大多数应用程序，就像使用标准用户帐户时一样。

默认情况下，不会向作为 Windows Administrators 组成员的 Windows Vista 用户自动授予连接到 SQL Server 的权限。另外，也不会自动向用户授予管理凭据。SQL Server 系统管理员角色的成员可以在 SQL Server 实例中执行任何活动。

若要允许 Administrators 组的成员从运行 Windows Vista 的计算机上登录，您必须将该帐户显式添加到 SQL Server 的登录名中。

选项

若要更新 SQL Server 系统管理员角色中的用户列表，请使用该复选框启动“用于 Windows Vista 的 SQL Server 2005 用户设置工具”。

确保“要设置的用户”字段列出了应更新其权限的用户的“域名\用户名”。从“可用权限”窗格的 SQL Server 实例列表中选择要更新的角色，然后单击向右箭头。若要将用户添加到 SQL Server 实例的所有可用实例的所有可用角色中，请双击向右箭头。

右侧窗格列出将更新其权限的用户的“域名\用户名”，以及将向其添加用户的 SQL Server 实例和角色。

若要从右侧窗格中删除某个角色，请选择该角色，然后单击向左箭头。若要从右侧窗格中删除所有角色，请单击向左双箭头。请注意，向左箭头的功能只会影响显示在工具中的用户、角色和权限。该工具中没有撤消权限的功能。若要撤消用户的权限，管理员必须手动更新或删除该用户的凭据。

若要在完成选择后实行这些更改，请单击“确定”。若要在不做出更改的情况下结束使用此工具，请单击“取消”。

若要在此安装程序结束后访问“用于 Microsoft Vista 的 SQL Server 2005 用户设置工具”，请在 SQL Server 2005 外围应用配置器工具 (SQLSAC.exe) 中单击“添加新管理员”链接。

“其他信息”（修补程序）链接列表提供了若干链接，可通过链接指向的网站获取 SQL Server 的其他信息。这些链接包含有关产品支持、文档更新和针对 SQL Server 的 Microsoft 更新选项的信息。