Установка пакета обновления (исправление)

Пакет обновления 2 (SP2) для Microsoft SQL Server 2005
Установка пакета обновления (исправление)

Можно обновить любой установленный компонент SQL Server 2005 до версии SQL Server 2005 с пакетом обновления 2 (SP2). Если уровень версии существующего компонента SQL Server 2005 выше, чем пакет обновления 2 (SP2), программа установки пакета обновления 2 (SP2) исключит этот компонент из списка обновления.

Необходимо учитывать следующие соображения при установке пакета обновления 2 (SP2) для SQL Server 2005.

  • После применения пакета обновления 2 (SP2) для SQL Server 2005 его нельзя удалить без удаления всего продукта.

  • Все компоненты, которые принадлежат экземпляру SQL Server, должны обновляться одновременно. Например, при обновлении служб Database Services необходимо также обновить службы Analysis Services, если они установлены на том же экземпляре SQL Server. Если компонент или экземпляр не выбран в дереве компонентов, то он не будет обновлен до версии SQL Server 2005 с пакетом обновления 2 (SP2).

  • По возможности используйте проверку подлинности Windows.

  • При использовании проверки подлинности SQL Server пароль, указанный для имени входа sa, не может содержать двойные кавычки. Если пароль содержит двойные кавычки, то при установке SQL Server 2005 с пакетом обновления 2 (SP2) следует вместо проверки подлинности SQL Server использовать проверку подлинности Windows или изменить пароль для имени входа sa перед запуском программы установки пакета обновления 2 (SP2).

  • При обновлении экземпляра служб Reporting Services программа установки подключается к серверу отчетов, чтобы обновить базу данных сервера отчетов. Если учетная запись Windows пользователя, запустившего программу установки, не входит в фиксированную серверную роль sysadmin на сервере отчетов, необходимо предоставить имя входа и пароль пользователя SQL Server с достаточными правами. Для этого выберите экземпляр служб Reporting Services в диалоговом окне Режим проверки подлинности, введите учетные данные пользователя с нужными разрешениями и нажмите кнопку ОК.

  • По умолчанию файлы журнала программы установки пакета обновления 2 (SP2) для SQL Server 2005 сохраняются в папку %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Дополнительная документация

Дополнительная документация по пакету обновления 2 (SP2) для SQL Server 2005 доступна из следующих источников.

  • Файл Readme пакета обновления 2 (SP2) для SQL Server 2005.

  • Статья базы знаний Майкрософт о пакете обновления 2 (SP2) для SQL Server 2005.

Требования к свободному месту на диске

Для загрузки и установки пакета обновления 2 (SP2) для SQL Server 2005 компьютер должен располагать минимум 1,9 ГБ свободного места на диске. В следующей таблице приводятся сведения об использовании места на диске.

Использование места на диске (МБ) | Расположение | Тип
50 | Каталог установки SQL Server 2005 | Постоянно
1 000 | Системный диск | Постоянно
600 | Каталог temp | Временно
250 | Место загрузки | Временно

После установки можно удалить с компьютера загруженный пакет размером 250 МБ. Место на диске, постоянно занимаемое SQL Server 2005 с пакетом обновления 2 (SP2), составляет около 1 ГБ.

Обзор установки

В этом разделе содержится обзор установки пакета обновления 2 (SP2) для SQL Server 2005, включая описание следующих действий:

  • Подготовка к установке пакета обновления 2 (SP2) для SQL Server 2005

  • Установка пакета обновления 2 (SP2) для SQL Server 2005

  • Перезапуск служб и приложений

Подготовка к установке пакета обновления 2 (SP2) для SQL Server 2005

Перед установкой пакета обновления 2 (SP2) для SQL Server 2005 необходимо выполнить следующие действия.

  • Резервное копирование баз данных SQL Server 2005. Перед установкой пакета обновления 2 (SP2) для SQL Server 2005 выполните резервное копирование баз данных master, msdb и model. При установке пакета обновления 2 (SP2) для SQL Server 2005 эти базы данных изменяются, что приведет к их несовместимости с более ранними версиями SQL Server 2005. Резервные копии этих баз данных понадобятся в случае, если будет принято решение переустановить SQL Server 2005 без пакета обновления 2 (SP2).

    Разумно также создать резервные копии пользовательских баз данных.

Важно!
При установке пакета обновления 2 (SP2) на экземпляры SQL Server, участвующие в топологии репликации, необходимо создать резервные копии реплицируемых баз данных наряду с системными базами данных перед установкой.

  • Резервное копирование баз данных, файла конфигурации и репозитория служб Analysis Services. Перед обновлением экземпляра служб Analysis Services до версии с пакетом обновления 2 (SP2) следует выполнить резервное копирование следующих элементов:

    • Базы данных служб Analysis Services. По умолчанию они установлены в папку C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\.

    • Параметр конфигурации сервера анализа данных в файле конфигурации msmdsrv.ini. По умолчанию файл находится в каталоге C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\.

    • База данных, которая содержит репозиторий служб Analysis Services (необязательно). Этот этап необходим только в случае, если сервер анализа данных был настроен для работы с библиотекой объектов DSO.

Примечание.
Если не будет выполнено резервное копирование файла конфигурации, репозитория и баз данных служб Analysis Services, будет невозможно восстановить обновленный экземпляр служб Analysis Services до предыдущей версии.

  • Обеспечение достаточного свободного места для системных баз данных. Если параметр autogrow не выбран для системных баз данных master и msdb, для каждой из этих баз данных необходимо обеспечить как минимум 500 КБ свободного места на диске. Чтобы убедиться в наличии необходимого свободного места в базах данных, выполните системную хранимую процедуру sp_spaceused для баз данных master и msdb. Если размер свободного места в какой-либо из этих баз данных составляет менее 500 КБ, увеличьте ее размер. Дополнительные сведения см. в разделе «Расширение базы данных» электронной документации по SQL Server.

  • Обеспечение активности служебных учетных записей SQL Server 2005. Программа установки может завершиться неуспешно, если параметру «Тип запуска» для служб MSSQLServer, MSSQLServerOLAPService и ReportServer присвоено значение «Отключено».

    Чтобы проверить состояние учетных записей служб и включить их, выполните следующие действия.

    1. На панели управления дважды щелкните элемент Администрирование, а затем дважды щелкните элемент Службы.

    2. Найдите службу MSSQLServer в списке и проверьте значение параметра Тип запуска.

    3. Если параметр Тип запуска имеет значение Отключено, дважды щелкните имя службы и измените значение Тип запуска на Вручную или Автоматически.

    4. Повторите шаги 2 и 3 для служб MSSQLServerOLAPService и ReportServer и нажмите кнопку ОК.

    5. Повторите процесс для всех установленных экземпляров SQL Server.

  • Остановка служб и приложений. Остановите все приложения и службы, которые подключаются к обновляемым экземплярам SQL Server, в том числе среду SQL Server Management Studio, среду Business Intelligence Development Studio, панель управления и элемент Установка и удаление программ, перед установкой пакета обновления 2 для SQL Server 2005.

Примечание.
В среде с отказоустойчивым кластером нельзя останавливать службы. Дополнительные сведения см. в подразделе, посвященном установке отказоустойчивого кластера, далее в этом разделе.

  • Чтобы устранить необходимость в перезагрузке компьютера после установки пакета обновления 2 (SP2), программа установки отобразит список процессов, блокирующих файлы. Если программе установки пакета обновления 2 (SP2) приходится остановить работу службы во время установки, эта служба будет перезапущена программой установки по завершении установки.

  • В случае обнаружения программой установки заблокированных файлов во время установки может возникнуть необходимость в перезагрузке компьютера по завершении установки пакета обновления 2 (SP2). При необходимости программа установки запрашивает пользователя о перезагрузке компьютера.

Установка пакета обновления 2 (SP2) для SQL Server 2005

В этом разделе описан процесс установки с помощью программы установки пакета обновления 2 (SP2) для SQL Server 2005.

Важно!
Программа установки пакета обновления 2 (SP2) для SQL Server 2005 должна запускаться с учетной записью, обладающей правами администратора на компьютере, куда устанавливается пакет обновления 2 (SP2).

Запуск программы установки пакета обновления 2 (SP2) для SQL Server 2005

Чтобы установить пакет обновления 2 (SP2) для SQL Server 2005, запустите самораскрывающийся файл SQLServer2005SP2-KB921896-PPP-LLL.exe, где PPP обозначает конкретную платформу, а LLL — язык установки.

Примечание.
Сведения о применении пакета обновления 2 (SP2) к компонентам SQL Server 2005, являющимся частью отказоустойчивого кластера, см. в разделе, посвященном установке отказоустойчивого кластера. Сведения о запуске программы установки пакета обновления 2 (SP2) в автоматическом режиме см. в разделе Установка из командной строки (исправление).

Установка отказоустойчивого кластера

Следующие сведения относятся только к компонентам SQL Server 2005, которые являются частью отказоустойчивого кластера.

Чтобы установить пакет обновления на отказоустойчивом кластере, выполните следующие действия.

  1. Чтобы обеспечить установку пакета обновления 2 (SP2) для SQL Server 2005 на всех узлах экземпляра отказоустойчивого кластера, убедитесь в том, что планировщик задач запущен на всех пассивных узлах экземпляра отказоустойчивого кластера.

  2. Если были добавлены какие-либо ресурсы, зависящие от ресурсов SQL Server, то эти зависимости должны быть удалены или переведены в автономный режим перед установкой пакета обновления 2 (SP2) для SQL Server 2005. Если не удалить зависимости, то в процессе установки пакета обновления 2 (SP2) такие ресурсы перейдут в автономный режим.

    Примечание.
    Если кластеризованный ресурс переведен в автономный режим, то все зависимые ресурсы также переводятся в автономный режим службой кластеров.

  3. Запустите исполняемый файл пакета обновления 2 (SP2) для SQL Server 2005 на активном узле, которому принадлежит группа, содержащая обновляемый экземпляр отказоустойчивого кластера. В результате файлы пакета обновления будут установлены на всех узлах в отказоустойчивом кластере. Нельзя установить пакет обновления 2 (SP2) с какого-либо пассивного узла в отказоустойчивом кластере.

  4. На странице «Выбор функций» мастера установки пакета обновления 2 (SP2) для SQL Server 2005 выберите обновляемый экземпляр отказоустойчивого кластера. Программа установки предложит ввести учетные данные, используемые для соединения с другими узлами кластера.

    Примечание.
    Во время установки все узлы кластера должны находиться в оперативном режиме. Это гарантирует, что будет выполнено обновление каждого узла кластера.

  5. Если на этапе 1 были удалены зависимости или ресурсы были переведены в автономный режим, то следует восстановить зависимости или перевести ресурсы в оперативный режим.

    Примечание.
    Для программы установки может потребоваться перезапустить узлы отказоустойчивого кластера. В результате перезапуска заменяются файлы, которые использовались в ходе установки.
Перестроение узла отказоустойчивого кластера SQL Server 2005 с пакетом обновления 2 (SP2)

Если необходимо перестроить узел в отказоустойчивом кластере после установки пакета обновления 2 (SP2), выполните следующие действия.

  1. Перестройте узел в отказоустойчивом кластере. Дополнительные сведения о перестроении узла см. в разделе «Как восстановить после сбоя отказоустойчивый кластер в сценарии 1» электронной документации по SQL Server.

  2. Запустите исходную программу установки SQL Server 2005, чтобы восстановить узел в отказоустойчивом кластере.

  3. Запустите программу установки пакета обновления 2 (SP2) для SQL Server 2005 на добавленном узле.

Перезапуск служб и приложений

После завершения установки может быть предложено перезагрузить компьютер. После перезапуска системы или по завершении программы установки без запроса на перезапуск системы используйте узел Службы на панели управления, чтобы перезапустить службы, остановленные перед установкой пакета обновления 2 (SP2) для SQL Server 2005.

В частности, к их числу относятся координатор распределенных транзакций и служба поиска Майкрософт или их эквиваленты для данного экземпляра. Перезапустите приложения, закрытые перед запуском программы установки пакета обновления 2 (SP2) для SQL Server 2005. Сразу после успешной установки может понадобиться выполнить еще одно резервное копирование обновленных баз данных master, msdb и model.


Установка из командной строки (исправление)

Установка из командной строки (исправление)

Перед установкой изучите сведения, приведенные в разделе Установка пакета обновления (исправление).

Для автоматической установки пакета обновления 2 (SP2) для SQL Server 2005 поддерживаются следующие параметры командной строки. Проверьте сценарии установки и внесите необходимые изменения.

Важно!
При возможности указывайте учетные данные безопасности в процессе выполнения. При хранении учетных данных в файле сценария необходимо защитить этот файл во избежание несанкционированного доступа.

Переключатель

Описание

/?

Отображает справку командной строки для автоматической установки.

/allinstances

Применяет пакет обновления 2 для SQL Server 2005 ко всем экземплярам SQL Server 2005 и ко всем общим компонентам SQL Server 2005, не связанным с конкретным экземпляром.

/instancename=ИмяЭкземпляра

Применяет пакет обновления 2 для SQL Server 2005 к экземпляру SQL Server 2005 с именем «ИмяЭкземпляра» и ко всем общим компонентам SQL Server 2005, не связанным с конкретным экземпляром.

/password=Пароль

Пароль учетной записи пользователя для подключения к удаленному узлу отказоустойчивого кластера.

/quiet

Запускает программу установки пакета обновления 2 для SQL Server 2005 в автоматическом режиме.

/reportonly

Выполняются только части программы установки, проводящие обнаружение и перечисление, а затем отображается отчет с перечислением всех экземпляров и компонентов SQL Server 2005.

Примечание.
При использовании этого переключателя пакет обновления 2 для SQL Server 2005 не устанавливается.

/rsupgradedatabaseaccount=ИмяУчетнойЗаписиСлужбRS

Указывает учетную запись с разрешениями для изменения схемы базы данных сервера отчетов при использовании проверки подлинности SQL Server. Этот параметр используется при обновлении экземпляра служб Reporting Services, который содержит базу данных сервера отчетов, требующую имя входа SQL Server.

/rsupgradepassword=ПарольСлужбRS

Указывает пароль для учетной записи с разрешениями на изменение схемы базы данных удаленного сервера отчетов. Этот параметр используется при обновлении экземпляра служб Reporting Services, который содержит базу данных удаленного сервера отчетов.

/rsupgradedatabase

Используйте переключатель /rsupgradedatabase=0, чтобы предотвратить обновление базы данных служб Reporting Services.

/sapwd=ПарольИмениВходаSa

Передает пароль проверки подлинности SQL Server имени входа sa для запуска сценариев.

Примечание.
Не следует экранировать символы для параметра /sapwd. Экранирование символов приведет к ошибке программы установки.

/user=Домен\ИмяПользователя

Учетная запись пользователя для подключения к удаленному узлу отказоустойчивого кластера.


Уведомление об авторских правах (исправление)

Уведомление об авторских правах (исправление)

Эта документация, включая входящие в нее образцы приложений, предоставляется исключительно для информационных целей и без каких-либо гарантий, прямых или косвенных. Данные, содержащиеся в этой документации, включая URL-адреса и ссылки на другие веб-узлы, могут меняться без предварительного уведомления. Всю ответственность за использование документации, а также за результаты ее использования несет исключительно пользователь.

Основная задача образцов, содержащихся в документации, состоит в том, чтобы проиллюстрировать какое-либо понятие или показать рациональное использование определенной инструкции или предложения. В большинство образцов не входит весь код, который содержался бы в полноценной работающей системе. Некоторые обычные операции проверки данных и обработки ошибок удалены из образцов намеренно, чтобы обратить внимание на конкретные концепции или инструкции, используемые в образцах. Техническая поддержка для таких образцов, равно как и для любого исходного кода, не предоставляется.

За исключением специально отмеченных случаев, описанные здесь компании, организации, товары, имена доменов, адреса электронной почты, люди, места и события являются вымышленными; любые совпадения с какими-либо реальными компаниями, организациями, товарами, именами доменов, адресами электронной почты, лицами, местами и событиями являются случайными. Ответственность за соблюдение всех авторских прав и прав на интеллектуальную собственность целиком и полностью несет пользователь. В рамках, предусмотренных законами об авторских правах, никакая часть настоящего документа не может быть воспроизведена, сохранена или введена в систему хранения и извлечения данных либо передана в любой форме или любым способом (электронным, механическим, методом фотокопирования, записи или иным способом) для любых целей без письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может являться правообладателем патентов, заявок на получение патентов, товарных знаков и прочих объектов авторского права, которые могут иметь отношение к содержанию данной документации. Предоставление данной документации не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Майкрософт.

© Корпорация Майкрософт, 2006. Все права защищены.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System и WinFX являются охраняемыми товарными знаками корпорации Майкрософт в США и других странах.

SAP NetWeaver является охраняемым товарным знаком SAP AG в Германии и в некоторых других странах.

Все прочие товарные знаки являются собственностью их владельцев.

Политика документирования поддержки и обновления SQL Server 2005

Содержимое документации по SQL Server публикуется только после выполнения необходимых проверок. Документация по продукту (электронная документация по SQL Server, файлы readme, документы об обнаруженных проблемах, а также статьи базы знаний) содержит сведения о компонентах сервера SQL Server и его функциях, которые достаточно надежны для общего использования всеми заказчиками. Данная политика относится ко всей документации SQL Server, включая файлы Readme отдельных версий и пакетов обновления; файлы Readme рассматриваются как дополнение к электронной документации.

В некоторых случаях функции не предназначены для непосредственного использования клиентами, поэтому они не описываются в документации. Если сведения о какой-либо функции отсутствуют в документации по SQL Server, опубликованной корпорацией Майкрософт, но содержатся в книгах или на веб-узлах сторонних компаний, то на нее не распространяется поддержка пользователей Майкрософт и она не должна применяться в работающих базах данных и приложениях.

Клиенты не должны использовать недокументированные API-интерфейсы, в частности следующие: хранимые процедуры, расширенные хранимые процедуры, функции, представления, таблицы, столбцы, свойства и метаданные. Служба поддержки пользователей Майкрософт не осуществляет сопровождение баз данных и приложений, в которых прямо или косвенно используются недокументированные точки входа.

Для приложений и баз данных, которые прямо или косвенно используют недокументированные точки входа, обновление сервера и баз данных для работы с будущими версиями SQL Server не гарантируется. Разрешено использование только возможностей и функций SQL Server, которые включены в документацию по Microsoft SQL Server. Если функция не включена в документацию по Microsoft SQL Server, то она не является поддерживаемой частью SQL Server.


Пользовательский интерфейс программы установки (исправление)

Пользовательский интерфейс программы установки (исправление)

В следующих разделах содержатся дополнительные сведения о решениях, принимаемых в ходе установки пакета обновления 2 (SP2) для SQL Server 2005. Чтобы просмотреть раздел справки, щелкните соответствующую ссылку:

Условия лицензии (исправление)

Выбор компонентов (исправление)

Режим проверки подлинности (исправление)

Удаление проверки подлинности (исправление)

Отчеты об ошибках и использовании (исправление)

Запущенные процессы (исправление)

Готовность к установке (исправление)

Выполнение установки (исправление)

Завершение установки (исправления)

Дополнительные сведения (исправление)


Условия лицензии (исправление)

Условия лицензии (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Условия лицензионного соглашения (исправление) мастера установки пакета обновления 2 для , чтобы подтвердить принятие условий лицензионного соглашения для этой версии.

Параметры

Чтобы продолжить установку пакета обновления 2 для SQL Server 2005, необходимо щелкнуть переключатель, подтверждая принятие условий лицензионного соглашения SQL Server 2005 SP2. Затем нажмите кнопку Далее, чтобы продолжить.

Используйте кнопку Печать, чтобы распечатать копию условий лицензионного соглашения для этой версии. Чтобы выйти из программы установки пакета обновления 2 для SQL Server 2005, нажмите кнопку Отмена.


Выбор компонентов (исправление)

Выбор компонентов (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Выбор компонентов (исправление) мастера установки пакета обновления 2 для , чтобы выбрать компоненты и функции SQL Server, которые нужно обновить.

Параметры

Щелкните имя функции в левой области, чтобы просмотреть сведения о языке, операционной системе, выпуске и состоянии.

Чтобы обновить компонент или функцию, установите флажок рядом с именем компонента или функции. Чтобы исключить компонент или функцию из текущего обновления, снимите флажок рядом с именем компонента или функции.

Несколько экземпляров SQL Server 2005 на одном компьютере могут обновляться в разное время, однако все компоненты одного экземпляра SQL Server должны обновляться одновременно. Все общие компоненты, в том числе компоненты рабочей станции, синтаксический анализатор MSXML, SQLXML, компоненты обратной совместимости и службы синхронизации контроля версий, должны быть обновлены до версии SQL Server 2005 с пакетом обновления 2 (SP2).

Если компонент не может быть обновлен, в области Подробности будет отображено пояснение.


Режим проверки подлинности (исправление)

Режим проверки подлинности (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Режим проверка подлинности (исправление) мастера установки пакета обновления 2 для , чтобы предоставить сведения об экземпляре и данные проверки подлинности, которые будут использоваться программой установки для подключения к обновляемым экземплярам SQL Server.

Параметры

Если режим проверки подлинности, имя пользователя и пароль совпадают для всех обновляемых компонентов или экземпляров, установите флажок Применить ко всем экземплярам. При выборе этого параметра раскрывающийся список Имя экземпляра будет отключен. Укажите тип проверки подлинности, имя пользователя и пароль, а затем нажмите кнопку Проверка, чтобы проверить правильность учетных данных.

Если для обновляемых компонентов используются разные режимы проверки подлинности, имена пользователей и пароли, укажите имя экземпляра, тип проверки подлинности, имя пользователя и пароль для каждого обновляемого компонента или экземпляра, а затем нажмите кнопку Проверка, чтобы проверить правильность учетных данных.

По мере выполнения проверки учетных данных для каждого компонента или экземпляра SQL Server таблица сведений о состоянии будет заполняться результатами. Когда все компоненты будут перечислены в таблице с состоянием «Успешно», нажмите кнопку Далее, чтобы продолжить. Необходимо устранить все проблемы, связанные с проверкой подлинности, прежде чем продолжить.

Если проверка подлинности завершается неуспешно, обновите данные для компонента и повторите попытку выполнить проверку. Когда все компоненты будут перечислены в таблице с состоянием «Успешно», нажмите кнопку Далее, чтобы продолжить.


Удаление проверки подлинности (исправление)

Удаление проверки подлинности (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Удаленная проверка подлинности (исправление) мастера установки пакета обновления 2 (SP2) для , чтобы предоставить данные удаленного входа в систему для обновляемых экземпляров отказоустойчивого кластера SQL Server.

Параметры

Имя пользователя

Если поле имени входа не заполнено заранее, укажите имя пользователя, соответствующее допустимой учетной записи администратора для всех узлов отказоустойчивого кластера.

Пароль

Укажите пароль для выбранной учетной записи администратора.

Домен

Укажите имя домена для выбранной учетной записи администратора.


Отчеты об ошибках и использовании (исправление)

Отчеты об ошибках и использовании (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Отчеты об ошибках и использовании (исправление) мастера установки пакета обновления 2 для , чтобы включить функцию отправки отчетов об ошибках и использовании для SQL Server 2005.

Параметры

Пакет обновления 2 (SP2) для SQL Server включает возможность настройки SQL Server для автоматической отправки отчетов о неисправимых ошибках служб в корпорацию Майкрософт или на корпоративный сервер отчетов об ошибках. Можно отключить один или оба параметра, сняв флажки на этой странице. Корпорация Майкрософт использует отчеты об ошибках для улучшения функциональности SQL Server и рассматривает все данные отчетов об ошибках и использовании как конфиденциальные.

Отчет об ошибках

Если включить возможность отчета об ошибках, SQL Server будет настроен для автоматической отправки отчета в корпорацию Майкрософт в случае неустранимой ошибки в любом из следующих компонентов SQL Server:

  • Компонент Database Engine

  • Агент SQL Server

  • Службы Analysis Services

  • Службы Reporting Services

  • Службы Notification Services

  • Службы Integration Services

  • Репликация

Корпорация Майкрософт использует отчеты об ошибках, чтобы улучшить функциональность SQL Server, и любые поступающие данные расценивает как конфиденциальные.

Сведения об ошибках отправляются в корпорацию Майкрософт по защищенному соединению (https) и хранятся там с ограничением доступа. Вместо этого отчеты об ошибках можно отправлять на собственный корпоративный сервер отчетов об ошибках. Дополнительные сведения о настройке корпоративного сервера отчетов об ошибках см. на веб-узле Майкрософт.

Отчеты об ошибках содержат следующие сведения:

  • состояние SQL Server при возникновении проблемы;

  • версия операционной системы и сведения об оборудовании компьютера;

  • код продукта, который не используется для идентификации лицензии;

  • сетевой IP-адрес компьютера или прокси-сервера;

  • сведения из памяти или файлов, связанных с процессом, вызвавшим ошибку.

Корпорация Майкрософт не осуществляет преднамеренный сбор файлов, имени, адреса, адреса электронной почты или других личных сведений пользователя. Однако отчет об ошибке может содержать личные сведения из памяти или файлов, связанных с процессом, вызвавшим ошибку. Хотя потенциально эти сведения можно использовать, чтобы идентифицировать пользователя, корпорация Майкрософт для этой цели их не использует.

Дополнительные сведения о политике Майкрософт по конфиденциальности и сбору сведений по SQL Server см. на странице Заявление о конфиденциальности SQL Server 2005.

Если при включенной функции отправки отчетов об ошибках произойдет неисправимая ошибка, можно увидеть в журнале событий Windows ответ от корпорации Майкрософт, указывающий на статью базы знаний Майкрософт об этой конкретной ошибке.

Чтобы отключить отчеты об ошибках или использовании компонентов для всех экземпляров SQL Server и его компонентов после завершения установки, перейдите в диалоговое окно Параметры отчетов об ошибках и использовании — «Пуск» : «Все программы» : «Microsoft SQL Server 2005» : «Средства настройки» : «Отчеты об ошибках и использовании SQL Server» — и снимите флажки в разделе Использование компонентов. Если функция отправки отчетов об ошибках включена для нескольких компонентов SQL Server (компонента Database Engine, сервера анализа данных, сервера отчетов и общих компонентов), можно отключить эту функцию для каждого экземпляра отдельного компонента. Можно также отключить эту функцию для общих компонентов, перечисленных в разделе Прочие.

Использование компонентов

Если включить отчеты об использовании компонентов, SQL Server будет настроен для регулярной отправки отчета в корпорацию Майкрософт. Отчеты будут содержать сведения об оборудовании компьютера и о том, как используется программное обеспечение и службы SQL Server 2005. Корпорация Майкрософт будет использовать эти сведения, чтобы улучшить службы SQL Server. Компоненты SQL Server 2005, контролируемые этим средством, включают в себя:

  • Database Engine

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Репликация

  • Business Intelligence Development Studio

Сведения об использовании возможностей будут отправлены в корпорацию Майкрософт, где будут храниться с ограничением доступа.

Чтобы отключить отчеты об использовании компонентов после завершения установки, воспользуйтесь средством Служба отчетов об ошибках и использовании SQL Server в меню Средства настройки SQL Server 2005.

Сведения собираются раз в день для всех включенных экземпляров SQL Server. По умолчанию сбор запланирован на полночь, что позволяет свести к минимуму нагрузку на сервер. Если необходимо изменить время сбора данных, можно вручную отредактировать раздел реестра, определяющий это время. Каждый экземпляр SQL Server использует собственный раздел реестра. Ниже приведен пример для первого экземпляра SQL Server, установленного на сервере (MSSQL.1):

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

Значение этого раздела реестра содержит время сбора данных как число минут с 00:00 (полуночи) до времени запуска. Например, значение 60 означает запуск сбора в 1:00, а 1200 – в 20:00 и т. д.


Запущенные процессы (исправление)

Запущенные процессы (исправление)
Пользовательский интерфейс программы установки (исправление) >

Во избежание перезапуска Windows после установки пакета обновления 2 для используйте страницу Выполняемые процессы (исправление) мастера установки SQL Server 2005 SP2, чтобы выявить процессы, которыми блокируются файлы, необходимые для программы установки пакета обновления 2 для SQL Server 2005.

Остановите все приложения и службы, которые соединяются с обновляемыми экземплярами SQL Server. К ним относятся среды SQL Server Management Studio и Business Intelligence Development Studio. Необходимо также закрыть панель управления и элемент Установка и удаление программ перед установкой пакета обновления 2 для SQL Server 2005.

  • Чтобы устранить необходимость в перезагрузке компьютера после установки пакета обновления 2 (SP2), программа установки отобразит список процессов, блокирующих файлы. Если программе установки пакета обновления 2 приходится остановить работу службы во время установки, эта служба будет перезапущена программой установки по завершении установки.

  • В случае обнаружения программой установки заблокированных файлов во время установки может возникнуть необходимость в перезагрузке компьютера по завершении установки пакета обновления 2. При необходимости программа установки запрашивает пользователя о перезагрузке компьютера.

Параметры

Если программой установки обнаружены заблокированные файлы, их список будет приведен в таблице. Остановите процессы и приложения, перечисленные в списке, и нажмите кнопку Обновить, чтобы заново выполнить проверку. Нажмите кнопку Остановить, чтобы прервать выполнение проверки. Если заблокированные файлы не обнаружены, таблица будет пустой.

Остановив все блокирующие процессы, нажмите кнопку Далее, чтобы продолжить установку.

Установка пакета обновления 2 (SP2) для SQL Server 2005 на экземпляре отказоустойчивого кластера

Обратите внимание на следующие сведения перед установкой пакета обновления 2 для SQL Server 2005 на экземпляре отказоустойчивого кластера.

  • Не останавливайте службу кластера перед запуском или во время работы программы установки пакета обновления 2.

  • Не завершайте работу процессов перед запуском программы установки пакета обновления 2.

  • Не отключайте службу SQL Server перед запуском программы установки пакета обновления 2. Программа установки самостоятельно выполняет остановку и запуск службы SQL Server.

  • Запускайте программу установки пакета обновления 2 на основном узле экземпляра отказоустойчивого кластера.

  • После завершения установки пакета обновления 2 необходимо перезагрузить все узлы отказоустойчивого кластера.

  • Пакет обновления 2 не поддерживает пошаговое обновление.


Готовность к установке (исправление)

Готовность к установке (исправление)
Пользовательский интерфейс программы установки (исправление) >

Страница Все готово для установки (исправление) мастера установки пакета обновления 2 для сообщает о том, что программа установки пакета обновления 2 для SQL Server 2005 располагает всеми необходимыми данными для установки обновления.

Параметры

Нажмите кнопку Назад, чтобы просмотреть или изменить параметры установки пакета обновления 2 для SQL Server 2005. Чтобы продолжить, нажмите кнопку Установить.


Выполнение установки (исправление)

Выполнение установки (исправление)
Пользовательский интерфейс программы установки (исправление) >

Используйте страницу Выполнение установки (исправление) мастера установки пакета обновления 2 для для наблюдения за ходом применения пакета обновления 2 для SQL Server 2005 к компонентам и экземплярам SQL Server.

Параметры

В таблице содержится имя продукта SQL Server, имя его экземпляра и состояние установки.


Завершение установки (исправления)

Завершение установки (исправления)
Пользовательский интерфейс программы установки (исправление) >

На странице Установка завершена (исправление) мастера установки пакета обновления 2 (SP2) для отображается состояние каждого компонента, обновляемого до версии SQL Server 2005 с пакетом обновления 2 (SP2).

Параметры

Чтобы просмотреть сводный журнал установки пакета обновления 2 (SP2) для SQL Server 2005, нажмите кнопку Просмотреть журнал. Файл сводного журнала сохраняется в папку C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Чтобы просмотреть путь к файлу журнала, щелкните имя компонента. Например, при выборе Собственный клиент SQL Server в области сведений отобразится путь к файлу журнала: C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log.


Дополнительные сведения (исправление)

Дополнительные сведения (исправление)
Пользовательский интерфейс программы установки (исправление) >

Дата обновления: 12 декабря 2006 г.

Страница Дополнительные сведения (исправление) мастера установки пакета обновления 2 (SP2) для содержит флажок, который позволяет запустить Средство подготовки пользователей SQL Server 2005 для Windows Vista. Используйте это средство для обновления списка пользователей, входящих в роль SQL Server «Системный администратор».

Контроль учетных записей, также называемый защитой учетных записей или ограничением учетных записей, — это новая функция системы безопасности в Windows Vista. Контроль учетных записей позволяет пользователям выполнять типичные задачи, не являясь администраторами. Учетные записи пользователей из локальной группы «Администраторы» могут запускать большинство приложений, как и при использовании учетной записи обычного пользователя.

По умолчанию пользователи Windows Vista, не являющиеся членами группы администраторов Windows, автоматически не получают разрешение на соединение с SQL Server. Пользователи также автоматически не получают права администратора. Члены роли системных администраторов SQL Server могут выполнять любые действия в экземпляре SQL Server.

Чтобы разрешить группе администраторов вход с компьютера, работающего под управлением Windows Vista, следует явно добавить учетную запись к именам входа SQL Server.

Параметры

Чтобы обновить список пользователей в роли системных администраторов SQL Server, установите флажок для запуска Средства подготовки пользователей SQL Server 2005 для Windows Vista.

Убедитесь, что поле Выделение ресурсов пользователю содержит данные в виде «ИмяДомена\ИмяПользователя» для пользователя, чьи разрешения нужно обновить. Выберите обновляемую роль из списка экземпляров SQL Server в области Имеющиеся права доступа и нажмите кнопку со стрелкой вправо. Чтобы добавить пользователя ко всем доступным ролям для всех доступных экземпляров SQL Server, дважды нажмите кнопку со стрелкой вправо.

Область справа содержит данные в виде «ИмяДомена\ИмяПользователя» для пользователя, чьи разрешения нужно обновить, а также экземпляры SQL Server и роли, к которым добавляется пользователь.

Чтобы удалить роль из области справа, выберите ее и нажмите кнопку со стрелкой влево. Чтобы удалить все роли из области справа, нажмите кнопку с двойной стрелкой влево. Следует отметить, что действия кнопки со стрелкой влево относятся только к пользователям, ролям и разрешениям, отображаемым в данной программе. В этой программе нет возможности отменить разрешения. Чтобы отменить разрешения для пользователя, администратор должен вручную обновить или удалить учетные данные пользователя.

Чтобы внести сделанные изменения, нажмите кнопку ОК. Чтобы завершить работу программы без внесения изменений, нажмите кнопку Отмена.

Чтобы получить доступ к программе Средство подготовки пользователей SQL Server 2005 для Windows Vista после завершения установки, щелкните ссылку Добавить нового администратора в средстве настройки контактной зоны SQL Server 2005 (SQLSAC.exe).

Список Дополнительные сведения (исправление) содержит ссылки на веб-узлы, содержащие дополнительные сведения о SQL Server. По ссылкам можно получить дополнительные сведения о технической поддержке, обновлениях документации и вариантах обновления .