서비스 팩 설치(핫픽스)

Microsoft SQL Server 2005 서비스 팩 2
서비스 팩 설치(핫픽스)

설치된 모든 SQL Server 2005 구성 요소를 SQL Server 2005 SP2로 업그레이드할 수 있습니다. 기존 SQL Server 2005 구성 요소의 버전 수준이 SP2 버전 수준보다 높은 경우 SP2 설치 프로그램에서는 해당 구성 요소를 업그레이드 작업에서 제외합니다.

SQL Server 2005 SP2를 설치할 때는 다음 사항을 고려해야 합니다.

  • SQL Server 2005 SP2를 적용한 다음에는 전체 제품을 제거해야 해당 서비스 팩을 제거할 수 있습니다.

  • SQL Server의 한 인스턴스에 속하는 모든 기능을 동시에 업그레이드해야 합니다. 예를 들어 Database Services를 업그레이드할 때 Analysis Services가 같은 SQL Server 인스턴스에 설치되어 있으면 함께 업그레이드해야 합니다. 기능 트리에서 구성 요소나 인스턴스를 선택하지 않으면 해당 구성 요소나 인스턴스는 SQL Server 2005 SP2로 업그레이드되지 않습니다.

  • 가능하면 Windows 인증을 사용합니다.

  • SQL Server 인증을 사용할 경우 sa 로그인에 제공하는 암호에는 큰따옴표를 사용할 수 없습니다. 암호에 큰따옴표가 있는 경우에는 SQL Server 2005 SP2를 적용할 때 SQL Server 인증 대신 Windows 인증을 사용하거나 SP2 설치 프로그램을 실행하기 전에 sa 로그인에 대한 암호를 변경해야 합니다.

  • Reporting Services 인스턴스를 업그레이드할 때는 설치 프로그램에서 보고서 서버에 연결하여 보고서 서버 데이터베이스를 업그레이드합니다. 설치 프로그램을 실행하는 사용자의 Windows 계정이 보고서 서버에서 sysadmin 고정 서버 역할의 멤버가 아닌 경우 권한이 충분한 SQL Server 로그인 및 암호를 제공해야 합니다. 이렇게 하려면 인증 모드 대화 상자에서 Reporting Services 인스턴스를 선택하고 필요한 권한이 있는 계정의 자격 증명을 입력한 다음 확인을 클릭합니다.

  • 기본적으로 SQL Server 2005 SP2 설치 로그 파일은 %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\에 저장됩니다.

추가 설명서

다음 출처에서 추가 SQL Server 2005 SP2 설명서를 구할 수 있습니다.

  • SQL Server 2005 SP2 추가 정보 파일.

  • SQL Server 2005 SP2에 대한 Microsoft 기술 자료 문서

디스크 공간 요구 사항

SQL Server 2005 SP2를 다운로드하여 설치하려면 컴퓨터에 1.9GB 이상의 사용 가능한 디스크 공간이 있어야 합니다. 다음 표에서는 디스크 공간 사용률에 대해 설명합니다.

디스크 사용률(MB) | 위치 | 유형
50 | SQL Server 2005 설치 디렉터리 | 영구
1,000 | 시스템 드라이브 | 영구
600 | 임시 디렉터리 | 임시
250 | 다운로드 위치 | 임시

설치 후 컴퓨터에서 250MB의 다운로드 패키지를 제거할 수 있습니다. 설치 후 SQL Server 2005 SP2의 영구 디스크 공간 사용률은 약 1GB입니다.

설치 개요

이 섹션에서는 다음을 수행하는 방법을 비롯하여 SQL Server 2005 SP2 설치에 대한 개요를 제공합니다.

  • SQL Server 2005 SP2 설치 준비

  • SQL Server 2005 SP2 설치

  • 서비스 및 응용 프로그램 다시 시작

SQL Server 2005 SP2 설치 준비

SQL Server 2005 SP2를 설치하기 전에 다음을 수행해야 합니다.

  • SQL Server 2005 데이터베이스 백업 - SQL Server 2005 SP2를 설치하기 전에 master, msdb 및 model 데이터베이스를 백업합니다. SQL Server 2005 SP2를 설치하면 이러한 데이터베이스가 수정되어 SP2 이전 버전의 SQL Server 2005와 호환되지 않습니다. SP2 없이 SQL Server 2005를 다시 설치하려면 이러한 데이터베이스의 백업이 필요합니다.

    사용자 데이터베이스도 백업하는 것이 좋습니다.

중요:
복제 토폴로지에 참가하는 SQL Server 인스턴스에 SP2를 적용할 경우에는 SP2를 적용하기 전에 복제된 데이터베이스를 시스템 데이터베이스와 함께 백업해야 합니다.

  • Analysis Services 데이터베이스, 구성 파일 및 리포지토리 백업 - Analysis Services 인스턴스를 SP2로 업그레이드하기 전에 다음을 백업해야 합니다.

    • Analysis Services 데이터베이스. 기본적으로 이러한 데이터베이스는 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\에 설치되어 있습니다.

    • msmdsrv.ini 구성 파일의 분석 서버 구성 설정. 기본적으로 이 파일은 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\ 디렉터리에 있습니다.

    • (옵션) Analysis Services 리포지토리가 포함된 데이터베이스. 이 단계는 DSO(의사결정 지원 개체) 라이브러리와 함께 작동하도록 분석 서버를 구성한 경우에만 필요합니다.

참고:
Analysis Services 데이터베이스, 구성 파일 및 리포지토리를 백업하지 못하면 업그레이드된 Analysis Service 인스턴스를 이전 버전으로 되돌릴 수 없습니다.

  • 시스템 데이터베이스에 사용 가능한 공간이 충분한지 확인 - master 및 msdb 시스템 데이터베이스에 대해 자동 증가 옵션을 선택하지 않은 경우 이러한 각 데이터베이스에 500KB 이상의 사용 가능한 공간이 있어야 합니다. 데이터베이스에 공간이 충분한지 확인하려면 master 및 msdb 데이터베이스에서 sp_spaceused 시스템 저장 프로시저를 실행합니다. 각 데이터베이스의 할당되지 않은 공간이 500KB보다 적은 경우에는 데이터베이스의 크기를 늘려야 합니다. 자세한 내용은 SQL Server 온라인 설명서의 "데이터베이스 확장"을 참조하십시오.

  • SQL Server 2005 서비스 계정을 사용 및 시작할 수 있는지 확인 - MSSQLServer, MSSQLServerOLAPService 및 ReportServer 서비스의 시작 유형이 사용 안 함으로 설정되어 있으면 설치가 실패할 수 있습니다.

    서비스 계정을 확인하고 사용 가능하도록 설정하려면

    1. 제어판에서 관리 도구, 서비스를 차례로 두 번 클릭합니다.

    2. 목록에서 MSSQLServer 서비스를 찾아 시작 유형의 값을 확인합니다.

    3. 시작 유형의 값이 사용 안 함인 경우 서비스 이름을 두 번 클릭한 다음 시작 유형을 수동 또는 자동으로 변경합니다.

    4. MSSQLServerOLAPService 및 ReportServer 서비스에 대해 2단계와 3단계를 반복한 다음 확인을 클릭합니다.

    5. 설치된 모든 SQL Server 인스턴스에 대해 이 과정을 반복합니다.

  • 서비스 및 응용 프로그램 중지 - SQL Server 2005 SP2를 설치하기 전에 SQL Server Management Studio, Business Intelligence Development Studio, 제어판 및 프로그램 추가/제거를 비롯하여 업그레이드할 SQL Server 인스턴스에 연결된 응용 프로그램 및 서비스를 모두 중지합니다.

참고:
장애 조치(Failover) 클러스터 환경에서는 서비스를 중지할 수 없습니다. 자세한 내용은 이 항목의 뒷부분에 나오는 장애 조치 클러스터 설치 섹션을 참조하십시오.

  • SP2 설치 후 컴퓨터를 다시 시작해야 할 필요가 없도록 설치 프로그램에서는 파일을 잠그는 프로세스의 목록을 표시합니다. SP2 설치 중에 특정 서비스를 끝내야 하는 경우에는 설치를 마친 후 설치 프로그램에서 해당 서비스를 다시 시작합니다.

  • 설치 중에 일부 파일이 잠겨 있다는 사실이 확인되면 SP2 설치가 끝난 후 컴퓨터를 다시 시작해야 할 수 있습니다. 필요할 경우 설치 프로그램에서는 컴퓨터를 다시 시작하라는 메시지를 표시합니다.

SQL Server 2005 SP2 설치

이 섹션에서는 SQL Server 2005 SP2의 설치 과정에 대해 설명합니다.

중요:
SQL Server 2005 SP2 설치 프로그램은 SP2가 설치될 컴퓨터에 대해 관리자 권한이 있는 계정으로 실행해야 합니다.

SQL Server 2005 SP2 설치 시작

SQL Server 2005 SP2를 설치하려면 자동 압축 풀기 패키지 파일 SQLServer2005SP2-KB921896-PPP-LLL.exe를 실행합니다. 여기서 PPP는 특정 플랫폼을 나타내고 LLL은 언어에 따라 달라지는 지정자를 나타냅니다.

참고:
장애 조치 클러스터의 일부인 SQL Server 2005 구성 요소에 SP2를 적용하려면 장애 조치 클러스터 설치에 대한 섹션을 참조하십시오. 무인 모드로 SP2 설치 프로그램을 실행하려면 명령 프롬프트에서 설치(핫픽스)를 참조하십시오.

장애 조치 클러스터 설치

다음 정보는 장애 조치 클러스터의 일부인 SQL Server 2005 구성 요소에만 적용됩니다.

장애 조치 클러스터에 서비스 팩을 설치하려면

  1. 장애 조치 클러스터 인스턴스의 모든 노드에 SQL Server 2005 SP2를 설치하려면 장애 조치 클러스터 인스턴스의 모든 수동 노드에서 작업 스케줄러가 실행되고 있는지 확인합니다.

  2. SQL Server 리소스에 종속된 리소스를 추가한 경우 SQL Server 2005 SP2를 설치하기 전에 해당 종속성을 제거하거나 오프라인으로 설정해야 합니다. 이러한 종속성을 제거하지 않으면 SP2 설치 시 해당 리소스가 오프라인으로 설정됩니다.

    참고:
    클러스터형 리소스를 오프라인으로 설정하면 클러스터 서비스에 의해 모든 종속 리소스도 오프라인으로 설정됩니다.

  3. 업그레이드할 장애 조치 클러스터 인스턴스가 포함된 그룹을 소유하는 활성 노드에서 SQL Server 2005 SP2 패키지 실행 파일을 실행합니다. 이렇게 하면 장애 조치 클러스터의 모든 노드에 서비스 팩 파일이 설치됩니다. 장애 조치 클러스터의 수동 노드에서는 SP2를 설치할 수 없습니다.

  4. SQL Server 2005 SP2 설치 마법사의 기능 선택 페이지에서 업그레이드할 장애 조치 클러스터 인스턴스를 선택합니다. 클러스터의 다른 노드에 연결하는 데 사용되는 로그인 자격 증명을 묻는 메시지가 표시됩니다.

    참고:
    설치하는 동안 클러스터의 모든 노드를 온라인 상태로 유지합니다. 이렇게 하면 업그레이드가 각 클러스터 노드에 적용됩니다.

  5. 1단계에서 종속성을 제거하거나 리소스를 오프라인으로 설정한 경우 종속성을 복원하거나 리소스를 온라인으로 설정합니다.

    참고:
    장애 조치 클러스터 노드를 다시 시작해야 할 수 있습니다. 그러면 설치하는 동안 사용된 파일이 대체됩니다.
SQL Server 2005 SP2 장애 조치 클러스터 노드 다시 작성

SP2를 적용한 다음 장애 조치 클러스터에서 노드를 다시 작성해야 하는 경우 다음 단계를 수행하십시오.

  1. 장애 조치 클러스터에서 노드를 다시 작성합니다. 노드를 다시 작성하는 방법은 SQL Server 온라인 설명서의 "방법: 시나리오 1의 장애 조치(Failover) 클러스터 오류 복구"를 참조하십시오.

  2. 원본 SQL Server 2005 설치 프로그램을 실행하여 노드를 장애 조치 클러스터로 복원합니다.

  3. 추가한 노드에서 SQL Server 2005 SP2 설치 프로그램을 실행합니다.

서비스 및 응용 프로그램 다시 시작

설치가 완료되면 컴퓨터를 다시 시작하라는 메시지가 표시될 수 있습니다. 시스템이 다시 시작된 후 또는 다시 시작하라는 메시지가 표시되지 않고 설치가 완료된 후에는 제어판에서 서비스 노드를 사용하여 SQL Server 2005 SP2를 적용하기 전에 중지한 서비스를 다시 시작합니다.

이러한 서비스에는 Distributed Transaction Coordinator 및 Microsoft Search 서비스 또는 인스턴스별 서비스가 포함됩니다. SQL Server 2005 SP2 설치 프로그램을 실행하기 전에 닫은 응용 프로그램을 다시 시작합니다. 설치가 완료된 다음 업그레이드된 master, msdb 및 model 데이터베이스를 즉시 다시 백업할 수도 있습니다.


명령 프롬프트에서 설치(핫픽스)

명령 프롬프트에서 설치(핫픽스)

설치를 진행하기 전에 서비스 팩 설치(핫픽스)에서 설치 고려 사항을 검토하십시오.

SQL Server 2005 SP2의 무인 설치에 대해 다음 명령 프롬프트 스위치가 지원됩니다. 조직의 필요에 따라 설치 스크립트를 테스트하고 수정하십시오.

중요:
가능하면 런타임에 보안 자격 증명을 지정하십시오. 스크립트 파일에 자격 증명을 저장해야 하는 경우에는 무단으로 액세스하지 못하도록 파일에 보안을 설정하십시오.

스위치

설명

/?

무인 설치 명령 프롬프트 도움말을 표시합니다.

/allinstances

SQL Server 2005 SP2를 모든 SQL Server 2005 인스턴스와 모든 SQL Server 2005 공유 인스턴스 비인식 구성 요소에 적용합니다.

/instancename=InstanceName

SQL Server 2005 SP2를 InstanceName이라는 SQL Server 2005 인스턴스와 모든 SQL Server 2005 공유 인스턴스 비인식 구성 요소에 적용합니다.

/password=Password

원격 장애 조치(Failover) 클러스터 노드에 연결하기 위한 사용자 계정 암호입니다.

/quiet

무인 모드로 SQL Server 2005 SP2 설치 프로그램을 실행합니다.

/reportonly

설치 프로그램의 검색 및 열거 섹션만 실행되고 SQL Server 2005의 로컬 인스턴스 및 구성 요소를 열거하는 보고서가 표시됩니다.

참고:
이 스위치를 사용하면 SQL Server 2005 SP2가 적용되지 않습니다.

/rsupgradedatabaseaccount=rsAccountName

SQL Server 인증을 사용할 때 보고서 서버 데이터베이스에서 스키마를 수정할 수 있는 권한이 있는 계정을 지정합니다. 이 매개 변수는 SQL Server 로그인이 필요한 보고서 서버 데이터베이스가 포함된 Reporting Services 인스턴스를 업그레이드할 때 사용됩니다.

/rsupgradepassword=rsPassword

원격 보고서 서버 데이터베이스에서 스키마를 수정할 수 있는 권한이 있는 계정의 암호를 지정합니다. 이 매개 변수는 원격 보고서 서버 데이터베이스가 포함된 Reporting Services 인스턴스를 업그레이드할 때 사용됩니다.

/rsupgradedatabase

스위치 /rsupgradedatabase=0을 사용하여 Reporting Services 데이터베이스가 업그레이드되지 않도록 할 수 있습니다.

/sapwd=SaLoginPassword

스크립트를 실행할 수 있도록 sa 로그인에 대한 SQL Server 인증 암호를 전달합니다.

참고:
/sapwd에 대한 문자를 이스케이프 처리하지 마십시오. 이스케이프 처리하면 설치에 실패할 수 있습니다.

/user=Domain\UserName

원격 장애 조치 클러스터 노드에 연결하기 위한 사용자 계정입니다.


저작권 표시(핫픽스)

저작권 표시(핫픽스)

예제 응용 프로그램을 포함하는 이 설명서는 오직 정보를 제공하기 위한 것이며 어떠한 명시적이거나 묵시적인 보증도 제공하지 않습니다. URL 및 기타 인터넷 웹 사이트 참조를 포함하여 이 설명서의 내용은 예고 없이 변경될 수 있습니다. 이 설명서의 사용이나 사용 결과에 따른 책임은 전적으로 사용자에게 있습니다.

이 설명서에 포함된 예제는 주로 특정 문이나 절의 개념을 설명하거나 적당한 사용법을 보여 주기 위한 것입니다. 특정 개념이나 문에 대한 예제를 중점적으로 제공하기 위해 일반적인 데이터 유효성 검사 및 오류 처리의 일부가 제거되었으므로 대부분의 예제에 전체 프로덕션 시스템에서 일반적으로 찾을 수 있는 모든 코드가 포함되어 있지는 않습니다. 이러한 예제나 포함된 원본 코드에 대한 기술 지원은 받을 수 없습니다.

다른 설명이 없는 한, 용례에 사용된 회사, 기관, 제품, 도메인 이름, 전자 메일 주소, 사람, 장소 및 이벤트 등은 실제 데이터가 아닙니다. 어떠한 실제 회사, 기관, 제품, 도메인 이름, 전자 메일 주소, 사람, 장소 또는 이벤트와도 연관시킬 의도가 없으며 그렇게 유추해서도 안 됩니다. 해당 저작권법을 준수하는 것은 사용자의 책임입니다. 저작권에서의 권리와는 별도로, 이 설명서의 어떠한 부분도 Microsoft의 명시적인 서면 승인 없이는 어떠한 형식이나 수단(전기적, 기계적, 복사기에 의한 복사, 디스크 복사 또는 다른 방법) 또는 목적으로도 복제되거나, 검색 시스템에 저장 또는 도입되거나, 전송될 수 없습니다.

Microsoft가 이 설명서 본안에 관련된 특허권, 상표권, 저작권, 또는 기타 지적 재산권 등을 보유할 수도 있습니다. 서면 사용권 계약에 따라 Microsoft로부터 귀하에게 명시적으로 제공된 권리 이외에 이 설명서의 제공은 귀하에게 이러한 특허권, 상표권, 저작권, 또는 기타 지적 재산권 등에 대한 어떠한 사용권도 허여하지 않습니다.

ⓒ 2006 Microsoft Corporation. All rights reserved.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows 서버 시스템 및 WinFX는 미국, 대한민국 및/또는 기타 국가에서의 Microsoft Corporation 등록 상표 또는 상표입니다.

SAP NetWeaver는 독일 및 기타 여러 국가에서의 SAP AG 등록 상표입니다.

다른 모든 상표는 해당 소유자의 상표입니다.

SQL Server 2005 지원 및 업그레이드에 대한 설명서 정책

SQL Server 설명서에 나오는 내용은 충분한 테스트를 거친 후에만 발표됩니다. SQL Server 온라인 설명서, 추가 정보 파일, 알려진 문제점 문서 및 기술 자료 문서를 포함하는 제품 설명서에는 모든 고객이 일반적인 용도로 사용해도 문제가 되지 않을 만큼 안전한 SQL Server 기능과 관련된 내용이 포함되어 있습니다. 이 정책은 릴리스 및 서비스 팩에 대한 추가 정보 파일을 비롯한 모든 SQL Server 설명서에 적용됩니다. 추가 정보 파일은 온라인 설명서의 내용을 보완합니다.

고객이 직접 사용해서는 안 되는 기능의 경우 설명서에 나와 있지 않습니다. Microsoft에서 발표한 SQL Server 설명서에서 다루어지지 않는 기능의 경우 타사 설명서나 웹 사이트에 해당 기능에 대한 내용이 제공되어도 Microsoft CSS(고객 지원 서비스)에서 이러한 내용을 지원하지 않으므로 프로덕션 데이터베이스나 응용 프로그램에서 해당 기능을 사용하면 안 됩니다.

고객들은 저장 프로시저, 확장 저장 프로시저, 함수, 뷰, 테이블, 열, 속성 또는 메타데이터를 비롯하여(이에 국한되지 않음) 설명서에서 다루지 않는 API를 사용해서는 안 됩니다. Microsoft 고객 지원 서비스에서는 설명서에 나와 있지 않은 실행 방식을 지원 또는 사용하는 데이터베이스나 응용 프로그램은 지원하지 않습니다.

설명서에 나와 있지 않은 실행 방식을 지원 및 사용하는 응용 프로그램 및 데이터베이스의 경우 후속 버전의 SQL Server로 업그레이드할 수 있다고 보장할 수 없습니다. Microsoft SQL Server 설명서에 포함되어 있는 SQL Server 기능만 사용해야 합니다. Microsoft SQL Server 설명서에서 다루어지지 않은 기능은 지원되지 않습니다.


설치 사용자 인터페이스(핫픽스)

설치 사용자 인터페이스(핫픽스)

다음 항목에서는 SQL Server 2005 SP2의 설치 과정에서 필요한 선택 옵션에 대한 추가 정보를 제공합니다. 도움말 항목을 보려면 해당 링크를 클릭합니다.

사용 약관(핫픽스)

기능 선택(핫픽스)

인증 모드(핫픽스)

원격 인증(핫픽스)

오류 및 사용 보고(핫픽스)

실행 중인 프로세스(핫픽스)

설치 준비 완료(핫픽스)

설치 진행률(핫픽스)

설치 완료(핫픽스)

추가 정보(핫픽스)


사용 약관(핫픽스)

사용 약관(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 사용 약관(핫픽스) 페이지를 사용하여 이 릴리스의 사용 약관에 동의할 수 있습니다.

옵션

SQL Server 2005 SP2 설치를 계속하려면 SQL Server 2005 SP2 사용 약관에 동의함을 나타내는 라디오 단추를 클릭해야 합니다. 그런 후 다음을 클릭하여 계속할 수 있습니다.

인쇄 단추를 사용하여 이 릴리스의 사용 약관 복사본을 인쇄할 수 있습니다. SQL Server 2005 SP2 설치를 끝내려면 취소를 클릭합니다.


기능 선택(핫픽스)

기능 선택(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 기능 선택(핫픽스) 페이지를 사용하여 업데이트할 SQL Server 구성 요소 및 기능을 선택할 수 있습니다.

옵션

언어, 운영 체제, 버전 및 상태 정보를 보려면 왼쪽 창에서 기능 이름을 클릭합니다.

구성 요소나 기능을 업데이트하려면 기능 이름 옆의 확인란을 선택합니다. 이 업데이트에서 구성 요소나 기능을 제외하려면 기능 이름 옆의 확인란을 선택 취소합니다.

단일 컴퓨터에 있는 SQL Server 2005의 여러 인스턴스는 각기 다른 시간에 업데이트할 수 있지만 SQL Server의 한 인스턴스에 있는 모든 구성 요소는 동시에 업그레이드해야 합니다. 워크스테이션 구성 요소, MSXML 파서, SQLXML, Backward Compatibility 구성 요소 및 VSS Writer와 같은 모든 공유 구성 요소는 SQL Server 2005 SP2로 업그레이드해야 합니다.

구성 요소를 업그레이드할 수 없는 경우 자세히 창에 설명이 제공됩니다.


인증 모드(핫픽스)

인증 모드(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 인증 모드(핫픽스) 페이지를 사용하여 업데이트할 SQL Server 인스턴스에 연결하는 데 사용되는 인스턴스 및 인증 정보를 제공할 수 있습니다.

옵션

업데이트할 모든 구성 요소나 인스턴스에 대해 인증 모드, 사용자 이름 및 암호가 같은 경우 모든 인스턴스에 선택 사항 적용 확인란을 선택합니다. 이 옵션을 선택하면 인스턴스 이름 드롭다운을 사용할 수 없게 됩니다. 인증 유형, 사용자 이름 및 암호 정보를 제공한 다음 테스트를 클릭하여 자격 증명을 확인합니다.

업데이트할 모든 구성 요소에 대해 인증 모드, 사용자 이름 및 암호가 같지 않은 경우 업데이트할 각 구성 요소나 인스턴스에 대해 인스턴스 이름, 인증 유형, 사용자 이름 및 암호 정보를 제공한 다음 테스트를 클릭하여 자격 증명을 확인합니다.

SQL Server의 각 구성 요소나 각 인스턴스에 대해 자격 증명을 테스트하면 상태 테이블이 결과로 채워집니다. 테이블에 모든 구성 요소가 나열되고 모든 상태가 "성공"이면 다음을 클릭하여 계속합니다. 계속하기 전에 모든 인증 문제를 해결해야 합니다.

인증이 실패하는 경우 구성 요소에 대한 정보를 업데이트한 다음 확인 테스트를 다시 시도합니다. 테이블에 모든 구성 요소가 나열되고 모든 상태가 "성공"이면 다음을 클릭하여 계속합니다.


원격 인증(핫픽스)

원격 인증(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 원격 인증(핫픽스) 페이지를 사용하여 업데이트할 SQL Server의 장애 조치(Failover) 클러스터 인스턴스에 대한 원격 로그온 정보를 제공할 수 있습니다.

옵션

사용자 이름

로그온 필드가 미리 채워져 있지 않은 경우 장애 조치 클러스터의 모든 노드에 대해 유효한 관리자 계정이 되는 사용자 이름을 지정합니다.

암호

선택한 관리자 계정의 암호를 지정합니다.

도메인

선택한 관리자 계정의 도메인 이름을 지정합니다.


오류 및 사용 보고(핫픽스)

오류 및 사용 보고(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 오류 및 사용 보고(핫픽스) 페이지를 사용하여 SQL Server 2005의 기능 오류 및 사용 보고 기능을 설정할 수 있습니다.

옵션

SQL Server SP2에는 서비스 오류 보고서를 자동으로 Microsoft 또는 사용자 회사의 오류 보고 서버로 보내도록 SQL Server를 구성하는 옵션이 있습니다. 이 페이지에서 확인란의 선택을 취소하여 두 가지 옵션 중 하나 또는 둘 다를 해제할 수 있습니다. 이러한 오류 보고는 Microsoft에서 SQL Server의 기능을 향상시키는 데 사용되며 모든 오류 보고 및 기능 사용 데이터는 기밀로 유지됩니다.

오류 보고

오류 보고 기능을 설정하면 SQL Server는 다음 SQL Server 구성 요소에서 오류가 발생할 경우 자동으로 Microsoft에 보고서를 보내도록 구성됩니다.

  • 데이터베이스 엔진

  • SQL Server 에이전트

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 복제

오류 보고는 Microsoft에서 SQL Server의 기능을 향상시키는 데 사용되며 모든 정보는 기밀로 유지됩니다.

오류 정보는 보안 연결(HTTPS)을 통해 Microsoft로 전송되며 액세스가 제한된 위치에 저장됩니다. 오류 보고서를 사용자 회사의 오류 보고 서버로 보낼 수도 있습니다. 회사의 오류 보고 서버를 설정하는 방법은 Corporate Error Reporting 웹 사이트를 참조하십시오.

오류 보고서에는 다음 정보가 포함됩니다.

  • 문제 발생 시 SQL Server의 상태

  • 운영 체제 버전 및 컴퓨터 하드웨어 정보

  • 라이센스 확인에 사용되지 않는 디지털 제품 ID

  • 컴퓨터 또는 프록시 서버의 네트워크 IP 주소

  • 오류가 발생한 프로세스와 관련된 메모리 또는 파일 정보

Microsoft에서는 사용자의 파일, 이름, 주소, 전자 메일 주소 또는 기타 형태의 개인 정보를 의도적으로 수집하지 않습니다. 그러나 오류 보고서에는 오류가 발생한 프로세스와 관련된 메모리 또는 파일에 있는 개인 정보가 포함될 수 있습니다. 이러한 정보는 사용자의 신분을 확인하는 데 사용될 가능성이 있지만 Microsoft에서는 그러한 의도로 해당 정보를 사용하지 않습니다.

개인 정보 보호 및 데이터 수집 정책에 대한 자세한 내용은 SQL Server 2005 Privacy Statement를 참조하십시오.

오류 보고 기능을 설정한 상태에서 오류가 발생하면 특정 오류에 대한 Microsoft 기술 자료 문서를 가리키는 Microsoft의 응답을 Windows 이벤트 로그에서 확인할 수 있습니다.

설치가 완료된 후에 SQL Server 및 해당 구성 요소의 모든 인스턴스에 대해 오류 또는 기능 사용 보고를 해제하려면 오류 및 사용 보고서 설정 대화 상자(시작, 모든 프로그램, Microsoft SQL Server 2005, 구성 도구, SQL Server 오류 및 사용 보고)로 이동하여 기능 사용 확인란의 선택을 취소합니다. 오류 보고가 SQL Server의 여러 구성 요소(데이터베이스 엔진, 분석 서버, 보고서 서버 및 공유 구성 요소)에 대해 설정되어 있으면 개별 구성 요소의 각 인스턴스에 대해 오류 보고를 해제할 수 있습니다. 기타로 나열된 공유 구성 요소에 대해 오류 보고를 해제할 수도 있습니다.

기능 사용

기능 사용 보고를 설정하면 SQL Server는 Microsoft로 보고서를 주기적으로 보내도록 구성됩니다. 보고서에는 하드웨어 구성에 대한 정보와 사용자가 SQL Server 2005 소프트웨어 및 서비스를 사용한 방식이 포함됩니다. 기능 사용 데이터는 Microsoft에서 SQL Server를 개선하는 데 사용됩니다. 이 기능을 통해 모니터링되는 SQL Server 2005 구성 요소는 다음과 같습니다.

  • 데이터베이스 엔진

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 복제

  • Business Intelligence Development Studio

기능 사용에 대한 정보는 Microsoft로 전송되며 액세스가 제한된 위치에 저장됩니다.

설치가 완료된 후에 기능 사용 보고를 해제하려면 SQL Server 2005 구성 도구 메뉴의 SQL Server 오류 및 사용 보고 도구를 사용합니다.

설정된 모든 SQL Server 인스턴스에 대해 하루에 한 번씩 정보가 수집됩니다. 기본적으로 수집 시간은 서버 로드를 최소화하기 위해 자정으로 설정됩니다. 수집 시간을 변경하려는 경우 수집 시간을 제어하는 레지스트리 키를 수동으로 편집할 수 있습니다. 각 SQL Server 인스턴스에는 자체 레지스트리 키가 있습니다. 다음은 서버에 설치된 첫 번째 SQL Server 인스턴스(MSSQL.1)에 대한 예입니다.

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

이 레지스트리 키 값에는 수집 실행 시간이 00:00(자정)부터 경과된 분 수로 포함되어 있습니다. 예를 들어 값 60은 오전 1시에 수집이 실행되었음을 나타내고 값 1200은 오후 8시에 수집이 실행되었음을 나타냅니다.


실행 중인 프로세스(핫픽스)

실행 중인 프로세스(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2를 설치한 다음 Windows를 다시 시작하지 않으려면 SQL Server 2005 SP2 설치 마법사의 실행 중인 프로세스(핫픽스) 페이지를 사용하여 SQL Server 2005 SP2 설치에 필요한 프로세스 중 파일을 잠그는 프로세스를 식별할 수 있습니다.

업그레이드할 SQL Server 인스턴스에 연결된 응용 프로그램 및 서비스를 모두 중지합니다. 여기에는 SQL Server 2005 SP2를 설치하기 전에 SQL Server Management Studio 및 Business Intelligence Development Studio를 중지하고 제어판 및 프로그램 추가/제거를 닫는 작업이 포함됩니다.

  • SP2 설치 후 컴퓨터를 다시 시작해야 할 필요가 없도록 설치 프로그램에서는 파일을 잠그는 프로세스의 목록을 표시합니다. SP2 설치 중에 특정 서비스를 끝내야 하는 경우에는 설치를 마친 후 설치 프로그램에서 해당 서비스를 다시 시작합니다.

  • 설치 중에 일부 파일이 잠겨 있다는 사실이 확인되면 SP2 설치가 끝난 후 컴퓨터를 다시 시작해야 할 수 있습니다. 필요할 경우 설치 프로그램에서는 컴퓨터를 다시 시작하라는 메시지를 표시합니다.

옵션

설치 프로그램에서 잠겨 있는 파일을 검색하면 테이블에 해당 파일이 나열됩니다. 목록에 나열된 프로세스 및 응용 프로그램을 중지하거나 끝낸 다음 새로 고침을 클릭하여 검사를 다시 실행합니다. 실행하고 있는 검사를 끝내려면 중지를 클릭합니다. 잠겨 있는 파일이 없으면 테이블이 비어 있게 됩니다.

잠금 프로세스가 모두 종료되면 다음을 클릭하여 계속합니다.

장애 조치(Failover) 클러스터 인스턴스에 SQL Server 2005 SP2 설치

장애 조치 클러스터 인스턴스에 SQL Server 2005 SP2를 설치하기 전에 다음 정보를 참조하십시오.

  • SP2 설치 프로그램을 실행하기 전 또는 설치 프로그램이 실행되고 있을 때 클러스터 서비스를 중지하지 마십시오.

  • SP2 설치 프로그램을 실행하기 전에 실행 중인 어떤 프로세스도 종료하지 마십시오.

  • SP2 설치 프로그램을 실행하기 전에 SQL Server 서비스를 오프라인으로 만들지 마십시오. SP2 설치 프로그램에서 SQL Server 서비스를 중지하고 실행합니다.

  • SP2 설치 프로그램을 장애 조치 클러스터 인스턴스의 주 노드에서 실행하십시오.

  • SP2의 설치가 끝나면 모든 장애 조치 클러스터 노드를 다시 시작해야 합니다.

  • SP2에서는 롤링 업그레이드가 지원되지 않습니다.


설치 준비 완료(핫픽스)

설치 준비 완료(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 설치 준비 완료(핫픽스) 페이지는 업데이트를 설치하는 데 필요한 정보가 SQL Server 2005 SP2 설치 프로그램에 있음을 나타냅니다.

옵션

SQL Server 2005 SP2 설치 옵션을 검토하거나 변경하려면 뒤로를 클릭합니다. 계속하려면 설치를 클릭합니다.


설치 진행률(핫픽스)

설치 진행률(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 설치 진행률(핫픽스) 페이지를 사용하여 사용자 SQL Server 구성 요소 및 인스턴스에 SQL Server 2005 SP2가 적용될 때 설치를 모니터링할 수 있습니다.

옵션

표에서 SQL Server 제품 이름, 해당 인스턴스 이름 및 설치 상태를 보여 줍니다.


설치 완료(핫픽스)

설치 완료(핫픽스)
설치 사용자 인터페이스(핫픽스) >

SP2 설치 마법사의 설치 완료(핫픽스) 페이지에서는 SQL Server 2005 SP2로 업데이트된 각 구성 요소의 상태를 보여 줍니다.

옵션

SQL Server 2005 SP2 설치의 요약 로그를 보려면 요약 보기를 클릭합니다. 요약 로그 파일은 C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\에 저장됩니다.

로그 파일의 경로를 보려면 구성 요소 이름을 클릭합니다. 예를 들어 SQL Server Native Client를 클릭하면 세부 정보 창에 로그 파일의 경로인 C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log가 표시됩니다.


추가 정보(핫픽스)

추가 정보(핫픽스)
설치 사용자 인터페이스(핫픽스) >

업데이트: 2006년 12월 12일

SP2 설치 마법사의 추가 정보(핫픽스) 페이지에는 Windows Vista에 대한 SQL Server 2005 사용자 제공 도구를 열 수 있는 확인란이 있습니다. 이 제공 도구를 사용하여 SQL Server에 대한 시스템 관리자 역할의 사용자 목록을 업데이트합니다.

UAP(사용자 계정 보호) 또는 LUA(제한된 사용자 계정)라고도 하는 UAC(사용자 계정 컨트롤)는 Windows Vista에서 제공되는 새로운 보안 기능입니다. UAC를 통해 사용자는 비관리자로 일반 작업을 수행할 수 있습니다. 로컬 Administrators 그룹의 멤버인 사용자 계정은 표준 사용자 계정을 사용하는 경우처럼 대부분의 응용 프로그램을 실행합니다.

Windows Administrators 그룹의 멤버인 Windows Vista 사용자의 경우 기본적으로 SQL Server에 연결할 수 있는 권한이 자동으로 부여되지 않습니다. 또한 관리 자격 증명도 사용자에게 자동으로 부여되지 않습니다. SQL Server 시스템 관리자 역할의 멤버는 SQL Server 인스턴스의 모든 작업을 수행할 수 있습니다.

Administrators 그룹의 멤버가 Windows Vista이 실행되는 컴퓨터에서 로그인할 수 있도록 하려면 SQL Server 로그인에 계정을 명시적으로 추가해야 합니다.

옵션

SQL Server 시스템 관리자 역할의 사용자 목록을 업데이트하려면 확인란을 사용하여 Windows Vista에 대한 SQL Server 2005 사용자 제공 도구를 시작합니다.

제공할 사용자 필드에 권한이 업데이트되어야 할 사용자의 DomainName\UserName이 나열되어야 합니다. 사용 가능한 권한 창에 있는 SQL Server 인스턴스 목록에서 업데이트할 역할을 선택한 다음 오른쪽 화살표를 클릭합니다. SQL Server 인스턴스의 모든 인스턴스에 대해 모든 역할을 사용할 수 있도록 사용자를 추가하려면 오른쪽 화살표를 두 번 클릭합니다.

오른쪽 창에는 권한이 업데이트될 사용자의 DomainName\UserName, SQL Server 인스턴스 및 추가할 사용자의 역할이 나열됩니다.

오른쪽 창에서 역할을 제거하려면 역할을 선택한 다음 왼쪽 화살표를 클릭합니다. 오른쪽 창에서 모든 역할을 제거하려면 왼쪽 화살표를 두 번 클릭합니다. 왼쪽 화살표 기능은 도구에 표시된 사용자, 역할 및 권한에만 영향을 줍니다. 도구에는 권한을 취소하는 기능이 없습니다. 사용자의 권한을 취소하려면 관리자가 사용자의 자격 증명을 직접 업데이트하거나 제거해야 합니다.

선택 작업이 완료된 경우 변경 내용을 구현하려면 확인을 클릭합니다. 변경 없이 도구를 끝내려면 취소를 클릭합니다.

이 설치 프로그램이 종료된 후 Windows Vista에 대한 SQL Server 2005 사용자 제공 도구에 액세스하려면 SQL Server 2005 노출 영역 구성 도구(SQLSAC.exe)의 새 관리자 추가 링크를 클릭합니다.

추가 정보(핫픽스) 링크 목록은 추가 SQL Server 정보를 제공하는 웹 사이트에 대한 링크를 제공합니다. 이 링크에는 SQL Server에 대한 Microsoft 업데이트 옵션, 도움말 업데이트 및 기술 지원 서비스에 대한 추가 정보가 포함되어 있습니다.