Service Pack のインストール (修正プログラム)

Microsoft SQL Server 2005 Service Pack 2
Service Pack のインストール (修正プログラム)

インストールした SQL Server 2005 コンポーネントはどれでも SQL Server 2005 SP2 にアップグレードできます。既存の SQL Server 2005 コンポーネントのバージョン レベルが SP2 のバージョン レベルより高い場合、そのコンポーネントは SP2 セットアップ プログラムによって自動的にアップグレードから除外されます。

SQL Server 2005 SP2 をインストールする際は、次の点について注意してください。

  • SQL Server 2005 SP2 の適用後、これを削除するには製品全体のアンインストールが必要になります。

  • 1 つの SQL Server インスタンスに属する機能はすべて同時にアップグレードする必要があります。たとえば、Database Services をアップグレードするとき、同じ SQL Server インスタンスに Analysis Services がインストールされている場合は、Analysis Services もアップグレードする必要があります。機能ツリーで選択されていないコンポーネントまたはインスタンスは、SQL Server 2005 SP2 にはアップグレードされません。

  • できるだけ Windows 認証を使用してください。

  • SQL Server 認証を使用する場合、sa ログインのパスワードに二重引用符を含めることはできません。パスワードに二重引用符がある場合は、SQL Server 2005 SP2 の適用時に SQL Server 認証ではなく Windows 認証を使用するか、SP2 セットアップの実行前に sa ログインのパスワードを変更してください。

  • Reporting Services インスタンスをアップグレードすると、セットアップによってレポート サーバーに接続が行われ、レポート サーバー データベースがアップグレードされます。セットアップを実行するユーザーの Windows アカウントがレポート サーバーの固定サーバー ロール sysadmin のメンバでない場合は、十分な特権のある SQL Server ログインとパスワードを入力する必要があります。これには、[認証モード] ダイアログ ボックスで Reporting Services インスタンスを選択し、必要な特権のあるアカウントの資格情報を入力して、[OK] をクリックします。

  • 既定では、SQL Server 2005 SP2 セットアップのログ ファイルは %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\ に保存されます。

関連ドキュメント

SQL Server 2005 SP2 関連のドキュメントは次のソースから入手できます。

  • SQL Server 2005 SP2 Readme ファイル。

  • SQL Server 2005 SP2 に関するサポート技術情報の資料。

必要なディスク領域

SQL Server 2005 SP2 をダウンロードしてインストールするには、コンピュータに 1.9 GB 以上の空きディスク領域が必要です。次の表に、ディスク領域の使用量の内訳を示します。

ディスク使用量 (MB) | 場所 | 種類
50 | SQL Server 2005 インストール ディレクトリ | 恒久的
1,000 | システム ドライブ | 恒久的
600 | Temp ディレクトリ | 一時的
250 | ダウンロード場所 | 一時的

インストール後、コンピュータからは 250 MB のダウンロード パッケージを削除できます。インストール後の SQL Server 2005 SP2 による恒久的なディスク領域の使用量は約 1 GB です。

インストールの概要

ここでは、SQL Server 2005 SP2 のインストールの概要として、次の各方法について説明します。

  • SQL Server 2005 SP2 のインストールの準備

  • SQL Server 2005 SP2 のインストール

  • サービスとアプリケーションの再起動

SQL Server 2005 SP2 のインストールの準備

SQL Server 2005 SP2 をインストールする前には、次のことを実行する必要があります。

  • SQL Server 2005 データベースをバックアップする - SQL Server 2005 SP2 をインストールする前に、master データベース、msdb データベース、model データベースをバックアップします。SQL Server 2005 SP2 をインストールするとこれらのデータベースは更新され、SP2 よりも前のバージョンの SQL Server 2005 と互換性がなくなります。SP2 を適用しない SQL Server 2005 を再インストールする場合には、これらのデータベースのバックアップ データが必要になります。

    念のため、ユーザー データベースもバックアップしておくことをお勧めします。

重要 :
レプリケーション トポロジに含まれる SQL Server インスタンスに SP2 を適用する場合は、適用前に、システム データベースに加えてレプリケートされたデータベースもバックアップする必要があります。

  • Analysis Services データベース、構成ファイル、リポジトリをバックアップする - Analysis Services インスタンスを SP2 にアップグレードする前には、次のものをバックアップする必要があります。

    • Analysis Services データベース。既定では、C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\ にインストールされています。

    • msmdsrv.ini 構成ファイル内の分析サーバーの構成設定。既定では、C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\ ディレクトリにあります。

    • (省略可能) Analysis Services のリポジトリを含むデータベース。この手順が必要になるのは、分析サーバーが Decision Support オブジェクト (DSO) ライブラリを使用するように構成されている場合のみです。

メモ :
Analysis Services データベース、構成ファイル、リポジトリをバックアップしなかった場合、アップグレード後の Analysis Services インスタンスを以前のバージョンに戻すことはできなくなります。

  • システム データベースに十分な空き領域があるかどうかを確認する - master システム データベースおよび msdb システム データベースに autogrow オプションが選択されていない場合は、これらのデータベースにそれぞれ 500 KB 以上の空き領域が必要です。データベースに十分な空き領域があるかどうかを確認するには、master データベースと msdb データベースで sp_spaceused システム ストアド プロシージャを実行します。どちらかのデータベースで空き領域が 500 KB 未満になっている場合は、そのデータベースのサイズを大きくしてください。詳細については、SQL Server Books Online の「データベースの拡張」を参照してください。

  • SQL Server 2005 のサービス アカウントが無効になっていないこと、開始可能であることを確認する - MSSQLServer サービス、MSSQLServerOLAPService サービス、ReportServer サービスのサービス スタートアップの種類が無効に設定されていると、セットアップが失敗する可能性があります。

    サービス アカウントを確認し有効にするには、次の手順を実行します。

    1. コントロール パネルの [管理ツール] をダブルクリックし、[サービス] をダブルクリックします。

    2. 一覧で [MSSQLServer] サービスを探し、[スタートアップの種類] の値を確認します。

    3. [スタートアップの種類] の値が [無効] の場合は、サービス名をダブルクリックし、[スタートアップの種類] の値を [手動] または [自動] に変更します。

    4. [MSSQLServerOLAPService] サービスと [ReportServer] サービスに対しても手順 2. と手順 3. を繰り返し、[OK] をクリックします。

    5. インストールされているすべての SQL Server インスタンスに対し、上記の手順を繰り返します。

  • サービスとアプリケーションを停止する - SQL Server 2005 SP2 をインストールする前に、SQL Server Management Studio、Business Intelligence Development Studio、コントロール パネル、[プログラムの追加と削除] など、アップグレードする SQL Server インスタンスに接続しているすべてのアプリケーションとサービスを停止します。

メモ :
クラスタ環境ではサービスを停止できません。詳細については、後のフェールオーバー クラスタのインストールに関するセクションを参照してください。

  • SP2 のインストール後にコンピュータを再起動しなくてもいいように、セットアップではファイルをロックしているプロセスが一覧表示されます。SP2 セットアップ プログラムで、インストール中にサービスを終了する必要があった場合、インストールの完了後にそのサービスが再起動されます。

  • セットアップで、インストール中にファイルがロックされていると認識された場合、SP2 のインストール完了後にコンピュータの再起動が必要になることがあります。再起動が必要な場合は、コンピュータの再起動を促すプロンプトが表示されます。

SQL Server 2005 SP2 のインストール

ここでは、SQL Server 2005 SP2 セットアップの実行中のインストール手順について説明します。

重要 :
SQL Server 2005 SP2 セットアップは、SP2 をインストールするコンピュータに対し管理者特権のあるアカウントで実行する必要があります。

SQL Server 2005 SP2 セットアップの開始

SQL Server 2005 SP2 をインストールするには、自己展開型のパッケージ ファイル SQLServer2005SP2-KB921896-PPP-LLL.exe を実行します。ここで PPP は特定のプラットフォーム、LLL は言語ごとの指定子を表します。

メモ :
フェールオーバー クラスタに含まれる SQL Server 2005 コンポーネントに SP2 を適用するには、フェールオーバー クラスタのインストールに関するセクションを参照してください。SP2 セットアップを自動実行モードで実行するには、「コマンド プロンプトからのインストール (修正プログラム)」を参照してください。

フェールオーバー クラスタのインストール

次に示す情報は、フェールオーバー クラスタに含まれる SQL Server 2005 コンポーネントのみに該当するものです。

フェールオーバー クラスタに Service Pack をインストールするには、次の手順を実行します。

  1. SQL Server 2005 SP2 をフェールオーバー クラスタ インスタンスのすべてのノードに確実にインストールするには、フェールオーバー クラスタ インスタンスのすべてのパッシブ ノード上でタスク スケジューラが実行されていることを確認します。

  2. SQL Server リソースに依存するリソースが追加されている場合は、SQL Server 2005 SP2 をインストールする前に、依存関係を削除するかオフラインにする必要があります。依存関係を削除せずに SP2 をインストールすると、該当するリソースがオフラインになります。

    メモ :
    クラスタ化されたリソースがオフラインになると、そのリソースに依存するすべてのリソースもクラスタ サービスによってオフラインにされます。

  3. アップグレードしようとしているフェールオーバー クラスタ インスタンスが含まれるグループの所有元アクティブ ノードから、SQL Server 2005 SP2 の実行可能パッケージ ファイルを実行します。これで Service Pack ファイルがフェールオーバー クラスタ内のすべてのノードにインストールされます。フェールオーバー クラスタ内のパッシブ ノードから SP2 をインストールすることはできません。

  4. SQL Server 2005 SP2 セットアップ ウィザードの [機能の選択] ページで、アップグレードするフェールオーバー クラスタ インスタンスを選択します。セットアップでは、ログイン資格情報の入力が求められます。この情報はクラスタ内の他のノードへの接続に使用されます。

    メモ :
    セットアップの実行中はすべてのクラスタ ノードをオンラインに保ってください。こうすることで、アップグレードが各クラスタ ノードに確実に適用されます。

  5. 手順 1. で依存関係を削除するかリソースをオフラインにした場合は、依存関係を復元するかリソースをオンラインにします。

    メモ :
    セットアップでは、フェールオーバー クラスタ ノードの再起動が必要になる場合があります。この再起動は、セットアップの実行中に使用されていたファイルを置き換えるためのものです。
SQL Server 2005 SP2 フェールオーバー クラスタ ノードの再構築

SP2 の適用後にフェールオーバー クラスタ内のノードを再構築する必要がある場合は、次の手順を実行します。

  1. フェールオーバー クラスタ内のノードを再構築します。ノードの再構築の詳細については、SQL Server Books Online の「フェールオーバー クラスタ障害例 1 で障害から復旧する方法」を参照してください。

  2. 元の SQL Server 2005 セットアップ プログラムを実行して、フェールオーバー クラスタにノードを復元します。

  3. 追加したノードに対して SQL Server 2005 SP2 セットアップを実行します。

サービスとアプリケーションの再起動

セットアップが完了すると、コンピュータの再起動を求められる場合があります。システムを再起動した後、または再起動を求められることなくセットアップが完了した後は、コントロール パネルの [サービス] ノードを使用して、SQL Server 2005 SP2 の適用前に停止したサービスを再開します。

たとえば分散トランザクション コーディネータや Microsoft Search サービスのようなサービス、または同等のインスタンス固有のサービスなどを再開します。次に、SQL Server 2005 SP2 セットアップの実行前に終了したアプリケーションを再起動します。インストールが正常に終了した直後に、アップグレード後の master データベース、msdb データベース、model データベースをバックアップすることもお勧めします。


コマンド プロンプトからのインストール (修正プログラム)

コマンド プロンプトからのインストール (修正プログラム)

続行する前に、「Service Pack のインストール (修正プログラム)」でインストールに関する考慮事項を確認してください。

SQL Server 2005 SP2 の自動インストールでは、次のコマンド プロンプトのスイッチがサポートされています。インストール スクリプトをテストし、必要に応じて変更してください。

重要 :
セキュリティ資格情報は、できるだけ実行時に入力してください。資格情報をスクリプト ファイルに含める必要がある場合は、不正なアクセスが行われないようにファイルをセキュリティで保護してください。

スイッチ

説明

/?

自動インストールのコマンド プロンプト ヘルプを表示します。

/allinstances

SQL Server 2005 SP2 を、すべての SQL Server 2005 インスタンスとすべての SQL Server 2005 コンポーネント (共有、インスタンス非対応) に適用します。

/instancename=InstanceName

SQL Server 2005 SP2 を、InstanceName という名前の SQL Server 2005 インスタンスとすべての SQL Server 2005 コンポーネント (共有、インスタンス非対応) に適用します。

/password=Password

リモートのフェールオーバー クラスタ ノードに接続するための、ユーザー アカウントのパスワードです。

/quiet

SQL Server 2005 SP2 セットアップを自動実行モードで実行します。

/reportonly

セットアップの検出と列挙の部分だけを実行します。SQL Server 2005 のローカル インスタンスとローカル コンポーネントを一覧にしたレポートが表示されます。

メモ :
このスイッチを使用した場合、SQL Server 2005 SP2 は適用されません。

/rsupgradedatabaseaccount=rsAccountName

SQL Server 認証を使用するときに、レポート サーバー データベースのスキーマを変更する権限のあるアカウントを指定します。このパラメータは、SQL Server ログインが必要なレポート サーバー データベースを含む Reporting Services インスタンスをアップグレードするときに使用します。

/rsupgradepassword=rsPassword

リモートのレポート サーバー データベースのスキーマを変更する権限のあるアカウントのパスワードを指定します。このパラメータは、リモートのレポート サーバー データベースを含む Reporting Services インスタンスをアップグレードするときに使用します。

/rsupgradedatabase

スイッチ /rsupgradedatabase=0 を使用すると、Reporting Services データベースはアップグレードされません。

/sapwd=SaLoginPassword

スクリプトを実行する sa ログイン用の SQL Server 認証パスワードを渡します。

メモ :
/sapwd の文字はエスケープしないでください。文字をエスケープすると、セットアップは失敗します。

/user=Domain\UserName

リモートのフェールオーバー クラスタ ノードに接続するための、ユーザー アカウントです。


著作権情報 (修正プログラム)

著作権情報 (修正プログラム)

このソフトウェアおよびマニュアルに記載されている参照用のアプリケーションを含んだ内容は情報の提供のみを目的としており、明示または黙示にかかわらず、これらの情報についてマイクロソフトはいかなる責任も負わないものとします。このソフトウェアの仕様およびマニュアルに記載されている事柄は、将来予告なしに変更することがあります。お客様が本製品を運用した結果の影響については、お客様が負うものとします。

このマニュアルに含まれているサンプルは、概念や特定のステートメントまたは句の利用方法について説明することを主目的として提供されています。多くのサンプルは、特定の概念やステートメントの説明のみを目的としているため、通常の実稼働システムで必要となるようなデータ評価やエラー処理のコードは含んでいません。提供されているサンプルおよびソース コードに対するテクニカル サポートは行っていません。

特に記載していない場合、このソフトウェアおよびマニュアルで使用している会社、組織、製品、ドメイン名、電子メール アドレス、人物、場所、出来事などの名称は架空のもので、実在する商品名、団体名、個人名などとは一切関係ありません。このソフトウェアおよびマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。このソフトウェアおよびマニュアルのいかなる部分も、米国 Microsoft Corporation の書面による許諾を受けることなく、その目的を問わず、どのような形態であっても、複製または譲渡することは禁じられています。ここでいう形態とは、複写や記録など、電子的な、または物理的なすべての手段を含みます。

マイクロソフトは、このマニュアルに記載されている内容に関し、特許、特許申請、商標、著作権、またはその他の無体財産権を有する場合があります。このマニュアルはこれらの特許、商標、著作権、またはその他の無体財産権に関する権利をお客様に許諾するものではありません。

© 2006 Microsoft Corporation. All rights reserved.

Microsoft、Windows、Windows NT、Windows Server、Active Directory、ActiveX、BackOffice、bCentral、BizTalk、DirectX、Excel、Hotmail、IntelliSense、J/Direct、Jscript、Microsoft Press、MSDN、MS-DOS、Outlook、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual FoxPro、Visual InterDev、Visual J#、Visual J++、Visual SourceSafe、Visual Studio、Win32、Win32s、Windows Mobile、Windows Server System、および WinFX は、米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

SAP NetWeaver は、ドイツ SAP AG のドイツおよびその他の国における登録商標または商標です。

記載されている会社名、製品名には、各社の商標のものもあります。

SQL Server 2005 のサポートおよびアップグレードに関するドキュメント ポリシー

SQL Server ドキュメントの内容は、十分なテストが実施されたうえで公開されています。SQL Server Books Online、Readme ファイル、既知の問題、サポート技術情報などの製品マニュアルには、SQL Server に関連する特徴および機能を安全に使用するための内容が含まれています。このポリシーは、各リリースおよびサービス パックの Readme ファイルを含む、すべての SQL Server ドキュメントに適用されます。Readme は、Books Online の追加ファイルとして扱われます。

機能によっては、お客様が直接使用しないものもあり、それらの機能の説明は、ドキュメントに記載されていない場合があります。マイクロソフト カスタマ サポート サービス (CSS) では、特定の機能に関する内容がマイクロソフトによって発行された SQL Server ドキュメントでも説明されていない限り、第三者によって発行されたマニュアルや Web サイトに記載されている内容はサポートしていません。また、それらの内容を運用データベースやアプリケーションで使用しないでください。

ストアド プロシージャ、拡張ストアド プロシージャ、関数、ビュー、テーブル、列、プロパティ、メタデータに限らず、公開されていない API は使用しないでください。マイクロソフトのカスタマ サポート サービスでは、公開されていないエントリ ポイントを使用または応用したデータベースやアプリケーションはサポートしていません。

また、このようなデータベースやアプリケーションについて、サーバーおよびデータベースを SQL Server の将来のバージョンにアップグレードする場合も保証しません。SQL Server の機能は、Microsoft SQL Server ドキュメントに記載されている内容に限りお使いください。特定の機能が Microsoft SQL Server ドキュメントに記載されていない場合は、SQL Server でサポートされていないものと見なします。


セットアップのユーザー インターフェイス (修正プログラム)

セットアップのユーザー インターフェイス (修正プログラム)

次のトピックでは、SQL Server 2005 SP2 のインストール時の判断事項に関する追加情報を説明しています。ヘルプ トピックを表示するには、リンクをクリックしてください。

[ライセンス条項 (修正プログラム)]

[機能の選択 (修正プログラム)]

[認証モード (修正プログラム) ]

[リモート認証 (修正プログラム)]

[エラーと使用状況レポート (修正プログラム)]

[実行中のプロセス (修正プログラム)]

[インストールの準備完了 (修正プログラム)]

[インストールの進行状況 (修正プログラム)]

[インストールの完了 (修正プログラム)]

[追加情報 (修正プログラム)]


[ライセンス条項 (修正プログラム)]

[ライセンス条項 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [ライセンス条項 (修正プログラム)] ページを使用して、このリリースのライセンス条項に同意します。

オプション

SQL Server 2005 SP2 セットアップを続行するには、SQL Server 2005 SP2 のライセンス条項に同意するオプション ボタンをクリックする必要があります。その後、[次へ] をクリックして続行します。

このリリースのライセンス条項を印刷するには、[印刷] ボタンを使用します。SQL Server 2005 SP2 セットアップを終了するには、[キャンセル] をクリックします。


[機能の選択 (修正プログラム)]

[機能の選択 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [機能の選択 (修正プログラム)] ページを使用して、更新する SQL Server のコンポーネントと機能を選択します。

オプション

左ペインの機能名をクリックして、言語、オペレーティング システム、エディション、状態の詳細を確認します。

コンポーネントまたは機能を更新するには、機能名の隣のチェック ボックスをオンにします。コンポーネントまたは機能を更新の対象外とするには、機能名の隣のチェック ボックスをオフにします。

1 台のコンピュータ上に複数の SQL Server 2005 インスタンスがある場合、それらは別々に更新できます。ただし 1 つの SQL Server インスタンスのコンポーネントはすべて同時にアップグレードする必要があります。ワークステーション コンポーネント、MSXML パーサー、SQLXML、旧バージョンとの互換性コンポーネント、VSS Writer などの共有コンポーネントはすべて、SQL Server 2005 SP2 にアップグレードする必要があります。

アップグレードできないコンポーネントがある場合は、[詳細] ペインに説明が表示されます。


[認証モード (修正プログラム) ]

[認証モード (修正プログラム) ]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [認証モード (修正プログラム)] ページを使用して、インスタンス情報と認証情報を指定します。これらの情報は、セットアップにおいて更新対象の SQL Server インスタンスへの接続に使用されます。

オプション

更新するすべてのコンポーネントまたはインスタンスに対し、認証モード、ユーザー名、パスワードが同じ場合は、[すべてのインスタンスに選択を適用する] チェック ボックスをオンにします。このオプションをオンにすると、[インスタンス名] の一覧は無効になります。認証の種類、ユーザー名、パスワードの情報を入力し、[テスト] をクリックして、資格情報を検証します。

更新するすべてのコンポーネントまたはインスタンスに対し、認証モード、ユーザー名、パスワードが同じでない場合は、コンポーネントまたはインスタンスごとにインスタンス名、認証の種類、ユーザー名、パスワードの情報を入力し、[テスト] をクリックして、資格情報を検証します。

SQL Server の各コンポーネントまたはインスタンスに対して資格情報のテストが完了すると、状態テーブルにテスト結果が表示されます。テーブル内にすべてのコンポーネントが表示され、そのすべての状態が "成功" と表示されたら、[次へ] をクリックして続行します。認証に関する問題がある場合は、続行前にすべて解決する必要があります。

認証に失敗した場合は、コンポーネントの情報を修正し、検証テストをもう一度行います。テーブル内にすべてのコンポーネントが表示され、そのすべての状態が "成功" と表示されたら、[次へ] をクリックして続行します。


[リモート認証 (修正プログラム)]

[リモート認証 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [リモート認証 (修正プログラム)] ページを使用して、更新する SQL Server のフェールオーバー クラスタ インスタンス用のリモート ログイン情報を指定します。

オプション

[ユーザー名]

このログオン フィールドがあらかじめ設定されていない場合は、フェールオーバー クラスタ内のすべてのノードに対して有効な管理者アカウントのユーザー名を指定します。

[パスワード]

選択した管理者アカウントのパスワードを指定します。

[ドメイン]

選択した管理者アカウントのドメイン名を指定します。


[エラーと使用状況レポート (修正プログラム)]

[エラーと使用状況レポート (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [エラーと使用状況レポート (修正プログラム)] ページを使用して、SQL Server 2005 の機能エラーと使用状況レポートの機能を有効にします。

オプション

SQL Server SP2 には、致命的なサービス エラーのレポートを Microsoft または企業のエラー報告サーバーに自動的に送信するように SQL Server を構成するためのオプションが用意されています。このページのチェック ボックスをオフにすることにより、1 つまたは両方のオプションを無効にできます。Microsoft では、エラー レポートを SQL Server の機能強化のために使用し、すべてのエラー レポートと機能の使用状況データを機密情報として扱います。

エラー報告

エラー報告機能を有効にすると、SQL Server は、次の SQL Server コンポーネントに致命的なエラーが発生した場合に Microsoft に自動的にレポートを送信するように構成されます。

  • データベース エンジン

  • SQL Server エージェント

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • レプリケーション

Microsoft では、エラー レポートを SQL Server の機能強化のために使用し、すべての情報を機密として扱います。

エラーに関する情報は、セキュリティで保護された接続 (https) を経由して Microsoft に送信され、アクセスが制限された場所に格納されます。エラー レポートを企業のエラー報告サーバーに送信することもできます。企業のエラー報告サーバーの設定の詳細については、Microsoft Web サイトの「企業内エラー報告」を参照してください。

エラー レポートには次の情報が含まれます。

  • 問題発生時の SQL Server の状態。

  • オペレーティング システムのバージョンとコンピュータ ハードウェアの情報。

  • ご使用のデジタル プロダクト ID。これはライセンスの識別には使用されません。

  • ご使用のコンピュータまたはプロキシ サーバーのネットワーク IP アドレス。

  • エラーの原因となったプロセスに関係するメモリまたはファイルからの情報。

Microsoft では、お客様のファイル、名前、住所、電子メール アドレス、またはその他の形式の個人情報を意図的に収集することはありません。ただし、エラーの原因となったプロセスに関係するメモリまたはファイル内の個人情報がエラー レポートに含められる場合もあります。Microsoft ではこの情報からお客様の身元を特定できることがあっても、そのような目的に情報を使用することは一切ありません。

のプライバシーとデータ収集ポリシーの詳細については、「SQL Server 2005 のプライバシーに関する声明」を参照してください。

エラー報告を有効にしているときに致命的なエラーが発生した場合は、Windows のイベント ログに、特定のエラーに関するサポート技術情報の記事へのリンクを含む Microsoft の説明が含まれていることがあります。

セットアップの完了後、すべての SQL Server インスタンスとそのコンポーネントに対してエラーと機能の使用状況レポートを無効にするには、[スタート]、[すべてのプログラム]、[Microsoft SQL Server 2005]、[構成ツール]、[SQL Server エラーと使用状況レポート] の順にクリックし、[エラーと使用状況レポートの設定] ダイアログ ボックスを開いて [機能の使用状況] チェック ボックスをオフにします。SQL Server の複数のコンポーネント (データベース エンジン、分析サーバー、レポート サーバー、および共有コンポーネント) に対してエラー報告が有効になっている場合は、個々のコンポーネントの各インスタンスに対してエラー報告を無効にできます。[その他] に表示されている共有コンポーネントに対しても、エラー報告を無効にできます。

機能の使用状況

機能の使用状況レポートを有効にすると、SQL Server は Microsoft に定期的にレポートを送信するように構成されます。レポートには、ハードウェア構成に関する情報と SQL Server 2005 のソフトウェアおよびサービスがどのように使用されているかを示す情報が含められます。Microsoft では、機能の使用状況データを SQL Server の機能強化のために使用します。この機能によって監視される SQL Server 2005 コンポーネントは次のとおりです。

  • データベース エンジン

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • レプリケーション

  • Business Intelligence Development Studio

機能の使用に関する情報は Microsoft に送信され、アクセスが制限された場所に格納されます。

セットアップの完了後、機能の使用状況レポートを無効にするには、SQL Server 2005 の [構成ツール] メニューにある [SQL Server エラーと使用状況レポート] ツールを使用します。

有効になっているすべての SQL Server インスタンスに対して、1 日に 1 回情報が収集されます。サーバーの負荷を最小にするため、この時刻は既定では午前 0 時となっています。収集時刻を変更する場合は、収集時刻を制御するレジストリ キーを手動で編集します。各 SQL Server インスタンスには専用のレジストリ キーがあります。次の例は、サーバー (MSSQL.1) にインストールされている最初の SQL Server インスタンスのものです。

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

このレジストリ キーの値は、収集を実行する時刻が 00:00 (午前 0 時) から何分後であるかを示しています。たとえば、値が 60 の場合は午前 1 時に収集が実行され、1200 の場合は午後 8 時に実行されます。


[実行中のプロセス (修正プログラム)]

[実行中のプロセス (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール後の Windows の再起動を避けるには、SQL Server 2005 SP2 インストール ウィザードの [実行中のプロセス (修正プログラム)] ページを使用して、SQL Server 2005 SP2 セットアップに必要とされるファイルをロックしているプロセスを特定します。

アップグレードする SQL Server インスタンスに接続しているすべてのアプリケーションとサービスを停止します。たとえば、SQL Server 2005 SP2 をインストールする前には、SQL Server Management Studio や Business Intelligence Development Studio を停止し、コントロール パネルや [プログラムの追加と削除] を閉じます。

  • SP2 のインストール後にコンピュータを再起動しなくてもいいように、セットアップではファイルをロックしているプロセスが一覧表示されます。SP2 セットアップ プログラムで、インストール中にサービスを終了する必要があった場合、インストールの完了後にそのサービスが再起動されます。

  • セットアップで、インストール中にファイルがロックされていると認識された場合、SP2 のインストール完了後にコンピュータの再起動が必要になることがあります。再起動が必要な場合は、コンピュータの再起動を促すプロンプトが表示されます。

オプション

セットアップで、ロックされているファイルが検出された場合、該当するファイルが表に一覧表示されます。一覧にあるプロセスとアプリケーションを停止または終了した後、[更新] をクリックして、再度チェックを実行します。実行中のチェックを終了するには [停止] をクリックします。ロックされているファイルが見つからなかった場合、表には何も表示されません。

ファイルをロックしていたプロセスがすべてシャットダウンされたら、[次へ] をクリックして続行します。

フェールオーバー クラスタへの SQL Server 2005 SP2 のインストール

SQL Server 2005 SP2 をフェールオーバー クラスタ インスタンスにインストールする前に、以下の注意をご確認ください。

  • SP2 セットアップ プログラムを実行する前や、インストール プログラムの実行中に、クラスタ サービスを停止しないでください。

  • SP2 セットアップ プログラムを実行する前に、実行中のプロセスを終了させないでください。

  • SP2 セットアップ プログラムを実行する前に、SQL Server サービスをオフラインにしないでください。SP2 セットアップ プログラムが、SQL Server サービスの停止と開始を行ないます。

  • フェールオーバー クラスタ インスタンスのプライマリ ノード上で、SP2 セットアップ プログラムを実行してください。

  • SP2 のインストールの終了後、すべてのフェールオーバー クラスタ ノードを再起動する必要があります。

  • ローリング アップグレードは、SP2 ではサポートされていません。


[インストールの準備完了 (修正プログラム)]

[インストールの準備完了 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [インストールの準備完了 (修正プログラム)] ページには、SQL Server 2005 SP2 セットアップで更新をインストールするために必要な情報が揃ったことが示されます。

オプション

SQL Server 2005 SP2 のインストール オプションを確認または変更するには、[戻る] をクリックします。続行するには、[インストール] をクリックします。


[インストールの進行状況 (修正プログラム)]

[インストールの進行状況 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [インストールの進行状況 (修正プログラム)] ページを使用して、セットアップによる SQL Server のコンポーネントとインスタンスへの SQL Server 2005 SP2 の適用処理を監視します。

オプション

SQL Server の製品名、インスタンス名、インストールの状態が表で示されます。


[インストールの完了 (修正プログラム)]

[インストールの完了 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

SP2 インストール ウィザードの [インストールの完了 (修正プログラム)] ページには、SQL Server 2005 SP2 に更新された各コンポーネントの状態が示されます。

オプション

SQL Server 2005 SP2 インストールの概要ログを表示するには、[概要の表示] をクリックします。概要ログ ファイルは C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\ に保存されます。

ログ ファイルのパスを表示するには、コンポーネント名をクリックします。たとえば、[SQL Server Native Client] をクリックすると、[詳細] ペインにログ ファイルのパス C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log が表示されます。


[追加情報 (修正プログラム)]

[追加情報 (修正プログラム)]
セットアップのユーザー インターフェイス (修正プログラム) >

更新 : 2006 年 12 月 12 日

SP2 インストール ウィザードの [追加情報 (修正プログラム)] ページには、[SQL Server 2005 User Provisioning Tool for Windows Vista] を開くためのチェック ボックスがあります。SQL Server のシステム管理者ロールのユーザー一覧を更新するには、準備ツールを使用してください。

ユーザー アカウント制御 (UAC)は、ユーザー アカウント保護 (UAP) または制限付きユーザー アカウント (LUA) とも呼ばれる、Windows Vista の新しいセキュリティ機能です。UAC により、ユーザーは管理者以外のユーザーとして、一般的なタスクを実行できます。ローカルの Administrators グループのメンバであるユーザー アカウントは、標準ユーザー アカウントを使用しているかのように、ほとんどのアプリケーションを実行します。

既定では、Windows Administrators グループのメンバである Windows Vista ユーザーに、SQL Server に接続する権限が自動的に付与されることはありません。また、管理者用の資格情報が自動的に付与されることもありません。SQL Server システム管理者ロールのメンバは、SQL Server のインスタンスのすべての操作を実行できます。

Windows Vista が動作するコンピュータから Administrators グループのメンバがログインできるようにするには、そのアカウントを SQL Server ログインに明示的に追加する必要があります。

オプション

SQL Server システム管理者ロールのユーザー一覧を更新するには、チェック ボックスを使って、[SQL Server 2005 User Provisioning Tool for Windows Vista]を起動してください。

[準備するユーザー] フィールドに、権限を更新するユーザーが DomainName\UserName 形式で表示されることを確認します。[使用できる特権] ペインの SQL Server インスタンスの一覧から、更新するロールを選択して、右矢印をクリックします。SQL Server インスタンスの使用可能なすべてのインスタンスで、使用できるすべてのロールにユーザーを追加するには、二重右矢印をクリックします。

右側のペインに、ユーザーの追加先となる SQL Server インスタンスとロールと共に、権限を更新するユーザーが DomainName\UserName 形式で一覧表示されます。

右側のペインからロールを削除するには、削除するロールを選択して、左矢印をクリックします。右側のペインからすべてのロールを削除するには、二重左矢印をクリックします。左矢印機能による影響を受けるのは、ツールに表示されているユーザー、ロール、および権限だけです。このツールには、権限を取り消す機能はありません。ユーザーから権限を取り消すには、管理者がユーザーの資格情報を手動で更新または削除する必要があります。

選択の完了後に変更を適用するには、[OK] をクリックします。変更を適用せずにツールを終了するには、[キャンセル] をクリックします。

このインストール プログラムの終了後に [SQL Server 2005 User Provisioning Tool for Microsoft Vista] にアクセスするには、SQL Server 2005 セキュリティ構成ツール (SQLSAC.exe) の [新しい管理者の追加] リンクをクリックします。

[追加情報 (修正プログラム)] のリンクの一覧には、SQL Server の追加情報を入手できる Web サイトへのリンクがあります。これらのリンクには、製品サポート、ドキュメントの更新、および SQL Server に関する Microsoft Update のオプションの情報が含まれています。