Installazione del Service Pack (hotfix)

Microsoft SQL Server 2005 Service Pack 2
Installazione del Service Pack (hotfix)

È possibile aggiornare a SQL Server 2005 SP2 qualsiasi componente di SQL Server 2005 installato. Se il livello di versione di un componente di SQL Server 2005 esistente è superiore a SP2, il programma di installazione di SP2 lo escluderà dall'aggiornamento.

Quando si installa SQL Server 2005 SP2 è necessario tenere conto delle considerazioni seguenti:

  • Dopo l'applicazione non sarà più possibile rimuovere SQL Server 2005 SP2 senza disinstallare l'intero prodotto.

  • Tutte le funzionalità appartenenti a una determinata istanza di SQL Server devono essere aggiornate contemporaneamente. Se ad esempio si aggiorna Servizi di database e nella stessa istanza di SQL Server è installato anche Analysis Services, sarà necessario aggiornare anche tale servizio. Le istanze o i componenti non selezionati nella struttura delle funzionalità non verranno aggiornati a SQL Server 2005 SP2.

  • Se possibile, utilizzare l'autenticazione di Windows.

  • Quando si utilizza l'autenticazione di SQL Server la password specificata per l'account di accesso sa non può contenere virgolette doppie. Se la password contiene virgolette doppie, utilizzare l'autenticazione di Windows anziché l'autenticazione di SQL Server per applicare SQL Server 2005 SP2 oppure modificare la password dell'account di accesso sa prima di eseguire il programma di installazione di SP2.

  • Quando si aggiorna un'istanza di Reporting Services viene automaticamente stabilita una connessione al server di report per aggiornare il relativo database. Se l'account di Windows dell'utente che esegue il programma di installazione non è membro del ruolo predefinito del server sysadmin, sarà necessario specificare un account di accesso e una password di SQL Server con privilegi sufficienti. A tale scopo, selezionare l'istanza di Reporting Services nella finestra di dialogo Modalità di autenticazione, specificare le credenziali di un account dotato dei privilegi necessari e quindi fare clic su OK.

  • Per impostazione predefinita, i file di log del programma di installazione di SQL Server 2005 SP2 vengono salvati in %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Documentazione aggiuntiva

Nelle fonti seguenti è disponibile documentazione aggiuntiva di SQL Server 2005 SP2:

  • File Leggimi di SQL Server 2005 SP2.

  • Articolo della Microsoft Knowledge Base relativo a SQL Server 2005 SP2.

Requisiti relativi allo spazio su disco

Per scaricare e installare SQL Server 2005 SP2, sono necessari 1,9 GB di spazio disponibile sul disco rigido del computer in uso. L'utilizzo dello spazio su disco è illustrato nella tabella seguente.

Utilizzo del disco (MB) | Percorso | Tipo
50 | Directory di installazione di SQL Server 2005 | Permanente
1,000 | Unità di sistema | Permanente
600 | Directory temporanea | Temporaneo
250 | Percorso di download | Temporaneo

Al termine dell'installazione è possibile rimuovere dal computer il pacchetto di download di 250 MB. L'utilizzo permanente dello spazio su disco da parte di SQL Server 2005 SP2 dopo l'installazione è di circa 1 GB.

Panoramica dell'installazione

In questa sezione viene fornita una panoramica dell'installazione di SQL Server 2005 SP2, che include una descrizione delle operazioni seguenti:

  • Preparazione per l'installazione di SQL Server 2005 SP2

  • Installazione di SQL Server 2005 SP2

  • Riavvio di servizi e applicazioni

Preparazione per l'installazione di SQL Server 2005 SP2

Prima di installare SQL Server 2005 SP2 è necessario eseguire le operazioni seguenti:

  • Backup dei database di SQL Server 2005 - Prima di installare SQL Server 2005 SP2 eseguire un backup dei database master, msdb e model. Durante l'installazione di SQL Server 2005 SP2 tali database vengono modificati e divengono incompatibili con le versioni di SQL Server 2005 anteriori a SP2. Se si decide di reinstallare SQL Server 2005 senza SP2, saranno necessari i backup di tali database.

    È inoltre consigliabile eseguire il backup dei database utente esistenti.

Importante:
Prima di applicare SP2 a istanze di SQL Server che fanno parte di una topologia di replica è necessario eseguire il backup dei database replicati e dei database di sistema.

  • Backup dei database, del file di configurazione e del repository di Analysis Services - Prima di aggiornare a SP2 un'istanza di Analysis Services è consigliabile eseguire il backup degli elementi seguenti:

    • Database di Analysis Services. Per impostazione predefinita tali database sono installati in C:\Programmi\Microsoft SQL Server\MSSQL.1\OLAP\Data\.

    • Impostazione di configurazione di Analysis Server nel file di configurazione msmdsrv.ini. Per impostazione predefinita tale file si trova nella directory C:\Programmi\Microsoft SQL Server\MSSQL.1\OLAP\Config\.

    • (Facoltativo) Database contenente il repository di Analysis Services. Questo passaggio è necessario solo se Analysis Server è stato configurato per l'utilizzo con la libreria DSO (Decision Support Objects).

Nota:
Se non si esegue il backup dei database, del file di configurazione e del repository di Analysis Services, non sarà possibile ripristinare la versione precedente di Analysis Services dopo l'installazione di una versione aggiornata.

  • Verifica dello spazio disponibile per i database di sistema - Se l'opzione di aumento automatico delle dimensioni non è selezionata per i database di sistema master e msdb, saranno necessari almeno 500 KB di spazio disponibile in ogni database. Per verificare che i database dispongano di spazio sufficiente, eseguire la stored procedure di sistema sp_spaceused sui database master e msdb. Se in almeno uno di questi database la quantità di spazio non allocato è inferiore a 500 KB, aumentare la dimensione del database. Per ulteriori informazioni, vedere "Espansione di un database" nella documentazione in linea di SQL Server.

  • Verifica dello stato ed eventuale attivazione degli account dei servizi di SQL Server 2005 - Se il tipo di avvio dei servizi MSSQLServer, MSSQLServerOLAPService e ReportServer è impostato su Disattivato, potrebbe verificarsi un errore del programma di installazione.

    Per verificare e, se necessario, attivare gli account di tali servizi:

    1. Nel Pannello di controllo fare doppio clic su Strumenti di amministrazione e quindi su Servizi.

    2. Individuare il servizio MSSQLServer nell'elenco e controllare il valore di Tipo di avvio.

    3. Se il valore di Tipo di avvio è Disattivato fare doppio clic sul nome del servizio e impostare Tipo di avvio su Manuale o Automatico.

    4. Ripetere i passaggi 2 e 3 per i servizi MSSQLServerOLAPService e ReportServer e quindi scegliere OK.

    5. Ripetere la procedura per tutte le istanze di SQL Server installate.

  • Interruzione di servizi e applicazioni - Interrompere tutti i servizi e le applicazioni che si connettono alle istanze di SQL Server da aggiornare, inclusi SQL Server Management Studio, Business Intelligence Development Studio, il Pannello di controllo e Installazione applicazioni, prima di installare SQL Server 2005 SP2.

Nota:
Non è possibile interrompere i servizi in un ambiente con cluster di failover. Per ulteriori informazioni, vedere la sezione relativa all'installazione nei cluster di failover più avanti in questo argomento.

  • Per eliminare la necessità di riavviare il computer dopo l'installazione di SP2, verrà visualizzato un elenco dei processi che bloccano file da aggiornare. Se durante l'installazione di SP2 è necessario arrestare un determinato servizio, al termine dell'installazione tale servizio verrà riavviato automaticamente.

  • Se vengono rilevati file bloccati durante l'installazione, potrebbe essere necessario riavviare il computer al termine dell'installazione di SP2. In questo caso verrà richiesto di riavviare il computer.

Installazione di SQL Server 2005 SP2

In questa sezione viene illustrato il processo di installazione di SQL Server 2005 SP2.

Importante:
Il programma di installazione di SQL Server 2005 SP2 deve essere eseguito con un account dotato di privilegi di amministratore sul computer di destinazione.

Avvio del programma di installazione di SQL Server 2005 SP2

Per installare SQL Server 2005 SP2, eseguire il pacchetto autoestraente SQLServer2005SP2-KB921896-PPP-LLL.exe, dove PPP indica la piattaforma di installazione specifica e LLL è un codice variabile che identifica la lingua.

Nota:
Per l'applicazione di SP2 a componenti di SQL Server 2005 che fanno parte di un cluster di failover, vedere la sezione relativa all'installazione in un cluster di failover. Per l'esecuzione del programma di installazione di SP2 in modalità automatica, vedere Installazione dal prompt dei comandi (hotfix).

Installazione in un cluster di failover

Le informazioni seguenti sono applicabili esclusivamente ai componenti di SQL Server 2005 che fanno parte di un cluster di failover.

Per installare il Service Pack in un cluster di failover:

  1. Per garantire che SQL Server 2005 SP2 verrà installato in tutti i nodi di una determinata istanza del cluster di failover, verificare che l'Utilità di pianificazione sia in esecuzione in tutti i nodi passivi di tale istanza del cluster di failover.

  2. Se sono state aggiunte risorse che dipendono da risorse di SQL Server, sarà necessario rimuovere o portare non in linea tali dipendenze prima di installare SQL Server 2005 SP2. Se le dipendenze non vengono rimosse, verranno automaticamente portate non in linea durante l'installazione di SP2.

    Nota:
    Quando una risorsa cluster viene portata non in linea, tutte le risorse dipendenti vengono automaticamente portate non in linea dal servizio cluster.

  3. Eseguire il file eseguibile del pacchetto di SQL Server 2005 SP2 dal nodo attivo proprietario del gruppo che contiene l'istanza del cluster di failover da aggiornare. I file del Service Pack verranno installati in tutti i nodi del cluster di failover. Non è possibile installare SP2 da un nodo passivo del cluster di failover.

  4. Nella pagina Selezione funzionalità dell'Installazione guidata di SQL Server 2005 SP2 selezionare l'istanza del cluster di failover da aggiornare. Verrà richiesto di immettere le credenziali di accesso necessarie per la connessione agli altri nodi del cluster.

    Nota:
    Durante l'installazione è necessario mantenere in linea tutti i nodi del cluster, per consentire l'applicazione dell'aggiornamento a ogni singolo nodo.

  5. Se al passaggio 1 sono state rimosse dipendenze o portate non in linea risorse, ripristinare le dipendenze o portare in linea le risorse.

    Nota:
    È possibile che venga richiesto di riavviare i nodi del cluster di failover. Durante il riavvio vengono sostituiti i file che erano in uso durante l'installazione.
Ricostruzione di un nodo di un cluster di failover di SQL Server 2005 SP2

Se è necessario ricostruire un nodo di un cluster di failover dopo l'applicazione di SP2, eseguire la procedura seguente.

  1. Ricostruire il nodo nel cluster di failover. Per ulteriori informazioni sulla ricostruzione di un nodo, vedere "Procedura: Recupero da un errore del cluster di failover. Scenario 1" nella documentazione in linea di SQL Server.

  2. Eseguire il programma di installazione originale di SQL Server 2005 per ripristinare il nodo nel cluster di failover.

  3. Eseguire il programma di installazione di SQL Server 2005 SP2 sul nodo appena aggiunto.

Riavvio di servizi e applicazioni

Al termine dell'installazione potrebbe essere necessario riavviare il computer. Dopo il riavvio del sistema, oppure al termine del programma di installazione se non viene richiesto di riavviare il sistema, utilizzare l'icona Servizi del Pannello di controllo per riavviare i servizi interrotti prima dell'applicazione di SQL Server 2005 SP2.

Sono inclusi servizi quali Distributed Transaction Coordinator e Microsoft Search o i servizi equivalenti specifici dell'istanza. Riavviare le applicazioni chiuse prima di eseguire il programma di installazione di SQL Server 2005 SP2. Subito dopo il completamento dell'installazione è inoltre consigliabile eseguire un altro backup dei database master, msdb e model aggiornati.


Installazione dal prompt dei comandi (hotfix)

Installazione dal prompt dei comandi (hotfix)

Prima di procedere, vedere le considerazioni relative all'installazione in Installazione del Service Pack (hotfix).

Per l'installazione automatica di SQL Server 2005 SP2 è possibile utilizzare le opzioni del prompt dei comandi descritte nella tabella seguente. Provare gli script di installazione e adattarli alle esigenze della propria azienda.

Importante:
Se possibile, specificare le credenziali di protezione in fase di esecuzione. Se è necessario archiviare le credenziali in un file di script, proteggere tale file per impedire l'accesso non autorizzato.

Opzione

Descrizione

/?

Visualizza la Guida del prompt dei comandi per l'installazione automatica.

/allinstances

Applica SQL Server 2005 SP2 a tutte le istanze di SQL Server 2005 e a tutti i componenti condivisi di SQL Server 2005 che non supportano le istanze.

/instancename=InstanceName

Applica SQL Server 2005 SP2 all'istanza di SQL Server 2005 denominata InstanceName e a tutti i componenti condivisi di SQL Server 2005 che non supportano le istanze.

/password=Password

Password dell'account utente per la connessione a un nodo di cluster di failover remoto.

/quiet

Esegue l'installazione di SQL Server 2005 SP2 in modalità automatica.

/reportonly

Viene eseguita solo la sezione del programma di installazione relativa a individuazione ed enumerazione. Al termine viene visualizzato un report in cui sono enumerati i componenti e le istanze locali di SQL Server 2005.

Nota:
Se si utilizza questa opzione, SQL Server 2005 SP2 non verrà applicato.

/rsupgradedatabaseaccount=rsAccountName

Specifica un account che dispone delle autorizzazioni necessarie per modificare lo schema su un database del server di report quando si utilizza l'autenticazione di SQL Server. Questo parametro viene utilizzato quando si aggiorna un'istanza di Reporting Services che include un database del server di report per cui è necessario un account di accesso di SQL Server.

/rsupgradepassword=rsPassword

Specifica la password per un account che dispone delle autorizzazioni necessarie per modificare lo schema su un database del server di report remoto. Questo parametro viene utilizzato quando si aggiorna un'istanza di Reporting Services che include un database del server di report remoto.

/rsupgradedatabase

L'opzione /rsupgradedatabase=0 impedisce l'aggiornamento del database di Reporting Services.

/sapwd=SaLoginPassword

Passa la password per l'autenticazione di SQL Server dell'account di accesso sa per l'esecuzione degli script.

Nota:
Non utilizzare caratteri di escape con l'opzione /sapwd, poiché impedirebbero la corretta esecuzione del programma di installazione.

/user=Domain\UserName

Account utente per la connessione a un nodo di cluster di failover remoto.


Informazioni sul copyright (hotfix)

Informazioni sul copyright (hotfix)

La presente documentazione, incluse le applicazioni di esempio in essa contenute, viene fornita solo a scopo informativo e senza alcuna garanzia, espressa o implicita. Le informazioni contenute nella presente documentazione, compresi indirizzi URL e altri riferimenti a siti Web Internet, sono soggette a modifiche senza preavviso. L'utente utilizza la presente documentazione a proprio rischio.

Obiettivo principale degli esempi inclusi nella documentazione è quello di illustrare un concetto o l'utilizzo comune di un'istruzione o di una clausola specifica. La maggior parte degli esempi non include tutto il codice normalmente disponibile in un sistema di produzione completo, poiché una parte delle normali funzioni per la gestione degli errori e la convalida dei dati è stata rimossa dagli esempi, per mettere in maggiore evidenza l'istruzione o il concetto specifico illustrato nell'esempio stesso. Per gli esempi o il codice sorgente incluso non è disponibile il supporto tecnico.

Se non specificato diversamente, ogni riferimento a società, organizzazioni, prodotti, nomi di dominio, indirizzi di posta elettronica, persone, luoghi ed eventi utilizzato negli esempi è puramente casuale e ha il solo scopo di illustrare l'uso del prodotto Microsoft. Il rispetto di tutte le applicabili leggi in materia di copyright è esclusivamente a carico dell'utente. Fermi restando tutti i diritti coperti da copyright, nessuna parte di questa documentazione potrà comunque essere riprodotta o inserita in un sistema di riproduzione o trasmessa in qualsiasi forma e con qualsiasi mezzo (in formato elettronico, meccanico, fotocopia, tramite registrazione o altro) per qualsiasi scopo, senza il permesso scritto di Microsoft Corporation.

Microsoft può essere titolare di brevetti, domande di brevetto, marchi, copyright o altri diritti di proprietà intellettuale relativi all'oggetto della presente documentazione. Salvo quanto espressamente previsto in un contratto scritto di licenza Microsoft, la consegna della presente documentazione non implica la concessione di alcuna licenza su tali brevetti, marchi, copyright o altra proprietà intellettuale.

© 2006 Microsoft Corporation. Tutti i diritti riservati.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System e WinFX sono marchi o marchi registrati di Microsoft Corporation negli Stati Uniti e/o negli altri paesi.

SAP NetWeaver è un marchio registrato di SAP AG in Germania e in altri paesi.

Altri nomi di prodotti e società citati nel presente documento possono essere marchi dei rispettivi proprietari.

Criteri relativi alla documentazione per il supporto e l'aggiornamento di SQL Server 2005

I contenuti visualizzati nella documentazione di SQL Server vengono pubblicati solo dopo essere stati sottoposti a test adeguati. La documentazione del prodotto, che comprende la documentazione in linea di SQL Server, i file Leggimi, i documenti con i problemi noti e gli articoli della Knowledge Base, include contenuti relativi alle funzionalità e alle caratteristiche di SQL Server sufficientemente affidabili in termini di sicurezza per l'utilizzo generale da parte degli utenti. Questo criterio si applica a tutta la documentazione di SQL Server, inclusi i file Leggimi relativi a versioni già rilasciate e Service Pack. I file Leggimi sono considerati estensioni della documentazione in linea.

Per alcune funzionalità specifiche non è previsto l'utilizzo diretto da parte degli utenti. Tali funzionalità non sono pertanto documentate. Salvo il caso in cui una funzionalità sia illustrata nella documentazione di SQL pubblicata da Microsoft, il contenuto di pubblicazioni di terzi o di siti Web di terzi non è supportato dal Servizio Supporto Tecnico Clienti Microsoft (CSS, Client Support Services) e non è consigliabile utilizzarlo in relazione a database o applicazioni di produzione.

I clienti non devono utilizzare le API non documentate, inclusi ad esempio metadati, stored procedure, stored procedure estese, funzioni, immagini, tabelle, colonne o proprietà. Il Servizio Supporto Tecnico Clienti Microsoft non fornirà supporto per database o applicazioni che utilizzano o si basano su punti di ingresso non documentati.

Gli aggiornamenti di server e database alle versioni successive di SQL Server non sono garantiti per applicazioni e database che utilizzano o si basano su punti di ingresso non documentati. L'utilizzo delle funzionalità e delle caratteristiche di SQL Server deve essere limitato a quanto incluso nella documentazione di Microsoft SQL Server. Le funzionalità non incluse nella documentazione di Microsoft SQL Server sono da intendersi come non supportate nell'ambito di SQL Server.


Interfaccia utente del programma di installazione (hotfix)

Interfaccia utente del programma di installazione (hotfix)

Negli argomenti seguenti vengono fornite ulteriori informazioni sulle scelte da effettuare durante la fase di installazione di SQL Server 2005 SP2. Per visualizzare uno specifico argomento della Guida, fare clic sul collegamento corrispondente:

Condizioni di licenza (hotfix)

Selezione funzionalità (hotfix)

Modalità di autenticazione (hotfix)

Autenticazione remota (hotfix)

Segnalazione errori e utilizzo funzionalità (hotfix)

Processi in esecuzione (hotfix)

Inizio installazione (hotfix)

Stato dell'installazione (hotfix)

Installazione completata (hotfix)

Ulteriori informazioni (hotfix)


Condizioni di licenza (hotfix)

Condizioni di licenza (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Condizioni di licenza (hotfix) dell'Installazione guidata di SP2 consente di accettare le condizioni di licenza per la versione in uso.

Opzioni

Per procedere con l'installazione di SQL Server 2005 SP2, è necessario selezionare il pulsante di opzione corrispondente all'accettazione delle condizioni di licenza di SQL Server 2005 SP2, quindi fare clic su Avanti per continuare.

Per stampare una copia delle condizioni di licenza per la versione in uso, utilizzare il pulsante Stampa. Per uscire dall'installazione di SQL Server 2005 SP2, fare clic su Annulla.


Selezione funzionalità (hotfix)

Selezione funzionalità (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Selezione funzionalità (hotfix) dell'Installazione guidata di SP2 consente di selezionare i componenti e le funzionalità di SQL Server da aggiornare.

Opzioni

Fare clic sul nome di una funzionalità nel riquadro sinistro per visualizzare informazioni sulla lingua, il sistema operativo, l'edizione e lo stato.

Per aggiornare un componente o una funzionalità, selezionare la casella di controllo accanto al suo nome. Per escludere dall'aggiornamento un componente o una funzionalità, deselezionare la casella di controllo accanto al suo nome.

Se in uno stesso computer sono presenti più istanze di SQL Server 2005, le singole istanze potranno essere aggiornate in momenti diversi, ma tutti i componenti di una stessa istanza di SQL Server dovranno essere aggiornati contemporaneamente. È necessario aggiornare a SQL Server 2005 SP2 tutti i componenti condivisi, quali i componenti workstation, il parser MSXML, SQLXML, i componenti per la compatibilità con le versioni precedenti e VSS Writer.

Se non è possibile aggiornare un determinato componente, il motivo verrà specificato nel riquadro dei dettagli.


Modalità di autenticazione (hotfix)

Modalità di autenticazione (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Modalità di autenticazione (hotfix) dell'Installazione guidata di SP2 consente di specificare l'istanza e le informazioni di autenticazione che dovranno essere utilizzate dal programma di installazione per connettersi alle istanze di SQL Server che si desidera aggiornare.

Opzioni

Se la modalità di autenticazione, il nome utente e la password sono uguali per tutti i componenti o le istanze da aggiornare, selezionare la casella di controllo Applica selezione a tutte le istanze. Se si seleziona questa opzione, l'elenco a discesa Nome istanza verrà disattivato. Specificare il tipo di autenticazione, il nome utente e la password, quindi fare clic su Test per verificare le credenziali.

Se la modalità di autenticazione, il nome utente e la password non sono uguali per tutti i componenti da aggiornare, specificare il nome dell'istanza, il tipo di autenticazione, il nome utente e la password per ogni componente o istanza da aggiornare e quindi fare clic su Test per verificare le credenziali.

Le credenziali vengono quindi verificate per ogni componente o istanza di SQL Server e i risultati vengono inseriti nella tabella di stato. Quando tutti i componenti elencati nella tabella hanno stato "Operazione completata" fare clic su Avanti per continuare. Prima di procedere è necessario risolvere tutti i problemi di autenticazione.

Se l'autenticazione non riesce, aggiornare le informazioni per il componente in questione e quindi eseguire di nuovo il test di verifica. Quando tutti i componenti elencati nella tabella hanno stato "Operazione completata" fare clic su Avanti per continuare.


Autenticazione remota (hotfix)

Autenticazione remota (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Autenticazione remota (hotfix) dell'Installazione guidata di SP2 consente di specificare le informazioni di accesso remoto per le istanze del cluster di failover di SQL Server che si desidera aggiornare.

Opzioni

Nome utente

Se il campo dell'account di accesso non viene popolato automaticamente, specificare il nome utente di un account amministratore valido per tutti i nodi del cluster di failover.

Password

Specificare una password per l'account amministratore selezionato.

Dominio

Specificare il nome del dominio per l'account amministratore selezionato.


Segnalazione errori e utilizzo funzionalità (hotfix)

Segnalazione errori e utilizzo funzionalità (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Segnalazione errori e utilizzo funzionalità (hotfix) dell'Installazione guidata di SP2 consente di attivare il servizio di segnalazione degli errori e di utilizzo delle funzionalità di SQL Server 2005.

Opzioni

In SQL Server SP2 è disponibile un'opzione che consente di configurare SQL Server in modo da inviare automaticamente i report sugli errori irreversibili dei servizi a Microsoft o al server interno per la segnalazione degli errori (Corporate Error Reporting) della propria azienda. È possibile disattivare una o entrambe le opzioni deselezionando le caselle di controllo corrispondenti. Tali report, considerati riservati, vengono utilizzati da Microsoft per migliorare le funzionalità di SQL Server.

Segnalazione errori

Se si attiva la funzionalità di segnalazione degli errori, SQL Server verrà configurato per l'invio automatico di un report a Microsoft nel caso in cui si verifichi un errore irreversibile in uno dei componenti di SQL Server seguenti:

  • Database Engine (Motore di database)

  • SQL Server Agent

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Replica

Le segnalazioni degli errori sono considerate riservate e vengono utilizzate da Microsoft per migliorare le funzionalità di SQL Server.

Le informazioni relative agli errori vengono inviate a Microsoft mediante una connessione protetta (https) e archiviate con diritti di accesso limitati. In alternativa, le segnalazioni possono essere inviate al server interno per la segnalazione degli errori (Corporate Error Reporting) della propria azienda. Per ulteriori informazioni sulla configurazione di un server interno per la segnalazione degli errori (Corporate Error Reporting), visitare il sito Web Microsoft Segnalazione errori a server interno.

Nelle segnalazioni degli errori sono incluse le informazioni seguenti:

  • Condizione di SQL Server nel momento in cui si è verificato il problema.

  • Versione del sistema operativo e informazioni sull'hardware del computer.

  • ID digitale del prodotto, che non viene utilizzato per l'identificazione della licenza in uso.

  • Indirizzo IP di rete del computer o del server proxy in uso.

  • Informazioni ricavate dalla memoria o dai file associati al processo che ha generato l'errore.

Microsoft non raccoglie intenzionalmente file, nomi, indirizzi, indirizzi di posta elettronica o qualsiasi altro tipo di informazioni personali. È tuttavia possibile che la segnalazione degli errori contenga informazioni personali ricavate dalla memoria o dai file associati al processo che ha generato l'errore. Le informazioni raccolte possono contenere dati personali. Tali informazioni non saranno tuttavia utilizzate da Microsoft in alcun modo se non per gli scopi sopra menzionati.

Per ulteriori informazioni sui criteri di raccolta dei dati e sull'informativa sulla privacy di , vedere l'Informativa sulla privacy di SQL Server 2005.

Se la funzionalità di segnalazione degli errori è attivata e si verifica un errore irreversibile, è possibile che nel log eventi di Windows venga visualizzata una risposta di Microsoft che fa riferimento a un articolo della Microsoft Knowledge Base relativo all'errore specifico.

Per disattivare il servizio di segnalazione degli errori e di utilizzo delle funzionalità per tutte le istanze di SQL Server e i relativi componenti al termine dell'installazione, aprire la finestra di dialogo Impostazioni segnalazione errori e utilizzo funzionalità (fare clic su Start, Tutti i programmi, Microsoft SQL Server 2005, Strumenti di configurazione, Segnalazione errori e utilizzo funzionalità di SQL Server) e deselezionare le caselle di controllo relative a Utilizzo funzionalità. Se la segnalazione degli errori è attivata per più componenti di SQL Server (Database Engine (Motore di database), Analysis Server, Reporting Server e i componenti condivisi), sarà possibile disattivare Segnalazione errori per ogni istanza di un singolo componente. È inoltre possibile disattivare Segnalazione errori per i componenti condivisi, elencati in Altro.

Utilizzo funzionalità

Se si attiva la segnalazione relativa all'utilizzo delle funzionalità, SQL Server verrà configurato in modo da inviare periodicamente un report a Microsoft. Nei report verranno incluse informazioni sulla configurazione hardware in uso e sulle modalità di utilizzo del software e dei servizi di SQL Server 2005. I dati relativi all'utilizzo delle funzionalità verranno utilizzati da Microsoft per migliorare SQL Server. Tra i componenti di SQL Server 2005 monitorati da questa funzionalità sono inclusi:

  • Database Engine (Motore di database)

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Replica

  • Business Intelligence Development Studio

Le informazioni relative all'utilizzo delle funzionalità verranno inviate a Microsoft e archiviate con diritti di accesso limitati.

Per disattivare la segnalazione relativa all'utilizzo delle funzionalità al termine dell'installazione, utilizzare lo strumento Segnalazione errori e utilizzo funzionalità di SQL Server, disponibile nel menu Strumenti di configurazione di SQL Server 2005.

Le informazioni vengono raccolte una volta al giorno per tutte le istanze di SQL Server abilitate. Per ridurre il carico del server, la raccolta viene eseguita a mezzanotte per impostazione predefinita. Se si desidera cambiare l'ora della raccolta, è possibile modificare manualmente la chiave del Registro di sistema che la controlla. È disponibile una chiave del Registro di sistema specifica per ogni istanza di SQL Server. L'esempio seguente si riferisce alla prima istanza di SQL Server installata nel server (MSSQL.1):

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting.

Il valore della chiave del Registro di sistema include l'ora della raccolta espressa come numero di minuti a partire dalle ore 00.00 (mezzanotte). Se ad esempio tale valore è 60, la raccolta verrà eseguita alle ore 1.00, mentre se il valore immesso è 1200 la raccolta verrà eseguita alle ore 20.00 e così via.


Processi in esecuzione (hotfix)

Processi in esecuzione (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

Per evitare il riavvio di Windows dopo l'installazione di SP2, utilizzare la pagina Processi in esecuzione (hotfix) dell'Installazione guidata di SQL Server 2005 SP2 per identificare i processi che bloccano i file necessari per l'installazione di SQL Server 2005 SP2.

Interrompere tutti i servizi e le applicazioni che si connettono alle istanze di SQL Server da aggiornare, inclusi SQL Server Management Studio e Business Intelligence Development Studio, quindi chiudere il Pannello di controllo e Installazione applicazioni prima di installare SQL Server 2005 SP2.

  • Per eliminare la necessità di riavviare il computer dopo l'installazione di SP2, verrà visualizzato un elenco dei processi che bloccano i file necessari. Se durante l'installazione di SP2 è necessario arrestare un determinato servizio, al termine dell'installazione tale servizio verrà riavviato automaticamente.

  • Se vengono rilevati file bloccati durante l'installazione, potrebbe essere necessario riavviare il computer al termine dell'installazione di SP2. In questo caso verrà richiesto di riavviare il computer.

Opzioni

I file bloccati eventualmente rilevati dal programma di installazione verranno elencati nella tabella. Interrompere o arrestare i processi e le applicazioni inclusi nell'elenco e quindi fare clic su Aggiorna per eseguire di nuovo il controllo. Per arrestare un controllo in esecuzione, fare clic su Interrompi. Se non vengono rilevati file bloccati, la tabella sarà vuota.

Dopo l'arresto di tutti i processi che bloccano file necessari, fare clic su Avanti per continuare.

Installazione di SQL Server 2005 SP2 in un'istanza del cluster di failover

Prima di installare SQL Server 2005 SP2 in un'istanza del cluster di failover, è necessario tenere presenti le informazioni seguenti:

  • Non interrompere il servizio cluster prima di eseguire il programma di installazione di SP2 o durante l'esecuzione di tale programma.

  • Non terminare alcun processo in esecuzione prima di eseguire il programma di installazione di SP2.

  • Non attivare la modalità non in linea per il servizio SQL Server prima di eseguire il programma di installazione di SP2. Il servizio SQL Server verrà interrotto e avviato dal programma di installazione di SP2.

  • Eseguire il programma di installazione di SP2 nel nodo primario dell'istanza del cluster di failover.

  • Al termine dell'installazione di SP2, è necessario riavviare tutti i nodi del cluster di failover.

  • L'aggiornamento in sequenza non è supportato per SP2.


Inizio installazione (hotfix)

Inizio installazione (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

Nella pagina Inizio installazione (hotfix) dell'Installazione guidata di SP2 viene indicato che il programma di installazione di SQL Server 2005 SP2 dispone di tutte le informazioni necessarie per installare l'aggiornamento.

Opzioni

Fare clic su Indietro per controllare o modificare le opzioni di installazione di SQL Server 2005 SP2. Per continuare, fare clic su Installa.


Stato dell'installazione (hotfix)

Stato dell'installazione (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

La pagina Stato dell'installazione (hotfix) dell'Installazione guidata di SP2 consente di monitorare il programma di installazione durante l'applicazione di SQL Server 2005 SP2 alle istanze e ai componenti di SQL Server esistenti.

Opzioni

Nella tabella vengono specificati il nome del prodotto SQL Server, il nome della relativa istanza e lo stato dell'installazione.


Installazione completata (hotfix)

Installazione completata (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

Nella pagina Installazione completata (hotfix) dell'Installazione guidata di SP2 viene mostrato lo stato di ogni componente aggiornato a SQL Server 2005 SP2.

Opzioni

Per visualizzare un log di riepilogo dell'installazione di SQL Server 2005 SP2, fare clic su Visualizza riepilogo. Il file del log di riepilogo viene salvato in C:\Programmi\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Per visualizzare il percorso di un file di log specifico, fare clic sul nome del componente desiderato. Se ad esempio si fa clic su SQL Server Native Client, nel riquadro dei dettagli verrà visualizzato il percorso del file di log corrispondente, ovvero C:\Programmi\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log.


Ulteriori informazioni (hotfix)

Ulteriori informazioni (hotfix)
Interfaccia utente del programma di installazione (hotfix) >

Data aggiornamento: 12 dicembre 2006

The La pagina Ulteriori informazioni (hotfix) dell'Installazione guidata di SP2 contiene una casella di controllo che consente di aprire SQL Server 2005 User Provisioning Tool for Windows Vista. Utilizzare lo strumento per il provisioning per aggiornare l'elenco degli utenti del ruolo di amministratore di sistema per SQL Server.

Controllo account utente, denominato anche Protezione account utente o Account utente con limitazioni, rappresenta una nuova funzionalità di protezione di Windows Vista. Controllo account utente consente agli utenti di eseguire attività comuni come non amministratori. Gli account utente membri del gruppo Administrators locale possono eseguire la maggior parte delle applicazioni come se utilizzassero un account utente standard.

Per impostazione predefinita, agli utenti di Windows Vista membri del gruppo Administrators di Windows non vengono automaticamente concesse né le autorizzazioni necessarie per connettersi a SQL Server, né le credenziali amministrative. I membri del ruolo di amministratore di sistema di SQL Server possono eseguire qualsiasi attività nell'istanza di SQL Server.

Per consentire ai membri del gruppo Administrators di accedere da un computer che esegue Windows Vista, è necessario aggiungere esplicitamente l'account agli account di accesso di SQL Server.

Opzioni

Per aggiornare l'elenco degli utenti nel ruolo di amministratore di sistema di SQL Server, utilizzare la casella di controllo per avviare SQL Server 2005 User Provisioning Tool for Windows Vista.

Verificare che il campo Utente a cui concedere i privilegi contenga DomainName\UserName dell'utente le cui autorizzazioni devono essere aggiornate. Nell'elenco delle istanze di SQL Server incluso nel riquadro Privilegi disponibili selezionare il ruolo da aggiornare e quindi fare clic sulla freccia a destra. Per aggiungere l'utente a tutti i ruoli disponibili per tutte le istanze di SQL Server, fare doppio clic sulla freccia a destra.

Nel riquadro destro è disponibile DomainName\UserName dell'utente le cui autorizzazioni verranno aggiornate, nonché i nomi delle istanze di SQL Server e dei ruoli a cui l'utente verrà aggiunto.

Per rimuovere un ruolo dal riquadro destro, selezionare tale ruolo e quindi fare clic sulla freccia a sinistra. Per rimuovere tutti i ruoli dal riquadro destro, fare clic sulla doppia freccia a sinistra. Si noti che la funzionalità della freccia a sinistra è valida solo per gli utenti, le autorizzazioni e i ruoli visualizzati nello strumento. Nello strumento non è disponibile alcuna funzionalità per revocare le autorizzazioni. Per revocare le autorizzazioni di un utente, un amministratore deve aggiornare o rimuovere manualmente le credenziali di tale utente.

Al termine delle selezioni, fare clic su OK per implementare le modifiche apportate. Per chiudere lo strumento senza apportare alcuna modifica, fare clic su Annulla.

Per accedere a SQL Server 2005 User Provisioning Tool for Microsoft Vista al termine del programma di installazione, fare clic sul collegamento Aggiungi nuovo amministratore nello strumento Configurazione superficie di attacco (SQLSAC.exe) di SQL Server 2005.

L'elenco di collegamenti Ulteriori informazioni (hotfix) contiene collegamenti a siti Web in cui sono disponibili ulteriori informazioni su SQL Server. Tali collegamenti consentono di visualizzare informazioni sul supporto tecnico, sugli aggiornamenti della documentazione e sulle opzioni di Microsoft Update per SQL Server.