Installation du Service Pack (Correctif logiciel)

Microsoft SQL Server 2005 Service Pack 2
Installation du Service Pack (Correctif logiciel)

Vous pouvez mettre à niveau n'importe quel composant SQL Server 2005 installé sur votre ordinateur vers SQL Server 2005 SP2. Si la version d'un composant SQL Server 2005 existant est supérieure à celle de SP2, le programme d'installation de SP2 exclura ce composant de la mise à niveau.

Vous devez tenir compte des points suivants lors de l'installation de SQL Server 2005 SP2 :

  • Une fois que vous avez appliqué SQL Server 2005 SP2, vous ne pouvez pas le supprimer sans procéder à une désinstallation complète du produit.

  • Tous les composants appartenant à une instance de SQL Server doivent être mis à niveau en même temps. Par exemple, lorsque vous mettez à niveau Database Services, vous devez également mettre à niveau Analysis Services si ce composant est installé sur la même instance de SQL Server. Si un composant ou instance n'est pas sélectionné dans l'arborescence, le composant ou instance ne sera pas mis à niveau vers SQL Server 2005 SP2.

  • Utilisez l'authentification Windows chaque fois que cela est possible.

  • Lorsque vous utilisez l'authentification SQL Server, le mot de passe que vous spécifiez pour la connexion sa ne peut pas contenir de guillemets doubles. Si le mot de passe contient des guillemets doubles, utilisez l'authentification Windows au lieu de l'authentification SQL Server lorsque vous appliquez SQL Server 2005 SP2, ou modifiez le mot de passe de la connexion sa avant d'exécuter le programme d'installation du SP2.

  • Lorsque vous mettez à niveau une instance de Reporting Services, le programme d'installation se connecte au serveur de rapports afin de mettre à niveau la base de données du serveur de rapports. Si le compte Windows de l'utilisateur qui exécute le programme d'installation n'est pas membre du rôle de serveur fixe sysadmin sur le serveur de rapports, vous devez fournir un nom d'accès et un mot de passe SQL Server disposant de privilèges suffisants. Pour ce faire, sélectionnez l'instance de Reporting Services dans la boîte de dialogue Mode d'authentification, spécifiez les informations d'identification d'un compte bénéficiant des privilèges nécessaires, puis cliquez sur OK.

  • Par défaut, les fichiers journaux du programme d'installation de SQL Server 2005 SP2 sont enregistrés dans %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Documentation supplémentaire

Une documentation supplémentaire sur SQL Server 2005 SP2 est disponible à partir des sources suivantes :

  • Fichier Lisez-moi de SQL Server 2005 SP2

  • Article de la Base de connaissances Microsoft pour SQL Server 2005 SP2

Espace disque requis

Pour télécharger et installer SQL Server 2005 SP2, vous devez disposer d'au moins 1,9 Go d'espace disque libre. Le tableau ci-dessous décrit l'utilisation de l'espace disque :

Utilisation du disque (Mo) | Emplacement | Type
50 | Répertoire d'installation de SQL Server 2005 | Permanent
1 000 | Lecteur système | Permanent
600 | Répertoire Temp | Temporaire
250 | Emplacement de téléchargement | Temporaire

Après l'installation, vous pouvez supprimer le package de téléchargement de 250 Mo de votre ordinateur. L'utilisation permanente de l'espace disque de SQL Server 2005 SP2 après l'installation est d'environ 1 Go.

Vue d'ensemble de l'installation

Cette section donne une vue d'ensemble de l'installation de SQL Server 2005 SP2 en expliquant, entre autres, comment effectuer les tâches suivantes :

  • Préparer l'installation de SQL Server 2005 SP2

  • Installer SQL Server 2005 SP2

  • Redémarrer les services et les applications

Préparer l'installation de SQL Server 2005 SP2

Vous devez effectuer les opérations suivantes avant d'installer SQL Server 2005 SP2 :

  • Sauvegarder vos bases de données SQL Server 2005 - Avant d'installer SQL Server 2005 SP2, sauvegardez les bases de données master, msdb et model. L'installation de SQL Server 2005 SP2 modifie ces bases de données et les rend incompatibles avec les versions de SQL Server 2005 antérieures au SP2. La sauvegarde de ces bases de données est nécessaire si vous décidez de réinstaller SQL Server 2005 sans le SP2.

    Il est également prudent de sauvegarder vos bases de données utilisateur.

Important :
Lorsque vous appliquez le SP2 à des instances de SQL Server qui participent à une topologie de réplication, vous devez sauvegarder vos bases de données répliquées et vos bases de données système avant d'appliquer le SP2.

  • Sauvegarder vos bases de données, fichier de configuration et référentiel Analysis Services - Avant de mettre à niveau une instance d'Analysis Services vers SP2, vous devez sauvegarder les éléments suivants :

    • Les bases de données Analysis Services. Par défaut, ces bases de données sont installées dans C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\.

    • Le paramètre de configuration du serveur d'analyse dans le fichier de configuration msmdsrv.ini. Par défaut, celui-ci se trouve dans le répertoire C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\.

    • (Facultatif) La base de données contenant le référentiel Analysis Services. Cette étape est requise uniquement si le serveur d'analyse a été configuré pour fonctionner avec la bibliothèque DSO (Decision Support Objects).

Remarque :
Si vous ne sauvegardez pas vos bases de données, fichier de configuration et référentiel Analysis Services, il ne vous sera pas possible de rétrograder une instance d'Analysis Services mise à niveau vers la version précédente.

  • Vérifier que les bases de données système disposent d'un espace libre suffisant - Si l'option de croissance automatique n'est pas sélectionnée pour les bases de données système master et msdb, ces dernières doivent disposer chacune d'un espace libre d'au moins 500 Ko. Pour vérifier si les bases de données disposent d'un espace libre suffisant, exécutez la procédure stockée système sp_spaceused sur les bases de données master et msdb. Si l'espace non alloué dans l'une ou l'autre base de données est inférieur à 500 Ko, augmentez la taille de la base de données. Pour plus d'informations, consultez « Extension d'une base de données » dans la documentation en ligne de SQL Server.

  • Vérifier que les comptes de service SQL Server 2005 ne sont pas désactivés et qu'ils peuvent être démarrés - Le programme d'installation peut échouer si le type de démarrage des services MSSQLServer, MSSQLServerOLAPService et ReportServer a comme valeur Désactivé.

    Pour vérifier et activer les comptes de service :

    1. Dans le Panneau de configuration, double-cliquez sur Outils d'administration, puis double-cliquez sur Services.

    2. Recherchez le service MSSQLServer dans la liste et notez la valeur de Type de démarrage.

    3. Si la valeur de Type de démarrage est Désactivé, double-cliquez sur le nom du service, puis changez la valeur de Type de démarrage en Manuel ou Automatique.

    4. Répétez les étapes 2 et 3 pour les services MSSQLServerOLAPService et ReportServer, puis cliquez sur OK.

    5. Répétez la procédure pour toutes les instances SQL Server installées.

  • Arrêter les services et les applications - Arrêtez toutes les applications et tous les services qui établissent des connexions avec les instances de SQL Server qui sont en cours de mise à niveau, notamment SQL Server Management Studio, Business Intelligence Development Studio, le Panneau de configuration et Ajout/Suppression de programmes, avant d'installer SQL Server 2005 SP2.

Remarque :
Vous ne pouvez pas arrêter les services dans un environnement de cluster avec basculement. Pour plus d'informations, consultez la section relative à l'installation d'un cluster avec basculement plus loin dans cette rubrique.

  • Pour vous éviter d'avoir à redémarrer votre ordinateur après l'installation du SP2, le programme d'installation affiche la liste des processus qui sont responsables du verrouillage de certains fichiers. Si le programme d'installation du SP2 doit arrêter un service au cours de l'installation, il redémarrera ce dernier une fois l'installation terminée.

  • Si le programme d'installation détermine que des fichiers sont verrouillés au cours de l'installation, il peut être nécessaire de redémarrer votre ordinateur une fois l'installation du SP2 terminée. Si c'est le cas, le programme d'installation vous demandera de le faire.

Installer SQL Server 2005 SP2

Cette section décrit le processus d'installation effectué par le programme d'installation de SQL Server 2005 SP2.

Important :
Le programme d'installation de SQL Server 2005 SP2 doit être exécuté à l'aide d'un compte disposant de privilèges d'administrateur sur l'ordinateur sur lequel le SP2 sera installé.

Démarrage de l'installation de SQL Server 2005 SP2

Pour installer SQL Server 2005 SP2, exécutez le fichier de package auto-extractible SQLServer2005SP2-KB921896-PPP-LLL.exe, où PPP indique la plateforme spécifique et LLL représente un indicateur qui varie en fonction de la langue.

Remarque :
Pour appliquer le SP2 aux composants SQL Server 2005 qui font partie d'un cluster avec basculement, consultez la section relative à l'installation d'un cluster avec basculement. Pour exécuter le programme d'installation du SP2 en mode sans assistance, consultez Installation à partir de l'invite de commandes (Correctif logiciel).

Installation d'un cluster avec basculement

Les informations suivantes ne s'appliquent qu'aux composants SQL Server 2005 faisant partie d'un cluster avec basculement.

Pour installer le Service Pack sur un cluster avec basculement :

  1. Pour vous assurer que SQL Server 2005 SP2 sera installé sur tous les nœuds d'une instance de cluster avec basculement, vérifiez que le planificateur de tâches est en cours d'exécution sur tous les nœuds passifs de votre instance de cluster avec basculement.

  2. En cas d'ajout de ressources ayant des dépendances sur des ressources SQL Server, vous devez supprimer ou déconnecter ces dépendances avant de procéder à l'installation de SQL Server 2005 SP2. Si vous ne supprimez pas ces dépendances, l'installation du SP2 déconnectera ces ressources.

    Remarque :
    Lorsqu'une ressource cluster est déconnectée, toutes les ressources dépendantes sont également déconnectées par le service cluster.

  3. Exécutez le fichier de package exécutable de SQL Server 2005 SP2 à partir du nœud actif qui possède le groupe contenant l'instance de cluster avec basculement que vous comptez mettre à niveau. Les fichiers du Service Pack s'installent alors sur tous les nœuds du cluster avec basculement. Vous ne pouvez pas installer le SP2 à partir d'un nœud passif du cluster avec basculement.

  4. Dans la page Sélection de composant de l'Assistant Installation de SQL Server 2005 SP2, sélectionnez l'instance de cluster avec basculement que vous comptez mettre à niveau. Le programme d'installation vous demandera les informations d'identification de connexion qui sont utilisées pour la connexion aux autres nœuds du cluster.

    Remarque :
    Conservez tous les nœuds du cluster en ligne pendant l'installation. Vous pourrez ainsi garantir que la mise à niveau est appliquée sur chaque nœud du cluster.

  5. Si vous avez supprimé des dépendances ou déconnecté des ressources à l'étape 1, restaurez les dépendances ou ramenez les ressources en ligne.

    Remarque :
    Le programme d'installation peut vous demander de redémarrer les nœuds du cluster avec basculement. Lors de ce redémarrage, les fichiers utilisés pendant l'installation seront remplacés.
Reconstruire un nœud de cluster avec basculement SQL Server 2005 SP2

Si vous devez reconstruire un nœud dans le cluster avec basculement après l'application du SP2, procédez comme suit :

  1. Reconstruisez le nœud dans le cluster avec basculement. Pour plus d'information sur la reconstruction d'un nœud, consultez « Procédure : récupérer à partir d'une défaillance de cluster avec basculement dans le scénario 1 » dans la documentation en ligne de SQL Server.

  2. Exécutez le programme d'installation d'origine de SQL Server 2005 pour restaurer le nœud dans le cluster avec basculement.

  3. Exécutez le programme d'installation de SQL Server 2005 SP2 sur le nœud que vous avez ajouté.

Redémarrer les services et les applications

À la fin de la procédure d'installation, vous devrez peut-être redémarrer l'ordinateur. Après le redémarrage du système ou après l'exécution du programme d'installation sans redémarrage, utilisez le nœud Services dans le Panneau de configuration pour redémarrer les services que vous avez arrêtés avant d'appliquer SQL Server 2005 SP2.

Cela inclut notamment des services tels que Distributed Transaction Coordinator et les services Microsoft Search, ou des services équivalents spécifiques à une instance. Redémarrez les applications que vous avez fermées avant d'exécuter le programme d'installation de SQL Server 2005 SP2. Vous pouvez également avoir intérêt à effectuer une autre sauvegarde des bases de données master, msdb et model mises à jour, immédiatement après l'installation.


Installation à partir de l'invite de commandes (Correctif logiciel)

Installation à partir de l'invite de commandes (Correctif logiciel)

Avant d'exécuter la procédure, passez en revue les considérations relatives à l'installation dans Installation du Service Pack (Correctif logiciel).

Les commutateurs d'invite de commandes suivants sont pris en charge pour une installation sans assistance de SQL Server 2005 SP2. Testez et modifiez les scripts d'installation selon les besoins de votre organisation.

Important :
Lorsque cela est possible, fournissez les informations d'identification de sécurité au moment de l'exécution. Si vous devez stocker des informations d'identification dans un fichier de script, sécurisez le fichier pour empêcher tout accès non autorisé.

Commutateur

Description

/?

Affiche de l'aide sur l'invite de commandes d'une installation sans assistance.

/allinstances

Applique SQL Server 2005 SP2 à toutes les instances de SQL Server 2005 et à tous les composants SQL Server 2005 partagés non liés à une instance.

/instancename=InstanceName

Applique SQL Server 2005 SP2 à une instance de SQL Server 2005 nommée InstanceName et à tous les composants SQL Server 2005 partagés non liés à une instance.

/password=Password

Mot de passe de compte utilisateur pour se connecter à un nœud de cluster avec basculement distant.

/quiet

Exécute le programme d'installation de SQL Server 2005 SP2 en mode sans assistance.

/reportonly

Seule la partie de découverte et d'énumération du programme d'installation est exécutée, et un rapport énumérant les instances locales et les composants locaux de SQL Server 2005 est affiché.

Remarque :
SQL Server 2005 SP2 n'est pas appliqué en cas d'utilisation de ce commutateur.

/rsupgradedatabaseaccount=rsAccountName

Spécifie un compte disposant des autorisations appropriées pour modifier le schéma relatif à une base de données du serveur de rapports lorsque vous utilisez l'authentification SQL Server. Ce paramètre est utilisé lorsque vous mettez à niveau une instance de Reporting Services qui inclut une base de données du serveur de rapports nécessitant une connexion SQL Server.

/rsupgradepassword=rsPassword

Spécifie le mot de passe d'un compte disposant des autorisations appropriées pour modifier le schéma relatif à une base de données de serveur de rapports distante. Ce paramètre est utilisé lorsque vous mettez à niveau une instance de Reporting Services qui inclut une base de données de serveur de rapports distante.

/rsupgradedatabase

Utilisez le commutateur /rsupgradedatabase=0 pour empêcher la mise à niveau de la base de données Reporting Services.

/sapwd=SaLoginPassword

Transmet le mot de passe d'authentification SQL Server de la connexion sa pour exécuter des scripts.

Remarque :
N'utilisez pas de caractères d'échappement pour /sapwd. L'utilisation de caractères d'échappement entraîne l'échec du programme d'installation.

/user=Domain\UserName

Compte utilisateur pour se connecter à un nœud de cluster avec basculement distant.


Copyright (Correctif logiciel)

Copyright (Correctif logiciel)

Cette documentation, ainsi que les exemples d'applications inclus, est fournie à titre d'information uniquement et n'est assortie d'aucune garantie expresse ou implicite. Les informations contenues dans cette documentation, notamment les URL et autres références à des sites Web Internet, pourront faire l'objet de modifications sans préavis. L'utilisateur reconnaît assumer tous les risques liés à l'utilisation ou aux résultats de l'utilisation de cette documentation.

Un exemple présenté dans cette documentation sert principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Aucun support technique n'est disponible pour ces exemples, ni pour le code source fourni.

Sauf mention contraire, les exemples de sociétés, d'organisations, de produits, de noms de domaine, d'adresses de messagerie, de personnes, de lieux et d'événements sont fictifs et toute ressemblance avec des sociétés, des organisations, des produits, des noms de domaine, des adresses de messagerie, des personnes, des lieux ou des événements réels serait tout à fait fortuite. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Aucune partie de cette documentation ne peut être reproduite, stockée ou introduite dans un système de restitution, ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, photocopie, enregistrement ou autre) sans la permission expresse et écrite de Microsoft Corporation.

Les produits mentionnés dans cette documentation peuvent faire l'objet de brevets, de dépôts de brevets en cours, de marques, de droits d'auteur ou d'autres droits de propriété intellectuelle et industrielle de Microsoft. Sauf stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de cette documentation n'a pas pour effet de vous concéder une licence sur ces brevets, marques, ni de vous céder des droits d'auteur ou autres droits de propriété intellectuelle quels qu'ils soient.

© 2006 Microsoft Corporation. Tous droits réservés.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System et WinFX sont soit des marques déposées de Microsoft Corporation, soit des marques de Microsoft Corporation aux États-Unis d'Amérique et/ou dans d'autres pays.

SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie appliquée à la documentation d'assistance et de mise à niveau de SQL Server 2005

Le contenu de la documentation de SQL Server est publié uniquement après avoir été suffisamment testé. Tous les documents relatifs au produit (documentation en ligne de SQL Server, fichiers Lisezmoi, documents sur les problèmes connus et articles de la Base de connaissances) portent sur des fonctionnalités SQL Server suffisamment robustes pour une utilisation générale fiable pour tous les clients. Cette stratégie s'applique à la totalité de la documentation de SQL Server, y compris aux fichiers Lisezmoi des versions et Services Packs ; un fichier Lisezmoi est considéré comme une extension de la documentation en ligne.

Dans certains cas, une fonctionnalité particulière n'est pas destinée à être directement utilisée par les clients ; par conséquent, elle ne fait pas l'objet d'une documentation. Sauf si une fonctionnalité est également présentée dans la documentation de SQL Server publiée par Microsoft, le contenu des livres ou sites Web tiers n'est pas pris en charge par le support technique de Microsoft et ne doit pas être utilisé dans les bases de données ou applications de production.

Les clients ne doivent pas utiliser d'API non documentée, notamment, mais de façon non limitative : des procédures stockées, des procédures stockées étendues, des fonctions, des vues, des tables, des colonnes, des propriétés ou des métadonnées. Le support technique de Microsoft ne prend pas en charge les bases de données ou les applications qui exploitent ou font appel à des points d'entrée non documentés.

Les mises à niveau de serveur et de base de données vers des versions ultérieures de SQL Server ne sont pas garanties pour les applications et les bases de données qui exploitent et font appel à des points d'entrée non documentés. L'utilisation des fonctionnalités de SQL Server doit être limitée à celles incluses dans la documentation de Microsoft SQL Server. Si une fonctionnalité n'est pas mentionnée dans la documentation de Microsoft SQL Server, elle ne constitue pas un élément pris en charge de SQL Server.


Interface utilisateur du programme d'installation (Correctif logiciel)

Interface utilisateur du programme d'installation (Correctif logiciel)

Les rubriques suivantes fournissent des informations supplémentaires sur la procédure d'installation de SQL Server 2005 SP2. Pour afficher une rubrique d'aide, cliquez sur le lien correspondant :

Termes du contrat de licence (Correctif logiciel)

Sélection de composant (Correctif logiciel)

Mode d'authentification (Correctif logiciel)

Authentification distante (Correctif logiciel)

Rapports d'erreurs et d'utilisation (Correctif logiciel)

Processus en cours d'exécution (Correctif logiciel)

Prêt pour l'installation (Correctif logiciel)

Progression de l'installation (Correctif logiciel)

Installation terminée (Correctif logiciel)

Informations supplémentaires (Correctif logiciel)


Termes du contrat de licence (Correctif logiciel)

Termes du contrat de licence (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Termes du contrat de licence (Correctif logiciel) de l'Assistant Installation de SP2 pour accepter les termes du contrat de licence de cette version.

Options

Pour procéder à l'installation de SQL Server 2005 SP2, vous devez cliquer sur la case d'option indiquant que vous acceptez les termes du contrat de licence de SQL Server 2005 SP2. Vous pouvez ensuite cliquer sur Suivant pour continuer.

Utilisez le bouton Imprimer pour imprimer un exemplaire des termes du contrat de licence de cette version. Pour quitter le programme d'installation de SQL Server 2005 SP2, cliquez sur Annuler.


Sélection de composant (Correctif logiciel)

Sélection de composant (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Sélection de composant (Correctif logiciel) de l'Assistant Installation de SP2 pour sélectionner les composants et fonctionnalités SQL Server à mettre à jour.

Options

Cliquez sur un nom de composant dans le volet de gauche pour voir les informations relatives à la langue, au système d'exploitation, à l'édition et à l'état du composant.

Pour mettre à jour un composant ou une fonctionnalité, activez la case à cocher qui se trouve en regard de son nom. Pour exclure un composant ou une fonctionnalité de cette mise à jour, désactivez la case à cocher qui se trouve en regard de son nom.

Différentes instances de SQL Server 2005 installées sur un même ordinateur peuvent être mises à jour séparément, mais tous les composants d'une même instance de SQL Server doivent être mis à niveau en même temps. Tous les composants partagés, tels que les composants de station de travail, l'analyseur MSXML, SQLXML, les composants de compatibilité descendante et VSS Writer, doivent être mis à niveau vers SQL Server 2005 SP2.

Si un composant ne peut pas être mis à niveau, une explication sera fournie dans le volet d'informations.


Mode d'authentification (Correctif logiciel)

Mode d'authentification (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Mode d'authentification (Correctif logiciel) de l'Assistant Installation de SP2 pour spécifier les informations d'instance et d'authentification qui seront utilisées par le programme d'installation pour se connecter aux instances de SQL Server que vous souhaitez mettre à jour.

Options

Si le mode d'authentification, le nom d'utilisateur et le mot de passe sont les mêmes pour tous les composants ou instances à mettre à jour, activez la case à cocher Appliquer la sélection à toutes les instances. Si vous activez cette option, la liste déroulante Nom de l'instance sera désactivée. Spécifiez les informations relatives au type d'authentification, au nom d'utilisateur et au mot de passe, puis cliquez sur Tester pour vérifier les informations d'identification.

Si le mode d'authentification, le nom d'utilisateur et le mot de passe ne sont pas les mêmes pour tous les composants à mettre à jour, spécifiez le nom de l'instance, le type d'authentification, le nom d'utilisateur et le mot de passe pour chaque composant ou instance à mettre à jour, puis cliquez sur Tester pour vérifier les informations d'identification.

À mesure que les informations d'identification sont vérifiées pour chaque composant ou pour chaque instance de SQL Server, les résultats s'affichent dans la table d'état. Une fois que tous les composants apparaissent dans la table avec l'indication « Succès », cliquez sur Suivant pour continuer. Vous devez résoudre tous les problèmes d'authentification avant de poursuivre.

Si l'authentification échoue, mettez à jour les informations fournies pour le composant, puis relancez le test. Une fois que tous les composants apparaissent dans la table avec l'indication « Succès », cliquez sur Suivant pour continuer.


Authentification distante (Correctif logiciel)

Authentification distante (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Authentification distante (Correctif logiciel) de l'Assistant Installation de SP2 pour fournir des informations d'ouverture de session à distance pour les instances de cluster avec basculement de SQL Server que vous souhaitez mettre à jour.

Options

Nom d'utilisateur

Si le champ d'ouverture de session n'est pas rempli, spécifiez un nom d'utilisateur qui soit un compte d'administrateur valide pour tous les nœuds du cluster avec basculement.

Mot de passe

Spécifiez un mot de passe pour le compte d'administrateur sélectionné.

Domaine

Spécifiez le nom de domaine pour le compte d'administrateur sélectionné.


Rapports d'erreurs et d'utilisation (Correctif logiciel)

Rapports d'erreurs et d'utilisation (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Rapports d'erreurs et d'utilisation (Correctif logiciel) de l'Assistant Installation de SP2 pour activer la fonctionnalité de rapport d'erreurs et d'utilisation dans SQL Server 2005.

Options

SQL Server SP2 offre la possibilité de configurer SQL Server de manière à envoyer automatiquement des rapports d'erreurs de service irrécupérables à Microsoft ou au serveur de rapports d'erreurs de votre entreprise. Vous pouvez désactiver l'une de ces options ou les deux en désactivant les cases à cocher se trouvant sur cette page. Microsoft utilise les rapports d'erreurs pour améliorer le fonctionnement de SQL Server et garantit la confidentialité de toutes les données de rapports d'erreurs et d'utilisation des fonctionnalités.

Rapport d'erreurs

Si vous activez la fonctionnalité Rapport d'erreurs, SQL Server est configuré pour envoyer automatiquement un rapport à Microsoft si une erreur irrécupérable se produit dans l'un des composants SQL Server suivants :

  • Moteur de base de données

  • Agent SQL Server

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Réplication

Microsoft utilise les rapports d'erreurs pour améliorer le fonctionnement de SQL Server et garantit la confidentialité de toutes les informations.

Des informations sur les erreurs sont envoyées à Microsoft par le biais d'une connexion sécurisée (https) et elles sont ensuite stockées avec un accès limité. Les rapports d'erreurs peuvent également être envoyés vers votre propre serveur de rapports d'erreurs d'entreprise. Consultez le site Web de Microsoft sur les Rapports d'erreurs d'entreprise pour plus d'informations sur la configuration d'un serveur de rapports d'erreurs d'entreprise.

Les rapports d'erreurs contiennent les informations suivantes :

  • la condition de SQL Server lorsque le problème s'est produit ;

  • des informations sur la version du système d'exploitation et le matériel ;

  • votre ID de produit numérique, qui n'est pas utilisé pour identifier votre licence ;

  • l'adresse IP réseau de votre ordinateur ou de votre serveur proxy ;

  • des informations fournies par la mémoire ou par des fichiers associés au processus qui est à l'origine de l'erreur.

Microsoft ne collecte pas de manière intentionnelle vos fichiers, nom, adresse, adresse électronique ou toute autre forme d'informations personnelles. Le rapport d'erreurs peut toutefois contenir des informations personnelles provenant de la mémoire ou de fichiers associés au processus qui est à l'origine de l'erreur. Bien que ces informations permettent a priori de déterminer votre identité, Microsoft ne les exploite pas à cette fin.

Pour plus d'informations sur la politique de confidentialité et de collecte de données de , consultez la Déclaration de confidentialité de SQL Server 2005.

Si vous activez la fonctionnalité Rapport d'erreurs et qu'une erreur irrécupérable se produit, vous pouvez voir dans certains cas une réponse de Microsoft dans le journal des événements Windows, incluant un lien qui pointe vers un article de la Base de connaissances de Microsoft portant sur une erreur particulière.

Pour désactiver la fonction de rapport d'erreurs et d'utilisation des fonctionnalités pour toutes les instances de SQL Server et leurs composants une fois l'installation terminée, accédez à la boîte de dialogue Paramètres de rapports d'erreurs et d'utilisation (Démarrer - Tous les programmes - Microsoft SQL Server 2005 - Outils de configuration - Rapports d'erreurs et d'utilisation SQL Server) et désactivez la case à cocher pour Envoyer les rapports d'utilisation de fonctions de tous les composants et de toutes les instances de SQL Server 2005 à Microsoft. Si l'option Rapport d'erreurs est activée pour plusieurs composants de SQL Server (le Moteur de base de données, le serveur d'analyse, le serveur de rapports et les composants partagés), vous pouvez la désactiver individuellement pour chaque instance d'un composant. Vous pouvez également désactiver cette option pour les composants partagés classés comme Autres.

Utilisation des fonctionnalités

Si vous activez les rapports d'utilisation des fonctionnalités, SQL Server est configuré pour envoyer périodiquement un rapport à Microsoft. Ces rapports incluent des informations sur votre configuration matérielle et sur la façon dont vous utilisez les logiciels et les services SQL Server 2005. Microsoft utilise les données d'utilisation des fonctionnalités pour améliorer SQL Server. Les composants suivants font partie des composants SQL Server 2005 analysés :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Réplication

  • Business Intelligence Development Studio

Les informations sur l'utilisation des fonctionnalités sont envoyées à Microsoft, puis stockées avec un accès limité.

Pour désactiver les rapports d'utilisation des fonctionnalités une fois l'installation terminée, utilisez l'outil Rapports d'erreurs et d'utilisation SQL Server dans le menu Outils de configuration de SQL Server 2005.

Les informations sont collectées une fois par jour pour toutes les instances de SQL Server pour lesquelles cette fonction est activée. Par défaut, la collecte est effectuée à minuit afin de réduire la charge sur le serveur. Si vous souhaitez changer l'heure de la collecte, vous pouvez modifier manuellement la clé de Registre concernée. Chaque instance de SQL Server possède sa propre clé de Registre. L'exemple suivant correspond à la première instance de SQL Server qui est installée sur le server (MSSQL.1) :

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

La valeur de cette clé de Registre inclut l'heure de la collecte sous la forme du nombre de minutes qui s'écoulent à partir de 00:00 (minuit). Par exemple, la valeur 60 fixe l'exécution de la collecte à 1:00 tandis que la valeur 1200 fixe l'exécution de la collecte à 20:00.


Processus en cours d'exécution (Correctif logiciel)

Processus en cours d'exécution (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Pour éviter de redémarrer Windows après avoir installé SP2, utilisez la page Processus en cours d'exécution (Correctif logiciel) de l'Assistant Installation de SQL Server 2005 SP2 afin d'identifier les processus qui verrouillent des fichiers requis par le programme d'installation de SQL Server 2005 SP2.

Arrêtez toutes les applications et tous les services qui établissent des connexions avec les instances de SQL Server qui sont en cours de mise à niveau. Vous devez, entre autres, arrêter SQL Server Management Studio et Business Intelligence Development Studio, et fermer le Panneau de configuration et la fenêtre Ajout/Suppression de programmes avant d'installer SQL Server 2005 SP2.

  • Pour vous éviter d'avoir à redémarrer votre ordinateur après l'installation du SP2, le programme d'installation affiche la liste des processus qui sont responsables du verrouillage de certains fichiers. Si le programme d'installation du SP2 doit arrêter un service au cours de l'installation, il redémarrera ce dernier une fois l'installation terminée.

  • Si le programme d'installation détermine que des fichiers sont verrouillés au cours de l'installation, vous devrez peut-être redémarrer votre ordinateur après l'installation du SP2. Si c'est le cas, le programme d'installation vous demandera de le faire.

Options

Si le programme d'installation détecte des fichiers verrouillés, ceux-ci seront répertoriés dans le tableau. Arrêtez ou terminez les processus et applications figurant dans la liste, puis cliquez sur Actualiser pour relancer la vérification. Cliquez sur Arrêter pour mettre fin à une vérification en cours d'exécution. Si aucun fichier verrouillé n'est détecté, le tableau sera vide.

Une fois que tous les processus bloquants ont été arrêtés, cliquez sur Suivant pour continuer.

Installation de SQL Server 2005 SP2 sur une instance de cluster avec basculement

Notez les informations qui suivent avant d'installer SQL Server 2005 SP2 sur une instance de cluster avec basculement :

  • N'arrêtez pas le service de cluster avant d'exécuter le programme d'installation du Service Pack 2 ou pendant l'exécution du programme d'installation.

  • N'arrêtez pas les processus en cours d'exécution avant d'exécuter le programme d'installation du SP2.

  • Ne déconnectez pas le service SQL Server avant d'exécuter le programme d'installation du SP2. Le programme d'installation du SP2 arrêtera et redémarrera le service SQL Server.

  • Exécutez le programme d'installation du SP2 sur le nœud principal de l'instance de cluster avec basculement.

  • Vous devez redémarrer tous les nœuds de cluster avec basculement

  • La mise à niveau propagée n'est pas prise en charge par le SP2.


Prêt pour l'installation (Correctif logiciel)

Prêt pour l'installation (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

La page Prêt pour l'installation (Correctif logiciel) de l'Assistant Installation de SP2 indique que le programme d'installation de SQL Server 2005 SP2 dispose de toutes les informations nécessaires pour installer la mise à jour.

Options

Cliquez sur Précédent pour passer en revue ou pour modifier les options d'installation de SQL Server 2005 SP2. Pour continuer, cliquez sur Installer.


Progression de l'installation (Correctif logiciel)

Progression de l'installation (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Utilisez la page Progression de l'installation (Correctif logiciel) de l'Assistant Installation de SP2 pour surveiller le programme d'installation pendant qu'il applique SQL Server 2005 SP2 à vos composants et instances SQL Server.

Options

La table indique le nom du produit SQL Server, son nom d'instance et l'état de l'installation.


Installation terminée (Correctif logiciel)

Installation terminée (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

La page Installation terminée (Correctif logiciel) de l'Assistant Installation de SP2 indique l'état de chaque composant qui est mis à jour vers SQL Server 2005 SP2.

Options

Pour voir un journal résumé de l'installation de SQL Server 2005 SP2, cliquez sur Résumé. Le fichier journal résumé est enregistré dans C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\.

Pour afficher le chemin d'accès d'un fichier journal, cliquez sur le nom du composant. Par exemple, si vous cliquez sur SQL Server Native Client, le volet d'informations indiquera le chemin d'accès du fichier journal suivant : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log.


Informations supplémentaires (Correctif logiciel)

Informations supplémentaires (Correctif logiciel)
Interface utilisateur du programme d'installation (Correctif logiciel) >

Mis à jour : 12 décembre 2006

La page Informations supplémentaires (Correctif logiciel) de l'Assistant Installation de SP2 contient une case à cocher pour ouvrir l'outil Mise en service d'utilisateur SQL Server 2005 sur Vista. Utilisez cet outil pour mettre à jour la liste des utilisateurs du rôle Administrateur système pour SQL Server.

La fonction Contrôle de compte d'utilisateur, aussi appelée Protection des comptes d'utilisateur ou Comptes utilisateur limités, est une nouvelle fonction de sécurité de Windows Vista. Cette fonction permet aux utilisateurs d'effectuer des tâches courantes sans être administrateurs. Les comptes d'utilisateur qui sont membres du groupe local Administrateurs exécutent la plupart des applications comme s'ils utilisaient un compte d'utilisateur standard.

Par défaut, les utilisateurs de Windows Vista membres du groupe Administrateurs Windows ne disposent pas automatiquement de l'autorisation nécessaire pour se connecter à SQL Server. De plus, les utilisateurs ne disposent pas automatiquement des informations d'identification d'administration. Les membres du rôle Administrateur système de SQL Server peuvent effectuer n'importe quelle activité dans l'instance de SQL Server.

Pour permettre aux membres du groupe Administrateurs de se connecter depuis un ordinateur qui exécute Windows Vista, vous devez ajouter manuellement le compte aux comptes SQL Server.

Options

Pour mettre à jour la liste des utilisateurs dans le rôle Administrateur système de SQL Server, utilisez la case à cocher pour démarrer l'outil Mise en service d'utilisateur SQL Server 2005 sur Vista.

Assurez-vous que le champ Utilisateur à mettre en service contient les paramètres NomDomaine\NomUtilisateur de l'utilisateur dont les autorisations doivent être mises à jour. Sélectionnez le rôle à mettre à jour dans la liste des instances de SQL Server dans le volet Privilèges disponibles, puis cliquez sur la flèche droite. Pour ajouter l'utilisateur à tous les rôles disponibles pour toutes les instances disponibles de SQL Server, double-cliquez sur la flèche droite.

Le volet de droite présente l'ensemble NomDomaine\NomUtilisateur de l'utilisateur dont les autorisations vont être mises à jour, ainsi que les instances de SQL Server et les rôles auxquels l'utilisateur sera ajouté.

Pour supprimer un rôle dans le volet de droite, sélectionnez-le et cliquez sur la flèche gauche. Pour supprimer tous les rôles dans le volet de droite, cliquez sur la double flèche vers la gauche. Notez que la flèche gauche affecte uniquement les utilisateurs, les rôles et les autorisations affichés dans l'outil. L'outil n'offre aucune fonctionnalité de révocation d'autorisations. Pour révoquer des autorisations d'un utilisateur, un administrateur doit mettre à jour ou supprimer manuellement les informations d'identification de l'utilisateur.

Pour implémenter les modifications une fois votre sélection terminée, cliquez sur OK. Pour quitter l'outil sans apporter de modification, cliquez sur Annuler.

Pour accéder à l'outil Mise en service d'utilisateur SQL Server 2005 sur Vista après la fin de cette installation, cliquez sur le lien Ajouter un nouvel administrateur dans l'outil Configuration de la surface d'exposition de SQL Server 2005 (SQLSAC.exe).

La liste des liens Informations supplémentaires (Correctif logiciel) fournit des liens vers des sites Web qui proposent des informations supplémentaires sur SQL Server. Ces liens comprennent des informations sur la prise en charge du produit, les mises à jour de la documentation et les options de Microsoft Update pour SQL Server.