Installieren des Service Packs (Hotfix)

Microsoft SQL Server 2005 Service Pack 2
Installieren des Service Packs (Hotfix)

Sie können jede installierte Komponente von SQL Server 2005 auf SQL Server 2005 SP2 aktualisieren. Wenn die Versionsebene einer vorhandenen Komponente von SQL Server 2005 höher ist als die SP2-Versionsebene, schließt das SP2-Setupprogramm diese Komponente von der Aktualisierung aus.

Folgendes gilt bei der Installation von SQL Server 2005 SP2:

  • Nachdem SQL Server 2005 SP2 angewendet wurde, kann es nicht entfernt werden, ohne dass das gesamte Produkt deinstalliert wird.

  • Alle Features, die zu einer Instanz von SQL Server gehören, müssen gleichzeitig aktualisiert werden. Wenn Sie beispielsweise Datenbankdienste aktualisieren, müssen Sie auch Analysis Services aktualisieren, sofern Analysis Services in derselben Instanz von SQL Server installiert ist. Wenn eine Komponente oder Instanz in der Featurestruktur nicht ausgewählt ist, wird die Komponente oder Instanz nicht auf SQL Server 2005 SP2 aktualisiert.

  • Verwenden Sie nach Möglichkeit immer die Windows-Authentifizierung.

  • Bei Verwendung der SQL Server-Authentifizierung kann das von Ihnen für die sa-Anmeldung bereitgestellte Kennwort keine doppelten Anführungszeichen enthalten. Falls das Kennwort doppelte Anführungszeichen enthält, verwenden Sie bei der Anwendung von SQL Server 2005 SP2 die Windows-Authentifizierung statt der SQL Server-Authentifizierung, oder ändern Sie das Kennwort für die sa-Anmeldung vor der Ausführung des SP2-Setups.

  • Beim Aktualisieren einer Instanz von Reporting Services stellt das Setup eine Verbindung mit dem Berichtsserver her, um die Berichtsserver-Datenbank zu aktualisieren. Wenn das Windows-Konto des Benutzers, der das Setup ausführt, kein Mitglied der festen Serverrolle sysadmin des Berichtsservers ist, müssen Sie einen SQL Server-Anmeldenamen und ein Kennwort bereitstellen, dass über ausreichende Berechtigungen verfügt. Dazu wählen Sie eine Instanz von Reporting Services im Dialogfeld Authentifizierungsmodus aus, stellen die Anmeldeinformationen eines Kontos bereit, das über die entsprechenden Privilegien verfügt, und klicken dann auf OK.

  • Standardmäßig werden die SQL Server 2005 SP2-Setupprotokolldateien in %Programme%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\ gespeichert.

Zusätzliche Dokumentation

Zusätzliche SQL Server 2005 SP2-Dokumentation ist in den folgenden Quellen verfügbar:

  • Die SQL Server 2005 SP2-Infodatei.

  • Der Microsoft Knowledge Base-Artikel für SQL Server 2005 SP2.

Anforderungen an den Festplattenspeicher

Zum Downloaden und Installieren von SQL Server 2005 SP2 sind mindestens 1,9 GB verfügbarer Speicherplatz auf Ihrem Computer erforderlich. In der folgenden Tabelle wird die Speicherplatzverwendung aufgeführt:

Datenträgerverwendung (MB) | Pfad | Typ
50 | Installationsverzeichnis für SQL Server 2005 | Permanent
1,000 | Systemlaufwerk | Permanent
600 | Temporäres Verzeichnis | Temporär
250 | Downloadadresse | Temporär

Nach der Installation kann das Downloadpaket über 250 MB vom Computer entfernt werden. Die permanente Speicherplatzverwendung nach der Installation von SQL Server 2005 SP2 beträgt ungefähr 1 GB.

Übersicht über die Installation

In diesem Abschnitt finden Sie eine Übersicht über die Installation von SQL Server 2005 SP2, einschließlich Anweisungen zum Ausführen folgender Vorgänge:

  • Vorbereiten einer Installation von SQL Server 2005 SP2

  • Installieren von SQL Server 2005 SP2

  • Neustarten von Diensten und Anwendungen

Vorbereiten einer Installation von SQL Server 2005 SP2

Vor dem Installieren von SQL Server 2005 SP2 müssen Sie die folgenden Schritte ausführen:

  • Sichern der SQL Server 2005-Datenbanken - Sichern Sie vor der Installation von SQL Server 2005 SP2 die Datenbanken master, msdb und model. Durch die Installation von SQL Server 2005 SP2 werden diese Datenbanken geändert und sind somit inkompatibel mit Versionen von SQL Server 2005 vor SP2. Sicherungen dieser Datenbanken sind erforderlich, wenn Sie SQL Server 2005 ohne SP2 erneut installieren möchten.

    Das Sichern der Benutzerdatenbanken ist ebenfalls empfehlenswert.

Wichtig:
Wenn Sie SP2 auf Instanzen von SQL Server anwenden, die an einer Replikationstopologie beteiligt sind, müssen Sie vor dem Anwenden von SP2 die replizierten Datenbanken zusammen mit den Systemdatenbanken sichern.

  • Sichern der Datenbanken, der Konfigurationsdatei und des Repositorys von Analysis Services - Vor dem Aktualisieren einer Instanz von Analysis Services auf SP2 sollten Sie Folgendes sichern:

    • Analysis Services-Datenbanken. Standardmäßig sind diese in C:\Programme\Microsoft SQL Server\MSSQL.1\OLAP\Data\ installiert.

    • Die Analysis-Serverkonfigurationseinstellung in der Konfigurationsdatei msmdsrv.ini. Standardmäßig befindet sich diese im Verzeichnis C:\Programme\Microsoft SQL Server\MSSQL.1\OLAP\Config\.

    • (Optional) Die Datenbank, die das Analysis Services-Repository enthält. Dieser Schritt ist nur erforderlich, wenn der Analysis-Server für die Verwendung der DSO-Bibliothek (Decision Support Objects) konfiguriert wurde.

Hinweis:
Ohne eine Sicherung der Analysis Services-Datenbanken sowie der Konfigurationsdatei und des Repositorys von Analysis Services ist es nicht möglich, eine aktualisierte Instanz von Analysis Services auf die vorherige Version zurückzusetzen.

  • Überprüfen des freien Speicherplatzes für die Systemdatenbanken - Falls die automatische Vergrößerungsoption für die Systemdatenbanken master und msdb nicht aktiviert ist, muss für jede dieser Datenbanken mindestens 500 KB Speicherplatz verfügbar sein. Führen Sie die gespeicherte Systemprozedur sp_spaceused für die Datenbanken master und msdb aus, um zu überprüfen, ob die Datenbanken über genügend Speicherplatz verfügen. Falls der nicht zugeordnete Speicherplatz in einer der Datenbanken weniger als 500 KB beträgt, sollten Sie die Datenbank vergrößern. Weitere Informationen finden Sie unter "Erweitern einer Datenbank" in der SQL Server-Onlinedokumentation.

  • Überprüfen, ob die SQL Server 2005-Dienstkonten nicht deaktiviert sind und gestartet werden können - Möglicherweise tritt ein Fehler im Setup auf, wenn der Starttyp des Dienstes für die Dienste MSSQLServer, MSSQLServerOLAPService und ReportServer auf Deaktiviert festgelegt ist.

    So überprüfen und aktivieren Sie Dienstkonten:

    1. Doppelklicken Sie in der Systemsteuerung auf Verwaltung und dann auf Dienste.

    2. Suchen Sie den Dienst MSSQLServer in der Liste, und beachten Sie den Wert von Starttyp.

    3. Hat Starttyp den Wert Deaktiviert, doppelklicken Sie auf den Dienstnamen, und ändern Sie den Wert von Starttyp in Manuell oder in Automatisch.

    4. Wiederholen Sie die Schritte 2 und 3 für die Dienste MSSQLServerOLAPService und ReportServer, und klicken Sie dann auf OK.

    5. Wiederholen Sie den Vorgang für alle installierten Instanzen von SQL Server.

  • Beenden von Diensten und Anwendungen - Beenden Sie vor dem Installieren von SQL Server 2005 SP2 alle Anwendungen und Dienste, durch die Verbindungen mit den zu aktualisierenden Instanzen von SQL Server hergestellt werden, einschließlich SQL Server Management Studio, Business Intelligence Development Studio, der Systemsteuerung und Software.

Hinweis:
In einer Failoverclusterumgebung können Sie keine Dienste beenden. Weitere Informationen hierzu finden Sie weiter unten in diesem Thema im Abschnitt zur Failoverclusterinstallation.

  • Damit der Computer nach der SP2-Installation nicht neu gestartet werden muss, zeigt das Setup eine Liste der Prozesse an, die Dateien sperren. Wenn das SP2-Setupprogramm einen Dienst während der Installation beenden muss, wird der Dienst nach Abschluss der Installation neu gestartet.

  • Falls vom Setup bestimmt wird, dass Dateien während der Installation gesperrt werden, ist möglicherweise ein Neustart des Computers nach Abschluss der SP2-Installation erforderlich. Gegebenenfalls werden Sie aufgefordert, den Computer neu zu starten.

Installation von SQL Server 2005 SP2

In diesem Abschnitt wird der Installationsvorgang beim SQL Server 2005 SP2-Setup beschrieben.

Wichtig:
Das SQL Server 2005 SP2-Setup muss unter einem Konto ausgeführt werden, das über Administratorprivilegien auf dem Computer verfügt, auf dem SP2 installiert wird.

Starten des SQL Server 2005 SP2-Setups

Zum Installieren von SQL Server 2005 SP2 führen Sie die selbstextrahierende Paketdatei SQLServer2005SP2-KB921896-PPP-LLL.exe aus. PPP gibt hierbei die jeweilige Plattform an, und LLL stellt einen von der Sprache abhängigen Bezeichner dar.

Hinweis:
Informationen zum Anwenden von SP2 auf Komponenten von SQL Server 2005, die Teil eines Failoverclusters sind, finden Sie im Abschnitt zur Failoverclusterinstallation. Informationen zum Ausführen des SP2-Setups im unbeaufsichtigten Modus finden Sie unter Installieren von der Eingabeaufforderung (Hotfix).

Failoverclusterinstallation

Die folgenden Informationen gelten nur für SQL Server 2005-Komponenten, die Teil eines Failoverclusters sind.

So installieren Sie das Service Pack in einem Failovercluster:

  1. Stellen Sie sicher, dass SQL Server 2005 SP2 auf allen Knoten einer Failoverclusterinstanz installiert wird, indem Sie überprüfen, ob der Taskplaner auf allen passiven Knoten der Failoverclusterinstanz ausgeführt wird.

  2. Falls Ressourcen hinzugefügt wurden, die Abhängigkeiten von SQL Server-Ressourcen aufweisen, müssen diese Abhängigkeiten vor der Installation von SQL Server 2005 SP2 entfernt oder die betreffenden Ressourcen offline geschaltet werden. Wenn Sie die Abhängigkeiten nicht entfernen, werden die betreffenden Ressourcen bei der Installation von SP2 offline geschaltet.

    Hinweis:
    Wenn eine gruppierte Ressource offline geschaltet wird, werden alle abhängigen Ressourcen vom Clusterdienst ebenfalls offline geschaltet.

  3. Führen Sie die ausführbare Paketdatei für SQL Server 2005 SP2 von dem aktiven Knoten aus, der Besitzer der Gruppe mit der zu aktualisierenden Failoverclusterinstanz ist. Dadurch werden die Service Pack-Dateien auf allen Knoten im Failovercluster installiert. Sie können SP2 nicht von einem passiven Knoten im Failovercluster installieren.

  4. Wählen Sie auf der Featureauswahlseite des Setup-Assistenten für SQL Server 2005 SP2 die Failoverclusterinstanz aus, die aktualisiert werden soll. Sie werden vom Setup zur Eingabe der Anmeldeinformationen aufgefordert, die zur Verbindung mit anderen Knoten im Cluster verwendet werden.

    Hinweis:
    Lassen Sie alle Knoten des Clusters während der Ausführung des Setups online geschaltet. So wird sichergestellt, dass das Update auf jeden Clusterknoten angewendet wird.

  5. Falls Sie in Schritt 1 Abhängigkeiten entfernt oder Ressourcen offline geschaltet haben, stellen Sie die Abhängigkeiten jetzt wieder her, bzw. schalten Sie die Ressourcen wieder online.

    Hinweis:
    Möglicherweise erfordert das Setup, dass Sie die Failoverclusterknoten neu starten. Beim Neustart werden die Dateien ersetzt, die bei der Ausführung des Setups verwendet wurden.
Neuerstellen eines SQL Server 2005 SP2-Failoverclusterknotens

Führen Sie die folgenden Schritte aus, wenn Sie einen Knoten im Failovercluster nach der Anwendung von SP2 neu erstellen müssen.

  1. Erstellen Sie den Knoten im Failovercluster neu. Weitere Informationen zum Neuerstellen eines Knotens finden Sie unter "Vorgehensweise: Wiederherstellen bei einem Failovercluster-Fehler in Szenario 1" in der SQL Server-Onlinedokumentation.

  2. Führen Sie das ursprüngliche SQL Server 2005-Setupprogramm aus, um den Knoten im Failovercluster wiederherzustellen.

  3. Führen Sie das SQL Server 2005 SP2-Setup auf dem hinzugefügten Knoten aus.

Neustarten von Diensten und Anwendungen

Nach Abschluss des Setups werden Sie möglicherweise aufgefordert, den Computer neu zu starten. Nach dem Neustart des Systems oder nach Abschluss des Setups ohne erforderlichen Neustart können Sie den Knoten Dienste in der Systemsteuerung verwenden, um die Dienste neu zu starten, die Sie vor dem Anwenden von SQL Server 2005 SP2 beendet haben.

Dazu gehören Dienste wie Distributed Transaction Coordinator und die Microsoft Search-Dienste oder instanzspezifische entsprechende Dienste. Starten Sie die Anwendungen erneut, die Sie vor dem Ausführen von SQL Server 2005 SP2-Setup beendet haben. Es ist auch sinnvoll, gleich nach der erfolgreichen Installation eine weitere Sicherung der aktualisierten Datenbanken master, msdb und model zu erstellen.


Installieren von der Eingabeaufforderung (Hotfix)

Installieren von der Eingabeaufforderung (Hotfix)

Bevor Sie den Vorgang fortsetzen, lesen Sie die Überlegungen zur Installation unter Installieren des Service Packs (Hotfix).

Die folgenden Eingabeaufforderungsoptionen werden für die unbeaufsichtigte Installation von SQL Server 2005 SP2 unterstützt. Testen und ändern Sie die Installationsskripts, um die Anforderungen Ihrer Organisation zu erfüllen.

Wichtig:
Anmeldeinformationen sollten nach Möglichkeit zur Laufzeit angegeben werden. Wenn Sie Anmeldeinformationen in einer Skriptdatei speichern müssen, sollten Sie die Datei schützen, um nicht autorisierten Zugriff zu verhindern.

Schalter

Beschreibung

/?

Zeigt Hilfe zur unbeaufsichtigten Installation an der Eingabeaufforderung an.

/allinstances

Wendet SQL Server 2005 SP2 auf alle Instanzen von SQL Server 2005 und auf alle freigegebenen, nicht instanzabhängigen Komponenten von SQL Server 2005 an.

/instancename=InstanceName

Wendet SQL Server 2005 SP2 auf eine Instanz von SQL Server 2005 namens InstanceName und auf alle freigegebenen, nicht instanzabhängigen Komponenten von SQL Server 2005 an.

/password=Password

Kennwort eines Benutzerkontos zum Herstellen einer Verbindung mit einem Remote-Failoverclusterknoten.

/quiet

Führt das SQL Server 2005 SP2-Setup im unbeaufsichtigten Modus aus.

/reportonly

Nur der Ermittlungs- und Aufzählungsabschnitt des Setups wird ausgeführt. Anschließend wird ein Bericht angezeigt, in dem die lokalen Instanzen und Komponenten von SQL Server 2005 aufgezählt sind.

Hinweis:
Bei Verwendung dieses Schalters wird SQL Server 2005 SP2 nicht angewendet.

/rsupgradedatabaseaccount=rsAccountName

Gibt ein Konto an, das Berechtigungen zum Ändern des Schemas in einer Berichtsserver-Datenbank hat, wenn Sie die SQL Server-Authentifizierung verwenden. Dieser Parameter wird verwendet, wenn Sie eine Instanz von Reporting Services aktualisieren, die eine Berichtsserver-Datenbank enthält, die eine SQL Server-Anmeldung erfordert.

/rsupgradepassword=rsPassword

Gibt das Kennwort für ein Konto an, das Berechtigungen zum Ändern des Schemas in einer Remoteberichtsserver-Datenbank hat. Der Parameter wird verwendet, wenn Sie eine Instanz von Reporting Services aktualisieren, die eine Remoteberichtsserver-Datenbank enthält.

/rsupgradedatabase

Verwenden Sie den Schalter /rsupgradedatabase=0, um zu verhindern, dass die Reporting Services-Datenbank aktualisiert wird

/sapwd=SaLoginPassword

Übergibt das SQL Server-Authentifizierungskennwort für die Systemadministratoranmeldung zum Ausführen von Skripts.

Hinweis:
Verwenden Sie keine Escapezeichen für /sapwd. Escapezeichen verursachen Setupfehler.

/user=Domain\UserName

Benutzerkonto zum Herstellen einer Verbindung mit einem Remote-Failoverclusterknoten.


Urheberrechtshinweis (Hotfix)

Urheberrechtshinweis (Hotfix)

Diese Dokumentation, einschließlich der hierin enthaltenen Beispiele, wird lediglich zu Informationszwecken zur Verfügung gestellt, ohne jede Gewährleistung, sei sie ausdrücklich oder konkludent. Die in dieser Dokumentation enthaltenen Angaben und Daten, einschließlich URLs und anderen Verweisen auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Das vollständige Risiko der Nutzung oder der Ergebnisse der Nutzung dieser Dokumentation liegt bei dem Benutzer.

Die in dieser Dokumentation enthaltenen Beispiele dienen in erster Linie der Veranschaulichung eines Konzepts oder der sinnvollen Verwendung einer bestimmten Anweisung oder Klausel. Die meisten Beispiele enthalten nicht den gesamten Code, der normalerweise in einem vollständigen Produktionssystem vorhanden wäre, da die Datenüberprüfung und Fehlerbehandlung teilweise entfernt wurde, um das Beispiel eines bestimmten Konzepts oder einer Anweisung hervorzuheben. Für diese Beispiele oder den enthaltenen Quellcode ist kein technischer Support verfügbar.

Die in den Beispielen verwendeten Namen von Firmen, Organisationen, Produkten, Domänen, Personen, Orten, Ereignissen sowie E-Mail-Adressen und Logos sind frei erfunden, soweit nichts anderes angegeben ist. Jede Ähnlichkeit mit tatsächlichen Firmen, Organisationen, Produkten, Domänen, Personen, Orten, Ereignissen, E-Mail-Adressen und Logos ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieser Dokumentation für irgendwelche Zwecke vervielfältigt oder in einem Datenempfangssystem gespeichert oder eingelesen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen usw.) dies geschieht.

Es ist möglich, dass Microsoft Rechte an Patenten bzw. angemeldeten Patenten, an Marken, Urheberrechten oder sonstigem geistigen Eigentum besitzt, die sich auf den fachlichen Inhalt dieser Dokumentation beziehen. Das Bereitstellen dieser Dokumentation gibt Ihnen jedoch keinen Anspruch auf diese Patente, Marken, Urheberrechte oder auf sonstiges geistiges Eigentum, es sei denn, dies wird ausdrücklich in den schriftlichen Lizenzverträgen von Microsoft eingeräumt.

© 2006 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, Windows, Windows NT, Windows Server, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System und WinFX sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

SAP NetWeaver ist eine eingetragene Marke der SAP AG in Deutschland und/oder anderen Ländern.

Alle anderen Marken sind Eigentum ihrer jeweiligen Inhaber.

Dokumentationsrichtlinie für den Support von und die Aktualisierung auf SQL Server 2005

Die in der Dokumentation von SQL Server 2005 angezeigten Inhalte werden nur nach gründlichem Testen veröffentlicht. Die Produktdokumentation, bestehend aus der SQL Server-Onlinedokumentation, den Infodateien, Dokumenten zu bekannten Problemen und Knowledge Base-Artikeln, enthält Inhalte zu Features und zur Funktionalität von SQL Server, die so zuverlässig und sicher für den allgemeinen Einsatz bei jedem Kunden ist. Diese Richtlinie gilt für die gesamte SQL Server-Dokumentation, einschließlich der Infodateien zu Versionen und Service Packs. Eine Infodatei wird als Erweiterung der Onlinedokumentation betrachtet.

In einigen Fällen dürfen bestimmte Features nicht direkt vom Kunden verwendet werden und sind daher nicht dokumentiert. Dokumentationen und Websiteinhalte von Drittanbietern werden von Microsoft-Kundenservice und -Support nicht unterstützt und sollten in Produktionsdatenbanken oder -anwendungen nicht verwendet werden, es sei denn, ein solches Feature wird in der von Microsoft veröffentlichten SQL Server-Dokumentation näher erläutert.

Nicht dokumentierte APIs dürfen von Kunden nicht verwendet werden. Gleiches gilt auch für die folgenden und weitere hier nicht genannten Elemente: gespeicherte Prozeduren, erweiterte gespeicherte Prozeduren, Funktionen, Sichten, Tabellen, Spalten, Eigenschaften oder Metadaten. Der Microsoft-Kundenservice und -Support unterstützt keine Datenbanken oder Anwendungen, die nicht dokumentierte Einstiegspunkte nutzen.

Für Server- und Datenbankaktualisierungen auf zukünftige Versionen von SQL Server für Anwendungen und Datenbanken, die nicht dokumentierte Einstiegspunkte nutzen und verwenden, wird keine Gewährleistung übernommen. Es dürfen nur solche SQL Server-Features verwendet werden, die in der Dokumentation von Microsoft SQL Server enthalten sind. Wenn ein Feature in der Microsoft SQL Server-Dokumentation nicht dokumentiert ist, handelt es sich um einen nicht unterstützten Teil von SQL Server.


Setup-Benutzeroberfläche (Hotfix)

Setup-Benutzeroberfläche (Hotfix)

In den folgenden Themen werden zusätzliche Informationen zu Entscheidungen beim Installieren von SQL Server 2005 SP2 zur Verfügung gestellt. Klicken Sie zum Anzeigen eines Hilfethemas auf den entsprechenden Link:

Lizenzbedingungen (Hotfix)

Featureauswahl (Hotfix)

Authentifizierungsmodus (Hotfix)

Remoteauthentifizierung (Hotfix)

Einstellungen zur Fehler- und Verwendungsberichterstellung (Hotfix)

Ausführen der Prozesse (Hotfix)

Installationsbereit (Hotfix)

Installationsvorgang (Hotfix)

Installation abgeschlossen (Hotfix)

Zusätzliche Informationen (Hotfix)


Lizenzbedingungen (Hotfix)

Lizenzbedingungen (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Mithilfe der Seite Lizenzbedingungen (Hotfix) des Installations-Assistenten für SP2 können Sie die Lizenzbedingungen für diese Version akzeptieren.

Optionen

Klicken Sie zum Fortsetzen des SQL Server 2005 SP2-Setups auf das Optionsfeld, mit dem angezeigt wird, dass Sie die Lizenzbedingungen von SQL Server 2005 SP2 akzeptieren. Klicken Sie dann auf Weiter.

Mithilfe der Schaltfläche Drucken können Sie eine Kopie der Lizenzbedingungen für diese Version ausdrucken. Klicken Sie zum Beenden des SQL Server 2005 SP2-Setups auf Abbrechen.


Featureauswahl (Hotfix)

Featureauswahl (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Mit der Seite Featureauswahl (Hotfix) des Installations-Assistenten für SP2 können Sie zu aktualisierende Komponenten und Features von SQL Server auswählen.

Optionen

Klicken Sie auf einen Featurenamen im linken Bereich, und zeigen Sie so die Sprache, das Betriebssystem, die Edition und die Statusdetails an.

Aktivieren Sie zum Aktualisieren einer Komponente oder eines Features das Kontrollkästchen neben dem Featurenamen. Deaktivieren Sie zum Ausschließen einer Komponente oder eines Features von dieser Aktualisierung das Kontrollkästchen neben dem Featurenamen.

Es können mehrere Instanzen von SQL Server 2005 auf einem einzigen Computer zu unterschiedlichen Zeitpunkten aktualisiert werden, allerdings müssen alle Komponenten in einer Instanz von SQL Server gleichzeitig aktualisiert werden. Alle freigegebenen Komponenten, beispielsweise Arbeitsstationskomponenten, MSXML Parser, SQLXML, Abwärtskompatibilitätskomponenten und VSS Writer müssen auf SQL Server 2005 SP2 aktualisiert werden.

Wenn eine Komponente nicht aktualisiert werden kann, wird eine Erläuterung im Bereich Details zur Verfügung gestellt.


Authentifizierungsmodus (Hotfix)

Authentifizierungsmodus (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Verwenden Sie die Seite Authentifizierungsmodus (Hotfix) des Installations-Assistenten für SP2, um Instanz- und Authentifizierungsinformationen bereitzustellen, die vom Setup zum Herstellen von Verbindungen mit den Instanzen von SQL Server verwendet werden, die Sie aktualisieren möchten.

Optionen

Aktivieren Sie das Kontrollkästchen zum Anwenden der Auswahl für alle Instanzen, wenn Authentifizierungsmodus, Benutzername und Kennwort für alle zu aktualisierenden Komponenten oder Instanzen identisch sind. Wenn Sie diese Option auswählen, wird die Dropdownliste Instanzname deaktiviert. Stellen Sie den Authentifizierungstyp, den Benutzernamen und die Kennwortinformationen bereit, und klicken Sie dann auf Test, um die Anmeldeinformationen zu überprüfen.

Stellen Sie den Instanznamen, den Authentifizierungstyp, den Benutzernamen und die Kennwortinformationen für jede zu aktualisierende Komponente oder Instanz bereit, wenn der Authentifizierungsmodus, Benutzername und das Kennwort nicht für alle zu aktualisierenden Komponenten identisch sind. Klicken Sie dann auf Test, um die Anmeldeinformationen zu überprüfen.

Während die Anmeldeinformationen für jede Komponente oder für jede Instanz von SQL Server geprüft werden, wird die Statustabelle mit Ergebnissen aufgefüllt. Klicken Sie auf Weiter, um den Vorgang fortzusetzen, wenn alle Komponenten in der Tabelle aufgeführt werden und angezeigt wird, dass die Überprüfung erfolgreich war. Sie müssen alle Authentifizierungsprobleme lösen, bevor Sie den Vorgang fortsetzen.

Aktualisieren Sie die Informationen für die Komponente, wenn bei der Authentifizierung ein Fehler auftritt, und führen Sie dann den Überprüfungstest erneut aus. Wenn alle Komponenten in der Tabelle aufgeführt werden und angezeigt wird, dass die Überprüfung erfolgreich war, klicken Sie auf Weiter, um den Vorgang fortzusetzen.


Remoteauthentifizierung (Hotfix)

Remoteauthentifizierung (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Mit der Seite Remoteauthentifizierung (Hotfix) des Installations-Assistenten für SP2 können Sie Remoteanmeldeinformationen für zu aktualisierende Failoverclusterinstanzen von SQL Server zur Verfügung stellen.

Optionen

Benutzername

Das Anmeldefeld wird nicht vorab ausgefüllt. Geben Sie einen Benutzernamen für ein gültiges Administratorkonto für alle Knoten des Failoverclusters an.

Kennwort

Geben Sie ein Kennwort für das ausgewählte Administratorkonto an.

Domäne

Geben Sie den Domänennamen für das ausgewählte Administratorkonto an.


Einstellungen zur Fehler- und Verwendungsberichterstellung (Hotfix)

Einstellungen zur Fehler- und Verwendungsberichterstellung (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Verwenden Sie die Seite Einstellungen zur Fehler- und Verwendungsberichterstellung (Hotfix) des Installations-Assistenten für SP2, um die Funktionalität für Fehler- und Verwendungsberichterstellung von SQL Server 2005 zu aktivieren.

Optionen

SQL Server SP2 enthält die Option zum Konfigurieren von SQL Server für das automatische Senden von Berichten über schwerwiegende Dienstfehler an Microsoft oder an einen Firmen-Fehlerberichtsserver. Sie können beide oder eine der Optionen deaktivieren, indem Sie die Kontrollkästchen auf dieser Seite deaktivieren. Microsoft verwendet Fehlerberichte, um die Funktionalität von SQL Server zu verbessern, und behandelt alle Daten zu Fehlerberichterstellung und Featureverwendung vertraulich.

Fehlerberichterstellung

Wenn Sie das Feature Fehlerberichterstellung aktivieren, wird SQL Server so konfiguriert, dass automatisch ein Bericht an Microsoft gesendet wird, sobald ein schwerwiegender Fehler in einer der folgenden SQL Server-Komponenten auftritt:

  • Database Engine (Datenbankmodul)

  • SQL Server-Agent

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Replikation

Microsoft verwendet Fehlerberichte, um die SQL Server-Funktionalität zu verbessern, und behandelt alle Informationen vertraulich.

Informationen zu Fehlern werden über eine sichere Verbindung (https) an Microsoft gesendet, wo sie mit eingeschränkten Zugriffsrechten gespeichert werden. Alternativ dazu können Sie die Fehlerberichte auch an Ihren Firmen-Fehlerberichtsserver senden. Weitere Informationen zum Einrichten eines Firmen-Fehlerberichtsservers finden Sie auf der Microsoft-Website zur Firmen-Fehlerberichterstellung (möglicherweise in englischer Sprache).

Fehlerberichte enthalten folgende Informationen:

  • Zustand von SQL Server beim Auftreten des Problems.

  • Version des Betriebssystems und Computerhardwareinformationen.

  • Ihre digitale Product ID, die nicht zum Identifizieren Ihrer Lizenz verwendet wird.

  • Die Netzwerk-IP-Adresse des Computers oder Proxyservers.

  • Informationen aus dem Arbeitsspeicher oder aus Dateien, die dem Prozess zugeordnet sind, der den Fehler verursacht hat.

Microsoft verfolgt nicht die Absicht, Dateien, Namen, Adresse, E-Mail-Adresse oder andere persönliche Daten von Ihnen zu erfassen. Der Fehlerbericht kann jedoch persönliche Informationen aus dem Arbeitsspeicher oder aus Dateien, die dem Prozess zugeordnet sind, der den Fehler verursacht hat, enthalten. Mithilfe dieser Daten ist es möglich, Ihre Identität zu bestimmen. Microsoft verwendet diese Daten jedoch nicht zu diesem Zweck.

Informationen zu den Datenschutz- und Datensammlungsrichtlinien für finden Sie in den Datenschutzbestimmungen für SQL Server 2005 (möglicherweise in englischer Sprache).

Wenn Sie die Fehlerberichterstellung aktivieren und ein schwerwiegender Fehler auftritt, wird u. U. im Windows-Ereignisprotokoll eine Antwort von Microsoft angezeigt, die auf einen Microsoft Knowledge Base-Artikel zu einem bestimmten Fehler verweist.

Um nach Abschluss des Setups die Fehler- oder Featureverwendungs-Berichterstellung für alle Instanzen von SQL Server und die dazugehörigen Komponenten zu deaktivieren, wechseln Sie zum Dialogfeld Einstellungen für Fehler- und Verwendungsberichte - Start : Alle Programme : Microsoft SQL Server 2005 : Konfigurationstools : Fehler- und Verwendungsberichterstellung von SQL Server - und deaktivieren Sie die Kontrollkästchen für Featureverwendung. Wenn die Fehlerberichterstellung für mehrere Komponenten von SQL Server aktiviert ist (Database Engine (Datenbankmodul), Analysis Server, Reporting Server und freigegebene Komponenten), können Sie die Fehlerberichterstellung für jede Instanz einer einzelnen Komponente deaktivieren. Sie können die Fehlerberichterstellung auch für freigegebene Komponenten deaktivieren, die als Sonstige aufgeführt sind.

Featureverwendung

Wenn Sie die Berichterstellung für die Featureverwendung aktivieren, wird SQL Server so konfiguriert, dass in regelmäßigen Abständen ein Bericht an Microsoft gesendet wird. Die Berichte beinhalten Informationen zur Hardwarekonfiguration und zum Verwenden der SQL Server 2005-Software und -Dienste. Microsoft verwendet die Featureverwendungsdaten, um SQL Server weiter zu verbessern. Zu den durch dieses Feature überwachten SQL Server 2005-Komponenten gehören:

  • Database Engine (Datenbankmodul)

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Replikation

  • Business Intelligence Development Studio

Informationen zur Featureverwendung werden an Microsoft gesendet und dort mit eingeschränktem Zugriff gespeichert.

Um nach Abschluss des Setups die Featureverwendungs-Berichterstellung zu deaktivieren, verwenden Sie das Tool Fehler- und Verwendungsberichterstellung von SQL Server im SQL Server 2005-Menü Konfigurationstools.

Die Informationen werden für die aktivierten Instanzen von SQL Server einmal pro Tag gesammelt. Der Zeitpunkt der Erfassung ist standardmäßig Mitternacht, um die Belastung des Servers zu minimieren. Wenn Sie die Uhrzeit ändern möchten, können Sie den Registrierungsschlüssel, in dem die Uhrzeit festgelegt ist, manuell ändern. Jede Instanz von SQL Server hat ihren eigenen Registrierungsschlüssel. Das folgende Beispiel bezieht sich auf die erste auf dem Server installierte Instanz von SQL Server (MSSQL.1):

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

Der Wert dieses Registrierungsschlüssels enthält den Zeitpunkt der Informationssammlung, der durch die Anzahl der Minuten nach 00:00 (Mitternacht) ausgedrückt wird. Bei einem Wert von 60 würde die Erfassung also beispielsweise um 1:00 Uhr ausgeführt werden, und bei einem Wert von 1200 um 8:00 Uhr.


Ausführen der Prozesse (Hotfix)

Ausführen der Prozesse (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Verwenden Sie zum Vermeiden eines Neustarts von Windows nach dem Installieren von SP2 die Seite Ausführen der Prozesse (Hotfix) des Installations-Assistenten für SQL Server 2005 SP2 zum Identifizieren von Vorgängen, die von SQL Server 2005 SP2-Setup benötigte Dateien blockieren.

Beenden Sie alle Anwendungen und Dienste, die Verbindungen mit den aktualisierten Instanzen von SQL Server herstellen. Dazu gehört das Beenden von SQL Server Management Studio und Business Intelligence Development Studio, sowie das Schließen der Systemsteuerung und der Option Software vor dem Installieren von SQL Server 2005 SP2.

  • Damit der Computer nach der SP2-Installation nicht neu gestartet werden muss, zeigt das Setup eine Liste der Prozesse an, die Dateien sperren. Wenn das SP2-Setupprogramm einen Dienst während der Installation beenden muss, wird der Dienst nach Abschluss der Installation neu gestartet.

  • Wenn vom Setup bestimmt wird, dass Dateien während der Installation blockiert werden müssen, müssen Sie den Computer möglicherweise nach dem Fertigstellen der SP2-Installation erneut starten. Gegebenenfalls werden Sie aufgefordert, den Computer neu zu starten.

Optionen

Wenn blockierte Dateien entdeckt werden, werden diese in der Tabelle aufgeführt. Beenden Sie alle Vorgänge und Anwendungen in der Liste, und klicken Sie dann zum erneuten Ausführen der Überprüfung auf Aktualisieren. Klicken Sie zum Beenden einer gerade ausgeführten Überprüfung auf Beenden. Wenn keine blockierten Dateien gefunden wurden, ist die Tabelle leer.

Klicken Sie auf Weiter, um den Vorgang fortzusetzen, wenn alle blockierenden Vorgänge beendet sind.

Installieren von SQL Server 2005 SP2 in einer Failoverclusterinstanz

Beachten Sie die folgenden Informationen, bevor Sie SQL Server 2005 SP2 in einer Failoverclusterinstanz installieren:

  • Beenden Sie den Clusterdienst nicht, bevor Sie das SP2-Setupprogramm ausführen oder während das Installationsprogramm ausgeführt wird.

  • Beenden Sie keine ausgeführten Prozesse vor dem Ausführen des SP2-Setupprogramms.

  • Nehmen Sie den SQL Server-Dienst nicht offline, bevor Sie das SP2-Setupprogramm ausführen. Das SP2-Setupprogramm beendet und startet den SQL Server-Dienst.

  • Führen Sie das SP2-Setupprogramm auf dem primären Knoten der Failoverclusterinstanz aus.

  • Sie müssen alle Failoverclusterknoten nach der Installation von SP2 erneut starten.

  • Paralleles Update wird für SP2 nicht unterstützt.


Installationsbereit (Hotfix)

Installationsbereit (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Auf der Seite Installationsbereit (Hotfix) wird vom Installations-Assistenten für SP2 angezeigt, dass das SQL Server 2005 SP2-Setup über die zum Installieren der Aktualisierung erforderlichen Informationen verfügt.

Optionen

Klicken Sie zum Überprüfen oder Ändern der SQL Server 2005 SP2-Installationsoptionen auf Zurück. Klicken Sie zum Fortsetzen auf Installieren.


Installationsvorgang (Hotfix)

Installationsvorgang (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Mit der Seite Installationsvorgang (Hotfix) des Installations-Assistenten für SP2 können Sie das Setup beim Anwenden von SQL Server 2005 SP2 auf die SQL Server-Komponenten und -Instanzen überwachen.

Optionen

In der Tabelle werden der Produktname von SQL Server, dessen Instanznamen und der Installationsstatus zur Verfügung gestellt.


Installation abgeschlossen (Hotfix)

Installation abgeschlossen (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Auf der Seite Installation abgeschlossen (Hotfix) im Installations-Assistent für SP2 wird der Status jeder Komponente angezeigt, mit der SQL Server 2005 SP2 aktualisiert wird.

Optionen

Klicken Sie zum Anzeigen eines zusammenfassenden Installationsprotokolls von SQL Server 2005 SP2 auf Zusammenfassung anzeigen. Die zusammenfassende Protokolldatei wird in C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\ gespeichert.

Klicken Sie zum Anzeigen eines Pfades für eine Protokolldatei auf den Komponentenamen. Wenn Sie beispielsweise auf SQL Server Native Client klicken, wird im Detailbereich der Pfad für die Protokolldatei angezeigt: C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log.


Zusätzliche Informationen (Hotfix)

Zusätzliche Informationen (Hotfix)
Setup-Benutzeroberfläche (Hotfix) >

Aktualisiert: 12. Dezember 2006

Die Seite Zusätzliche Informationen (Hotfix) des SP2-Installations-Assistenten enthält ein Kontrollkästchen zum Öffnen des Bereitstellungstools von SQL Server 2005 für Benutzer von Windows Vista. Verwenden Sie das Bereitstellungstool, um die Benutzerliste in der Systemadministratorrolle für SQL Server zu aktualisieren.

Benutzerkontensteuerung (User Account Control, UAC), auch als Benutzerkontoschutz (User Account Protection, UAP) oder Benutzerkonten mit eingeschränkten Rechten (Limited User Accounts, LUA) bezeichnet, ist ein neues Sicherheitsfeature von Windows Vista. Damit können Benutzer allgemeine Aufgaben als Nichtadministrator ausführen. Benutzerkonten, die Mitglieder der lokalen Administratorgruppe sind, führen einen Großteil der Anwendungen wie bei Verwendung eines Standardbenutzerkontos aus.

Standardmäßig wird Benutzern unter Windows Vista, die Mitglied der Gruppe der Windows-Administratoren sind, nicht automatisch die Berechtigung zum Herstellen einer Verbindung mit SQL Server gewährt. Außerdem erhalten sie nicht automatisch administrative Anmeldeinformationen. Mitglieder der SQL Server-Systemadministratorrolle können jede beliebige Aktivität innerhalb der Instanz von SQL Server ausführen.

Sie können für Mitgliedern der Gruppe der Administratoren das Anmelden von einem Computer zulassen, auf dem Windows Vista ausgeführt wird, indem Sie das Konto explizit den SQL Server-Anmeldungen hinzufügen.

Optionen

Zum Aktualisieren der Benutzerliste in der Systemadministratorrolle für SQL Server verwenden Sie das Kontrollkästchen zum Starten des Bereitstellungstools von SQL Server 2005 für Benutzer von Windows Vista.

Stellen Sie sicher, dass im Feld Bereitstellung für Benutzer die Angaben zu Domänenname\Benutzername des Benutzers aufgeführt sind, dessen Berechtigungen aktualisiert werden sollen. Wählen Sie aus der Liste der SQL Server-Instanzen im Bereich Verfügbare Privilegien die zu aktualisierende Rolle aus, und klicken Sie dann auf den Pfeil nach rechts. Wenn Sie den Benutzer allen verfügbaren Rollen für alle verfügbaren SQL Server-Instanzen hinzufügen möchten, doppelklicken Sie auf den Pfeil nach rechts.

Im Bereich auf der rechten Seite werden die Angaben zu Domänenname\Benutzername des Benutzers aufgeführt, dessen Berechtigungen aktualisiert werden, zudem die SQL Server-Instanzen und die Rollen, denen der Benutzer hinzugefügt wird.

Wenn Sie eine Rolle aus dem rechten Bereich entfernen möchten, markieren Sie diese, und klicken Sie dann auf den Pfeil nach links. Sie können alle Rollen aus dem rechten Bereich entfernen, indem Sie auf den doppelten Pfeil nach links klicken. Beachten Sie, dass Änderungen mit dem Pfeil nach links nur die im Tool angezeigten Benutzer, Rollen und Berechtigungen betreffen. Das Tool bietet keine Funktion zum Aufheben von Berechtigungen. Wenn Sie Berechtigungen für einen Benutzer aufheben möchten, muss ein Administrator die Anmeldeinformationen des Benutzers manuell aktualisieren oder entfernen.

Klicken Sie zum Implementieren der Änderungen nach Abschluss der Auswahl auf OK. Klicken Sie auf Abbrechen, wenn Sie das Tool beenden möchten, ohne Änderungen vorzunehmen.

Klicken Sie auf den Link Neuen Administrator hinzufügen des SQL Server 2005-Tools für die SQL Server-Oberflächenkonfiguration (SQLSAC.exe), um nach Beendigung dieses Installationsprogramms auf das Bereitstellungstool von SQL Server 2005 für Benutzer von Windows Vista zuzugreifen.

Die Hyperlinkliste Zusätzliche Informationen (Hotfix) stellt Hyperlinks zu Websites mit zusätzlichen SQL Server-Informationen zur Verfügung. Diese Links enthalten zusätzliche Informationen zum Produktsupport, zu Dokumentationsupdates und zu Optionen von Microsoft Update für SQL Server zu erhalten.