安裝 Service Pack (Hotfix)

Microsoft SQL Server 2005 Service Pack 2
安裝 Service Pack (Hotfix)

您可以將任何已安裝的 SQL Server 2005 元件升級為 SQL Server 2005 SP2。如果現有 SQL Server 2005 元件的版本層級高於 SP2 版本層級，則 SP2 安裝程式會將其排除在升級作業外。

下列考量適用於安裝 SQL Server 2005 SP2 時：

  • 在套用 SQL Server 2005 SP2 之後，如果要將其移除，則必須先解除安裝整個產品。

  • 您必須同時升級屬於 SQL Server 執行個體的所有功能。例如，當升級 Database Services 時，如果 Analysis Services 安裝在同一個 SQL Server 執行個體上，則您也必須升級 Analysis Services。如果未選取功能樹狀目錄中的元件或執行個體，便不會將元件或執行個體升級到 SQL Server 2005 SP2。

  • 可能的話，請盡量使用 Windows 驗證。

  • 在使用 SQL Server 驗證時，為 sa 登入所提供的密碼不能包含雙引號。如果密碼包含雙引號，則在套用 SQL Server 2005 SP2 時，請改用 Windows 驗證而非 SQL Server 驗證，或者在執行 SP2 安裝程式之前，變更 sa 登入密碼。

  • 升級 Reporting Services 執行個體時，安裝程式會連接到報表伺服器，以升級報表伺服器資料庫。如果執行安裝程式的使用者 Windows 帳戶不是報表伺服器中系統管理員 (sysadmin) 固定伺服器角色的成員，您必須提供擁有足夠權限的 SQL Server 登入和密碼。若要這樣做，請在 [驗證模式] 對話方塊中選取 Reporting Services 執行個體，提供擁有所需權限的帳戶認證，再按一下 [確定]。

  • 根據預設，SQL Server 2005 SP2 安裝程式記錄檔會儲存到 %Program Files%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\。

其他文件集

下列來源可取得其他的 SQL Server 2005 SP2 文件集：

  • SQL Server 2005 SP2 讀我檔案。

  • SQL Server 2005 SP2 的 Microsoft 知識庫文件。

磁碟空間需求

若要下載並安裝 SQL Server 2005 SP2，電腦必須至少具備 1.9 GB 的可用磁碟空間。下表說明磁碟空間的使用量：

磁碟使用量 (MB) | 位置 | 類型
50 | SQL Server 2005 安裝目錄 | 永久
1,000 | 系統磁碟機 | 永久
600 | 暫存目錄 | 暫存
250 | 下載位置 | 暫存

完成安裝之後，您可以從您的電腦移除 250 MB 下載封裝，SQL Server 2005 SP2 在安裝後所使用的永久磁碟空間約為 1 GB。

安裝概觀

本節提供 SQL Server 2005 SP2 安裝的概觀，其中包括如何執行下列作業：

  • 準備安裝 SQL Server 2005 SP2

  • 安裝 SQL Server 2005 SP2

  • 重新啟動服務及應用程式

準備安裝 SQL Server 2005 SP2

安裝 SQL Server 2005 SP2 之前，您必須先執行下列動作：

  • 備份 SQL Server 2005 資料庫 - 在安裝 SQL Server 2005 SP2 之前，請先備份 master、msdb 和 model 資料庫。安裝 SQL Server 2005 SP2 會修改這些資料庫，而使其無法與 SQL Server 2005 SP2 之前的版本相容。如果決定要重新安裝 SQL Server 2005 (不含 SP2)，則備份這些資料庫是必要的。

    也必須備份您的使用者資料庫。

重要事項：
將 SP2 套用到在複寫拓撲中執行的 SQL Server 執行個體時，您必須先備份複寫資料庫以及系統資料庫，然後再套用 SP2。

  • 備份 Analysis Services 資料庫、組態檔和儲存機制 - 將 Analysis Services 的執行個體升級至 SP2 之前，應該先備份下列項目：

    • Analysis Services 資料庫。根據預設，這些資料庫會安裝在 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data\。

    • msmdsrv.ini 組態檔中的 Analysis Server 組態設定。根據預設，此檔案位於 C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Config\ 目錄中。

    • (選擇性) 包含 Analysis Services 儲存庫的資料庫。只有在 Analysis Server 已設定成與決策支援物件 (DSO) 程式庫一起使用時，才需要執行此步驟。

附註：
如果備份 Analysis Services 資料庫、組態檔及儲存庫時發生失敗，則無法將 Analysis Services 之已升級的執行個體還原為舊版本。

  • 確認系統資料庫擁有足夠的可用空間 - 如果 master 和 msdb 系統資料庫的自動成長選項未選取，則這些資料庫每個都必須至少擁有 500 KB 的可用空間。若要確認資料庫是否有足夠的空間，請在 master 和 msdb 資料庫上，執行 sp_spaceused 系統預存程序。如果其中一個資料庫的未配置空間少於 500 KB，請增加該資料庫的大小。如需詳細資訊，請參閱《SQL Server 線上叢書》中的＜展開資料庫＞。

  • 確認 SQL Server 2005 服務帳戶未停用且可以啟動 - 如果 MSSQLServer、MSSQLServerOLAPService 和 ReportServer 服務的服務啟動類型都設定為 [停用]，則安裝程式可能會失敗。

    若要確認並啟用服務帳戶：

    1. 在 [控制台] 中，按兩下 [系統管理工具]，然後按兩下 [服務]。

    2. 在清單中尋找 MSSQLServer 服務，並注意 [啟動類型] 的值。

    3. 如果 [啟動類型] 的值是 [停用]，請按兩下服務名稱，然後將 [啟動類型] 變更成 [手動] 或 [自動]。

    4. 針對 MSSQLServerOLAPService 和 ReportServer 服務重複執行步驟 2 和 3，然後按一下 [確定]。

    5. 針對所有已安裝的 SQL Server 執行個體重複執行此程序。

  • 停止服務和應用程式 - 在安裝 SQL Server 2005 SP2 之前，停止所有與正在升級之 SQL Server 執行個體連接的應用程式和服務，包括 SQL Server Management Studio、Business Intelligence Development Studio、[控制台] 和 [新增或移除程式] 等。

附註：
您無法停止容錯移轉叢集環境中的服務。如需詳細資訊，請參閱這個主題稍後的容錯移轉叢集安裝章節。

  • 為了排除在進行 SP2 安裝之後重新啟動電腦的需求，安裝程式會顯示正在鎖定檔案之處理序的清單。如果 SP2 安裝程式必須在安裝時結束某項服務，它會在安裝完成之後重新啟動該服務。

  • 如果安裝程式判斷在安裝時鎖定了檔案，則在 SP2 安裝完成之後可能必須重新啟動電腦。如有必要，安裝程式會提示您重新啟動電腦。

安裝 SQL Server 2005 SP2

本節描述安裝 SQL Server 2005 SP2 期間的安裝程序。

重要事項：
您必須在要安裝 SP2 的電腦上，以具有管理員權限的帳戶來執行 SQL Server 2005 SP2 安裝程式。

啟動 SQL Server 2005 SP2 安裝程式

若要安裝 SQL Server 2005 SP2，請執行可自動解壓縮的封裝檔案 SQLServer2005SP2-KB921896-PPP-LLL.exe，其中 PPP 代表特定的平台，而 LLL 則代表依語言而變更的指示項。

附註：
若要將 SP2 套用至做為容錯移轉叢集一部分的 SQL Server 2005 元件，請參閱容錯移轉叢集安裝的章節。若要以自動執行模式來執行 SP2 安裝程式，請參閱＜從命令提示字元進行安裝 (Hotfix)＞。

容錯移轉叢集的安裝

下列資訊僅適用於做為容錯移轉叢集一部分的 SQL Server 2005 元件。

若要在容錯移轉叢集上安裝 Service Pack：

  1. 若要確保 SQL Server 2005 SP2 會安裝在容錯移轉叢集執行個體的所有節點上，請確認容錯移轉叢集執行個體的所有被動節點上都有執行工作排程器。

  2. 如果已新增的任何資源相依於 SQL Server 資源，則在安裝 SQL Server 2005 SP2 之前，必須先移除那些相依性，或者使其離線。如果您沒有移除這些相依性，則 SP2 安裝作業會迫使那些資源離線。

    附註：
    叢集資源離線的同時，叢集服務也會使所有相依的資源離線。

  3. 從作用中節點 (擁有含有要進行升級之容錯移轉叢集執行個體的群組) 執行 SQL Server 2005 SP2 可執行檔封裝檔案。這會在容錯移轉叢集中的所有節點上，安裝 Service Pack 檔案。您無法從容錯移轉叢集中的任何被動節點安裝 SP2。

  4. 在 SQL Server 2005 SP2 安裝精靈的 [功能選擇] 頁面上，選取準備要升級的容錯移轉叢集執行個體。安裝程式會提示您提供用來連接到叢集中之其他節點的登入認證。

    附註：
    安裝期間，將叢集的所有節點保持在線上狀態。這可確定將升級套用到每個叢集節點。

  5. 如果已在步驟 1 移除相依性或使資源離線，請還原相依性，或使資源回復線上狀態。

    附註：
    安裝程式可能需要您重新啟動容錯移轉叢集節點。此重新啟動作業會取代安裝期間所使用的檔案。
重建 SQL Server 2005 SP2 容錯移轉叢集節點

套用 SP2 之後，如果您必須重建容錯移轉叢集中的節點，請執行下列步驟：

  1. 重建容錯移轉叢集中的節點。如需有關重建節點的詳細資訊，請參閱《SQL Server 線上叢書》中的＜如何：從狀況 1 中的容錯移轉叢集失敗進行還原＞。

  2. 執行原始的 SQL Server 2005 安裝程式，以將節點還原到容錯移轉叢集。

  3. 在您已加入的節點上執行 SQL Server 2005 SP2 安裝程式。

重新啟動服務及應用程式

安裝程式完成時，系統會提示您重新啟動電腦。在系統重新啟動或在安裝程式完成 (但未要求重新啟動電腦) 之後，使用 [控制台] 中的 [服務] 節點來重新啟動在套用 SQL Server 2005 SP2 之前所停止的服務。

這包括分散式交易協調器及 Microsoft Search 等服務，或執行個體特定的對等服務。重新啟動在執行 SQL Server 2005 SP2 安裝程式之前所關閉的應用程式。您可能還想在安裝成功完成之後，立即為已升級的 master、msdb 和 model 資料庫進行另一次備份。


從命令提示字元進行安裝 (Hotfix)

從命令提示字元進行安裝 (Hotfix)

在繼續之前，請檢閱＜安裝 Service Pack (Hotfix)＞中的安裝考量。

SQL Server 2005 SP2 的自動安裝支援下列命令提示字元參數。測試及修改安裝指令碼，以符合組織的需求。

重要事項：
可能的話，請在執行階段提供安全性認證。如果您將認證儲存在指令碼檔案中，必須保護該檔案免於未經授權的存取。

參數

描述

/?

顯示自動安裝命令提示字元說明。

/allinstances

將 SQL Server 2005 SP2 套用至所有的 SQL Server 2005 執行個體以及所有的 SQL Server 2005 共用執行個體非感知元件。

/instancename=InstanceName

將 SQL Server 2005 SP2 套用至名為 InstanceName 的 SQL Server 2005 執行個體以及所有的 SQL Server 2005 共用執行個體非感知元件。

/password=Password

用於連接到遠端容錯移轉叢集節點的使用者帳戶密碼。

/quiet

以自動模式執行 SQL Server 2005 SP2 安裝程式。

/reportonly

僅會執行安裝程式的探索和列舉部分，並顯示一份報表，列舉 SQL Server 2005 的本機執行個體和元件。

附註：
使用此參數時並不會套用 SQL Server 2005 SP2。

/rsupgradedatabaseaccount=rsAccountName

使用 SQL Server 驗證時，指定具有修改報表伺服器資料庫結構描述權限的帳戶。這個參數用於升級 Reporting Services 執行個體之時，而該執行個體包含需要 SQL Server 登入的報表伺服器資料庫。

/rsupgradepassword=rsPassword

指定具有修改遠端報表伺服器資料庫結構描述權限的帳戶密碼。這個參數用於升級 Reporting Services 執行個體之時，而該執行個體包含遠端報表伺服器資料庫。

/rsupgradedatabase

使用參數 /rsupgradedatabase=0 以防止 Reporting Services 資料庫升級

/sapwd=SaLoginPassword

通過 sa 登入的 SQL Server 驗證密碼以執行指令碼。

附註：
請勿逸出 /sapwd 的字元。逸出字元會導致安裝失敗。

/user=Domain\UserName

用於連接到遠端容錯移轉叢集節點的使用者帳戶。


著作權聲明 (Hotfix)

著作權聲明 (Hotfix)

本文件集之內容及其中所含範例應用程式僅供資訊參考之用，本文件集之提供不具有任何明示或暗示的保證。本文件集中的資訊，包括 URL 及其他網際網路網站參考資料，如有變更恕不另行通知。本文件集之使用或因使用本文件集所衍生之一切後果，概由使用者自行承擔所有風險。

本文件集內所含範例的主要目的在於闡釋某個概念，或說明特定陳述或文句之合理使用。多數範例並不包含通常可在完整生產系統中找到的所有程式碼，因為已將某些一般資料驗證及錯誤處理部分移除，以將焦點放在範例中的特定概念或陳述上。這些範例或其中包含的任何原始程式碼並不包含於技術支援的服務範圍之內。

除非另有特別聲明，否則本文件範例所舉之公司、組織、產品、網域名稱、電子郵件地址、人名、地名和事件均屬虛構，並非特定意指任何真實的公司、組織、產品、網域名稱、電子郵件地址、人名、地名和事件。遵守所有適用之著作權法係使用者的責任。在不限制任何依著作權本得享有之權利，未經 Microsoft Corporation 書面許可，貴用戶不得為任何目的使用任何形式或方法 (電子形式、機械形式、影印、記錄或其他方式) 複製或傳送本文件集的任何部分，也不得將本文件集的任何部分儲存或放入檢索系統。

Microsoft 可能擁有本文件集所提及內容中所含之專利權、專利優先權、商標、著作權，或其他智慧財產權。除非 Microsoft 書面授權合約所明示規定者外，提供本文件集並不授與貴用戶上述專利權、商標、著作權或其他智慧財產權。

© 2006 Microsoft Corporation.著作權所有，並保留一切權利。

Microsoft、Windows、Windows NT、Windows Server、Active Directory、ActiveX、BackOffice、bCentral、BizTalk、DirectX、Excel、Hotmail、IntelliSense、J/Direct、Jscript、Microsoft Press、MSDN、MS-DOS、Outlook、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual FoxPro、Visual InterDev、Visual J#、Visual J++、Visual SourceSafe、Visual Studio、Win32、Win32s、Windows Mobile、Windows Server System 和 WinFX 係 Microsoft Corporation 在美國及 (或) 其他國家 (地區) 的註冊商標或商標。

SAP NetWeaver 是 SAP AG 在德國和其他一些國家 (地區) 的註冊商標。

其他所有的商標為各擁有人所有之財產。

SQL Server 2005 支援及升級的文件集原則

SQL Server 文件集中出現的內容是在充分測試之後所發行。產品文件集 (SQL Server 線上叢書、讀我檔案、已知問題文件，以及知識庫文件) 當中包含與 SQL Server 功能相關的內容。而這些功能都是穩固且安全的，可以符合所有客戶一般使用上的需求。此原則適用於所有的 SQL Server 文件集，包括版本及 Service Pack 的讀我檔案，此讀我檔案可視為線上叢書的延伸部分。

在某些狀況下，特殊功能不是客戶可直接使用的功能，因此不會在文件集中加以說明。除非功能在 Microsoft 發行的 SQL Server 中討論，否則協力廠商的書籍及網站內容不受 Microsoft 客戶支援服務 (CSS) 的支援，並且不得在產品資料庫或應用程式中使用。

客戶不得使用未記載的 API，包括但不限於預存程序、擴充預存程序、函數、檢視、資料表、資料行、屬性或中繼資料。Microsoft 客戶支援服務不支援應用或使用未記載之進入點的資料庫或應用程式。

升級至 SQL Server 未來版本的伺服器或資料庫不保證適用於應用及使用未記載之進入點的應用程式或資料庫。SQL Server 功能的使用僅限於 Microsoft SQL Server 文件集所述者。如果功能未在 Microsoft SQL Server 文件集中記載，則不屬於 SQL Server 的支援部分。


安裝使用者介面 (Hotfix)

安裝使用者介面 (Hotfix)

下列主題提供有關 SQL Server 2005 SP2 安裝階段決策的其他資訊。若要檢視說明主題，請按一下其連結：

授權條款 (Hotfix)

功能選擇 (Hotfix)

驗證模式 (Hotfix)

遠端驗證 (Hotfix)

錯誤和使用方式報告 (Hotfix)

執行中的處理序 (Hotfix)

安裝準備就緒 (Hotfix)

安裝進度 (Hotfix)

安裝完成 (Hotfix)

其他資訊 (Hotfix)


授權條款 (Hotfix)

授權條款 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [授權條款 (Hotfix)] 頁面來接受此版本的授權條款。

選項

若要繼續進行 SQL Server 2005 SP2 安裝程式，必須按一下代表您接受 SQL Server 2005 SP2 授權條款的選項按鈕。接著可以按 [下一步] 繼續。

請使用 [列印] 按鈕來列印此版本的授權條款副本。若要結束 SQL Server 2005 SP2 安裝程式，請按一下 [取消]。


功能選擇 (Hotfix)

功能選擇 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [功能選擇 (Hotfix)] 頁面，來選取要更新的 SQL Server 元件和功能。

選項

按一下左窗格中的功能名稱，以查看語言、作業系統、版本和狀態詳細資料。

若要更新元件或功能，請選取功能名稱旁的核取方塊。若要從此次更新作業中排除元件或功能，請選取功能名稱旁的核取方塊。

單一電腦上的多個 SQL Server 2005 執行個體可以在不同時間更新，但是 SQL Server 執行個體中的所有元件則必須同時升級。所有的共用元件，例如工作站元件、MSXML 剖析器、SQLXML、回溯相容性元件以及 VSS Writer 等，都必須升級為 SQL Server 2005 SP2。

如果元件無法升級，則 [詳細資料] 窗格中會提供說明。


驗證模式 (Hotfix)

驗證模式 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [驗證模式 (Hotfix)] 頁面，來提供安裝程式用來連接到要更新之 SQL Server 執行個體的執行個體和驗證資訊。

選項

如果要更新之所有元件或執行個體的驗證模式、使用者名稱和密碼都是相同的，請選取 [將選取項目套用至所有執行個體] 核取方塊。如果選取此選項，則 [執行個體名稱] 下拉式清單會停用。提供驗證類型、使用者名稱和密碼資訊，然後按一下 [測試] 以確認認證。

如果要更新的所有元件並不全是使用相同的驗證模式、使用者名稱和密碼，則請針對要更新的每個元件或執行個體提供執行個體名稱、驗證類型、使用者名稱和密碼資訊，然後按一下 [測試] 以確認認證。

在測試每個元件或 SQL Server 執行個體的認證時，狀態表格中將會填入結果。當表格中列出所有元件且全部都具有「成功」狀態時，請按 [下一步] 繼續。您必須先解決所有的驗證問題，才能繼續作業。

如果驗證失敗，請更新該元件的資訊，然後重試驗證測試。當表格中列出所有元件且全部都具有「成功」狀態時，請按 [下一步] 繼續。


遠端驗證 (Hotfix)

遠端驗證 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [遠端驗證 (Hotfix)] 頁面，來針對要更新的 SQL Server 容錯移轉叢集執行個體提供遠端登入資訊。

選項

使用者名稱

如果登入欄位未預先填入，請指定容錯移轉叢集所有節點之有效管理員帳戶的使用者名稱。

密碼

指定所選取之管理員帳戶的密碼。

網域

指定所選取之管理員帳戶的網域名稱。


錯誤和使用方式報告 (Hotfix)

錯誤和使用方式報告 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [錯誤和使用方式報表 (Hotfix)] 頁面，來啟用 SQL Server 2005 的功能錯誤和使用方式報表功能。

選項

SQL Server SP2 含有將 SQL Server 設定為自動傳送嚴重服務錯誤報表至 Microsoft 或企業錯誤報告伺服器的選項。您可以藉由清除此頁面上的核取方塊來停用其中一個選項或將兩個選項都停用。Microsoft 會使用錯誤報告來改進 SQL Server 功能，並將所有的錯誤報告和功能使用方式資料當做機密資訊。

錯誤報告

如果您啟用錯誤報告功能，萬一下列任何一個 SQL Server 元件發生嚴重錯誤時，SQL Server 將會設定為自動將報告傳送至 Microsoft。

  • Database Engine

  • SQL Server Agent

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 複寫

Microsoft 會使用錯誤報告來改進 SQL Server 功能，並將所有資訊視為機密資訊。

關於錯誤的資訊會透過安全 (https) 連接傳送到 Microsoft (以限制存取的方式予以儲存)。另外，錯誤報告也可以傳送到您自己的企業錯誤報告伺服器。如需有關設定企業錯誤報告伺服器的詳細資訊，請參閱 Microsoft Corporate Error Reporting 網站。

錯誤報告包含下列資訊：

  • 發生問題時的 SQL Server 狀況。

  • 作業系統版本和電腦硬體資訊。

  • 數位產品識別碼，它不是用來識別授權。

  • 電腦或 Proxy 伺服器的網路 IP 位址。

  • 與導致錯誤之處理序相關聯的記憶體或檔案的資訊。

Microsoft 不會刻意收集檔案、名稱、地址、電子郵件地址或任何形式的個人資訊。不過，錯誤報告可包含與導致錯誤之處理序相關聯的記憶體或檔案的個人資訊。雖然這項資訊可能用來判斷您的身分，但 Microsoft 不會將這項資訊用作此用途。

如需有關 隱私權和資料集合原則的詳細資訊，請參閱＜SQL Server 2005 隱私權聲明＞(英文)。

如果您啟用錯誤報告卻發生嚴重錯誤，您會在 Windows 事件記錄檔中看到 Microsoft 的回應，它指向關於特定錯誤的 Microsoft 知識庫文件。

在安裝程式完成之後，若要為 SQL Server 的所有執行個體及其元件停用錯誤或功能使用方式報告，請到 [錯誤和使用方式報表設定] 對話方塊 ([開始] > [所有程式] > [Microsoft SQL Server 2005] > [組態工具] > [SQL Server 錯誤和使用方式報表])，並清除 [功能使用方式] 的核取方塊。如果針對 SQL Server 的多個元件 (Database Engine、Analysis Server、Reporting Server 和共用元件) 啟用錯誤報告，就可以停用每個個別元件執行個體的錯誤報告。您也可以為共用元件 (這些元件會列於 [其他] 中) 停用錯誤報告。

功能使用方式

如果您啟用功能使用方式報告，SQL Server 將會設定為定期將報告傳送至 Microsoft。報告將包含硬體組態及您如何使用 SQL Server 2005 軟體和服務的相關資訊。Microsoft 將會使用功能使用方式資料來改進 SQL Server。這項功能所監視的 SQL Server 2005 元件包括：

  • Database Engine

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • 複寫

  • Business Intelligence Development Studio

關於功能使用方式的資訊將傳送到 Microsoft (以限制存取的方式予以儲存)。

若要在安裝程式完成之後停用功能使用方式報告，請使用 SQL Server 2005 [組態工具] 功能表中的 [SQL Server 錯誤和使用方式報表] 工具。

對於所有已啟用的 SQL Server 執行個體，會一天收集一次資訊。根據預設，收集時間會設在午夜，以將伺服器的負載降至最低。如果您想要變更收集的時間，可以手動編輯控制收集時間的登錄機碼。每個 SQL Server 執行個體都擁有自己的登錄機碼。下列範例是針對安裝於伺服器 (MSSQL.1) 上的第一個 SQL Server 執行個體來說明：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

這個登錄機碼的值包含從 00:00 (午夜) 開始執行的收集時間之分鐘數。例如，60 這個值會在 1:00 a.m. 執行收集，1200 這個值則會在 8:00 p.m. 執行收集。


執行中的處理序 (Hotfix)

執行中的處理序 (Hotfix)
安裝使用者介面 (Hotfix) >

若要避免在安裝 SP2 之後重新啟動 Windows，請使用 SQL Server 2005 SP2 安裝精靈的 [執行中的處理序 (Hotfix)] 頁面來識別正在鎖定 SQL Server 2005 SP2 安裝程式所需之檔案的處理序。

停止所有連接到正在升級之 SQL Server 執行個體的應用程式和服務。這包括停止 SQL Server Management Studio 和 Business Intelligence Development Studio，並在安裝 SQL Server 2005 SP2 之前關閉 [控制台] 和 [新增或移除程式]。

  • 為了排除在進行 SP2 安裝之後重新啟動電腦的需求，安裝程式會顯示正在鎖定檔案之處理序的清單。如果 SP2 安裝程式必須在安裝時結束某項服務，它會在安裝完成之後重新啟動該服務。

  • 如果安裝程式判斷在安裝時鎖定了檔案，則在 SP2 安裝完成之後可能必須重新啟動電腦。如有必要，安裝程式會提示您重新啟動電腦。

選項

如果安裝程式偵測到鎖定的檔案，則表格中會列出這些檔案。停止或結束清單中的處理序和應用程式，然後按一下 [重新整理] 以重新執行檢查作業。按一下 [停止] 以結束正在執行的檢查作業。如果找不到鎖定的檔案，表格會是空的。

當所有的鎖定處理序都已關閉時，請按一下 [下一步] 繼續。

在容錯移轉叢集執行個體上安裝 SQL Server 2005 SP2

在容錯移轉叢集執行個體上安裝 SQL Server 2005 SP2 之前，請注意下列資訊：

  • 執行 SP2 安裝程式之前或正在執行安裝程式時，請不要停止叢集服務。

  • 執行 SP2 安裝程式之前，請不要結束任何正在執行的程序。

  • 執行 SP2 安裝程式之前，請不要將 SQL Server 服務離線。SP2 安裝程式會停止 SQL Server 服務再重新啟動。

  • 請在容錯移轉叢集執行個體的主要節點上執行 SP2 安裝程式。

  • 完成安裝 SP2 之後，必須重新啟動所有的容錯移轉叢集節點。

  • SP2 不支援回復升級。


安裝準備就緒 (Hotfix)

安裝準備就緒 (Hotfix)
安裝使用者介面 (Hotfix) >

SP2 安裝精靈的 [安裝準備就緒 (Hotfix)] 頁面代表 SQL Server 2005 SP2 安裝程式具有安裝更新時所需的資訊。

選項

按一下 [上一步]，以檢閱或變更 SQL Server 2005 SP2 安裝選項。若要繼續，請按一下 [安裝]。


安裝進度 (Hotfix)

安裝進度 (Hotfix)
安裝使用者介面 (Hotfix) >

請使用 SP2 安裝精靈的 [安裝進度 (Hotfix)] 頁面，來監視當安裝程式將 SQL Server 2005 SP2 套用至 SQL Server 元件和執行個體時的狀況。

選項

此表格提供 SQL Server 產品名稱、執行個體名稱和安裝狀態。


安裝完成 (Hotfix)

安裝完成 (Hotfix)
安裝使用者介面 (Hotfix) >

SP2 安裝精靈的 [安裝完成 (Hotfix)] 頁面會針對每個更新為 SQL Server 2005 SP2 的元件顯示狀態。

選項

若要檢視 SQL Server 2005 SP2 安裝的摘要記錄，請按一下 [檢視摘要]。摘要記錄檔的儲存位置是 C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\。

若要檢視記錄檔的路徑，請按一下元件名稱。例如，如果按一下 [SQL Server Native Client]，則 [詳細資料] 窗格會顯示記錄檔的路徑：C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_sqlncli.msi.log。


其他資訊 (Hotfix)

其他資訊 (Hotfix)
安裝使用者介面 (Hotfix) >

更新： 2006 年 12 月 12 日

SP2 安裝精靈的 [其他資訊 (Hotfix)] 頁面包含可以開啟 [適用於 Windows Vista 的 SQL Server 2005 使用者佈建工具] 的核取方塊。使用佈建工具可以升級 SQL Server 系統管理員角色中的使用者清單。

使用者帳戶控制 (UAC) 也稱為使用者帳戶保護 (UAP) 或限制使用者帳戶 (LUA)，這是 Windows Vista 的安全性新功能。UAC 可以讓使用者以非系統管理員身分執行一般工作。本機管理員群組成員的使用者帳戶可以執行大多數的應用程式，就像使用標準使用者帳戶一樣。

根據預設，對於 Windows Administrators 群組成員的 Windows Vista 使用者，不會自動授與連接到 SQL Server 的權限。此外，也不會自動授與使用者系統管理認證。SQL Server 系統管理員角色的成員可以在 SQL Server 的執行個體內執行任何活動。

若要讓管理員群組的成員從執行 Windows Vista 的電腦登入，就必須明確地將該帳戶加入至 SQL Server 登入。

選項

如果要更新 SQL Server 系統管理員角色中的使用者清單，請使用核取方塊，啟動 [適用於 Windows Vista 的 SQL Server 2005 使用者佈建工具]。

請確定 [要提供的使用者] 欄位有列出其權限應該更新之使用者的 DomainName\UserName。從 [可用權限] 窗格的 SQL Server 執行個體清單中選取要更新的角色，然後按一下向右鍵。如果要將使用者加入至 SQL Server 執行個體的所有可用執行個體的可用角色，按兩下向右鍵。

右窗格會列出要更新其權限之使用者的 DomainName\UserName，以及要將使用者加入的 SQL Server 執行個體及角色。

若要從右窗格移除角色，請將其選取，然後按一下向左鍵。若要從右窗格移除所有角色，按一下雙向左鍵。請注意，向左鍵功能只會影響工具中所顯示的使用者、角色和權限。工具中並沒有撤銷權限的功能。若要撤銷使用者權限，管理員必須手動更新或移除使用者的認證。

若要在完成選擇時實作變更，按一下 [確定]。若要結束工具而不進行變更，按一下 [取消]。

如果要在安裝程式結束之後存取 [適用於 Microsoft Vista 的 SQL Server 2005 使用者佈建工具]，請按一下 SQL Server 2005 介面組態工具 (SQLSAC.exe) 的 [新增管理員] 連結。

[其他資訊 (Hotfix)] 連結清單會提供有其他 SQL Server 可用資訊的網站。這些連結包括產品支援、文件集更新以及 SQL Server 之 Microsoft Update 選項的相關資訊。